You are not logged in.

#1 2016-01-21 12:40:16

alex4o
Member
Registered: 2016-01-21
Posts: 1

Problem with Pulseaudio

I have a very strange problem with Pulseaudio.  When the profile of the sound card is changed, it would revert back to "Analog Stereo Duplex", which causes sound defects. This ocures only on my integrated audio card however on my gpu with hdmi it stays the same. I dont have any problems when using only ALSA. I tried to launch pulseaudio with -vvvv but wasn't able to find the source of the problem. Here is the log: http://pastebin.com/pRMb5FEB. Sory for my bad english.

Offline

#2 2016-01-22 06:40:16

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,349
Website

Re: Problem with Pulseaudio

Moving to "Multimedia and Games".

Offline

#3 2016-01-26 17:18:12

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: Problem with Pulseaudio

I have an Intel motherboard with only integrated audio - and until very recently there was no issue - now since the latest pulseaudio updates every time I logout or reboot and log back in my audio output is also "reset" to "Analog Stereo Duplex".  I can set it back to the appropriate HDMI output using the pavucontrols but that only "sticks" until the next logout.  Strangely on another identical machine with a different user this problem has not occurred - so I suspect that a setting has been changed at the time I did the pacman updates with pulseaudio included.  I have not been able to find a solution by googling and it would be nice to know what the fix is (it has to be something simple!).

I think it associated with the updates that on my logs are:
[2016-01-23 10:56] [ALPM] upgraded libpulse (7.1-3 -> 8.0-1)
[2016-01-23 10:56] [ALPM] upgraded pulseaudio (7.1-3 -> 8.0-1)
[2016-01-23 10:56] [ALPM] upgraded pulseaudio-gconf (7.1-3 -> 8.0-1)

Edit: In the end I did "rm -fr .config/pulse" as user, and rebooted and this seems to have fixed it, at least for the moment!

Last edited by mcloaked (2016-01-26 17:36:31)


Mike C

Offline

#4 2016-01-30 11:00:49

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: Problem with Pulseaudio

Having thought that this was fixed it turns out that for me it is still a problem - but only on one machine and not on a second one which has exactly the same hardware and same desktop and setup! 

For me if I find that sound is not working then, from the plasma K menu, I have to go to System Settings -> Multimedia then Audio and Video tab - choose Audio Hardware Setup tab - and then select sound card profile as Digital Stereo (HDMI 2) Output and Analog Stereo Input and clock Apply.  If I then run "pactl list sinks" in a terminal I get the output which has the tail end as:

                device.product.name = "7 Series/C210 Series Chipset Family High Definition Audio Controller"
                device.form_factor = "internal"
                device.string = "hdmi:0,1"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "hdmi-stereo-extra1"
                device.profile.description = "Digital Stereo (HDMI 2)"
                device.description = "Built-in Audio Digital Stereo (HDMI 2)"
                alsa.mixer_name = "Intel PantherPoint HDMI"
                alsa.components = "HDA:10ec0892,80862036,00100302 HDA:80862806,80860101,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Ports:
                hdmi-output-1: HDMI / DisplayPort 2 (priority: 5800, available)
        Active Port: hdmi-output-1
        Formats:
                pcm

And sound through the HDMI connection to the speakers on the monitor work fine.

However after a period of time the sound stops working again, and the command "pactl list sinks" in a terminal then shows:

               device.product.name = "7 Series/C210 Series Chipset Family High Definition Audio Controller"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Intel PantherPoint HDMI"
                alsa.components = "HDA:10ec0892,80862036,00100302 HDA:80862806,80860101,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        Ports:
                analog-output-lineout: Line Out (priority: 9900, not available)
                analog-output-speaker: Speakers (priority: 10000)
                analog-output-headphones: Headphones (priority: 9000)
        Active Port: analog-output-speaker
        Formats:
                pcm

If I then go back to the System Settings, and look again at Multimedia then Audio and Video tab - choose Audio Hardware Setup tab, my settings have reverted back to "Analogue Stereo Output".

So it seems that pulseaudio has some kind of timeout for the changed setting and it does not remain permanent despite changing it and applying it in the plasma settings area.  I have also tried changing the setting by right clicking the volume icon in the system tray which then leads to the same GUI and options. But this has the same result.   

If anyone knows about this quirk in pulseaudio, and how to resolve it then it would be much appreciated.  The bizarre thing is that the same setup on a second computer also with the plasma desktop, and with pulseaudio shows no problem and the audio output styas as HDMI and does not reset itself!

Edit:  I have found something that may be relevant in the journal log:

Jan 29 21:35:34 home1 systemsettings5[16487]: Error loading plugin "kcm_pulseaudio" "The shared library was not found."
                                              Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin")
                                              The environment variable QT_PLUGIN_PATH might be not correctly set

and later in the journal:

Jan 30 09:10:23 home1 pulseaudio[685]: E: [pulseaudio] module.c: Module "module-device-manager" should be loaded once at most. Refusing to load.

and later again in the journal:

Jan 30 09:11:03 home1 systemd[517]: pulseaudio.service: Service hold-off time over, scheduling restart.
Jan 30 09:11:03 home1 systemd[517]: Stopped Sound Service.
Jan 30 09:11:03 home1 systemd[517]: Starting Sound Service...
Jan 30 09:11:03 home1 pulseaudio[19809]: W: [pulseaudio] pid.c: Stale PID file, overwriting.
Jan 30 09:11:03 home1 systemd[517]: Started Sound Service.

Does this point to a possible bug in the pulseaudio packages?

Edit: reported upstream at https://bugs.freedesktop.org/show_bug.cgi?id=93946 and the developers have responded pretty quickly and marked this bug as a 9.0 release blocker.  So once I have provided the log files requested in the upstream bug report then hopefully this will lead to a fix that will then be included when 9.0 is released.

Last edited by mcloaked (2016-01-31 16:01:58)


Mike C

Offline

#5 2016-02-05 14:27:39

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: Problem with Pulseaudio

In my case it seems that the nub of the problem is a patch introduced into pulseaudio 8.0 which has an impact when HDMI is selected as the pulseaudio sink for sound, and then the monitor goes into powesave mode - so pulseaudio then sees the sink become unavailable and switches back to the default analog stereo - but when the monitor comes back after moving the mouse or pressing a key on the keyboard then pulse does not re-establish HDMI sound again. In the bug report that I quoted in the previous comment two developers disagree with each other about what to do about this. One says it is a clear regression and the implicated patch should be reverted and the other says the patch gives improvements elsewhere so should not be reverted and disagrees that the new behaviour is even a regression, calling my situation a "corner case"!  Any further additional input on the upstream bug would be useful from other users - particularly supporting the case that the regression should be fixed though it looks like no change at all will be made until pulseaudio version 9.0 is released.

For the moment I have made a workaround based on the comment #5 by Alexander in the referenced upstream report, and edited /etc/pulse/default.pa to comment out the line:

#load-module module-switch-on-port-available

After restarting, now the selected HDMI port remains in place and remains selected after the monitor goes into powersave and later when I come back to the computer and re-activate the HDMI connected monitor sound remains working with no further change.

Last edited by mcloaked (2016-02-05 16:01:49)


Mike C

Offline

Board footer

Powered by FluxBB