You are not logged in.

#1 2016-02-08 09:53:08

Registered: 2008-06-05
Posts: 124

[Solved] ALPS Touchpad - middle click and natural scrolling

I have a AlpsPS/2 ALPS DualPoint TouchPad in a HP ZBook Stdio G3 laptop. This touchpad has two physical buttons (not visible but physically existing).

Using the xf86-input-evdev package and having the synaptics driver installed, the basic functions work correctly. I have two major problems to resolve though:

1. enable middle click:
  I desperately need middle click somehow on my touchpad. Checking with synclient, I have TapButton3 configured but according to evtest, 3-finger taps does not even get recognized.. I would also be happy to achieve middle clicking via eg. clicking to the bottom center of the touchpad but I'm afraid that wouldn't be easy to achieve either.

2. disable natural scrolling:
  Natural scrolling (the OSX-style, which drives me crazy) seems to be turned on by default for two finger scrolling and I can't really get rid of it. I tried to enable/disable it in Gnome (it's disabled by default), alter the value of VertScrollDelta trying to set negative values, etc - no matter what I try, nothing gets changed, the OSX style is there to stay. There's a single exception though: after getting the laptop to suspend and turn it back on, natural scrolling is off!

Anyone can help me out with these? Thanks a lot in advance.

-- EDIT --
Testing some more with evtest, I found something suspicious.. Without getting my laptop suspended, evtest detected events on the "ALP0011:00 044E:120C" device. After resuming from suspend, evtest records no events on this but it does for the device "AlpsPS/2 ALPS DualPoint TouchPad". The complete list of registered input mouse devices is this:

# xinput list
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ ALP0011:00 044E:120C                        id=11    [slave  pointer  (2)]
⎜   ↳ Logitech Anywhere MX                        id=9    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint Stick               id=13    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint TouchPad            id=14    [slave  pointer  (2)]

Blacklisting the i2c_hid module seems to made the ALP0011:00 044E:120C device go away and now Gnome's built-in control for setting/unsetting natural scrolling works just fine. I'm not sure what this device was though as the screen in this laptop is not a touchscreen..

-- EDIT 2 --
Middle clicking is also solved disabling the i2c_hid device made three-finger taps correctly detected on the AlpsPS/2 ALPS DualPoint TouchPad device. Sorry for the noise smile

Last edited by kjozsa (2016-02-08 10:27:32)


Board footer

Powered by FluxBB