You are not logged in.

#1 2016-01-19 11:05:45

Serpente
Member
Registered: 2016-01-19
Posts: 5

[SOLVED] Login flashes console and returns to login screen

Hi,

On the weekend I installed Arch on my laptop for the first time. I have been using Mint for the past few years and decided to make the move.

Things are mostly working fine, but I do have an curious issue.

After the system starts up, it hits the login screen. When I type in my password and hit enter, it flashes the console screen (the one I saw during the boot process) for about a second or two and then returns to the login screen.
It does this several times, but eventually I am able to log in.

Sometimes I have to try 2 times, others a couple of times. I find that if I make several quick attempts, more fail. Whereas, if I make 1 attempt to log in, then wait a few seconds and make another, often the second will succeed.

It's not giving me any errors. Typing the incorrect password will not display the behaviour and instead will give me a failed login notification.

Is there some log that may help troubleshoot what is happening at the login screen?

I have done a full system update and am running the latest KDE plaasma desktop.

The behaviour does not happen on the lock screen.

It almost seems like Arch might be wating on something in the background until I can login successfully.

Any help would be greatly appreciated.

Last edited by Serpente (2016-01-24 01:56:28)

Offline

#2 2016-01-19 11:15:54

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,388
Website

Re: [SOLVED] Login flashes console and returns to login screen

Moving to "Applications and Desktop Environments".

Offline

#3 2016-01-19 12:34:36

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,844
Website

Re: [SOLVED] Login flashes console and returns to login screen

Serpente wrote:

It almost seems like Arch might be wating on something in the background until I can login successfully.

Perhaps.

Have a look at the output of:

systemd-analyze
systemd-analyze blame
systemd-analyze critical-chain

Then compare the times listed with the actual time it takes to get to the console login; if the `systemd-analyze` time is much longer then you may be correct.

Do you have this problem is you use a display manager instead?

Do you have this problem with other desktop environments or simple pure window manager environments?


_0_
__0
000

Offline

#4 2016-01-21 01:47:38

Serpente
Member
Registered: 2016-01-19
Posts: 5

Re: [SOLVED] Login flashes console and returns to login screen

Hi Head_on_a_Stick,

Thanks for the reply. My system doesn't boot to console; it boots straight to the SDDM login. It's at that screen that when I enter my password the gui will disappear for a second, displaying the underlying console, and then it will re-appear.

I was just doing some testing and after a reboot, I was able to log in first try, but after another reboot the behaviour manifested once more.

I checked systemd-analyze, as you suggested, but didn't really find anything hinting to a cause. It reports that the system takes approximately 24s to reach userspace. Timing it manually I get just about 30 seconds from the grub menu to the SDDM login screen.

I checked "last" to see if the login attempts are registered there, but only the successful logins have been logged.

Is there a way to temporarily disable SDDM and login via console? I could very well be an SDDM glitch.

Offline

#5 2016-01-21 02:02:08

Serpente
Member
Registered: 2016-01-19
Posts: 5

Re: [SOLVED] Login flashes console and returns to login screen

Upon further inspection, I found this error in dmesg:

33.082088] sddm-greeter[346]: segfault at 30 ip 00007fcd195c69bf sp 00007ffcb234ff20 error 4 in libKF5CoreAddons.so.5.18.0[7fcd19592000+96000]

Offline

#6 2016-01-21 02:41:09

Docbroke
Member
From: India
Registered: 2015-06-13
Posts: 529

Re: [SOLVED] Login flashes console and returns to login screen

sudo systemctl disable sddm

reboot or logout after running above command.


Arch is home!
i3 rofi w3m mc vim mutt pass
w3m-dmenu

Offline

#7 2016-01-23 12:04:00

Serpente
Member
Registered: 2016-01-19
Posts: 5

Re: [SOLVED] Login flashes console and returns to login screen

Ok,  so disabling SDDM allowed me to log in via console without any issues.

I had a strong feeling that this is an SDDM issue, so I did some searching on the below error that I am getting:

33.082088] sddm-greeter[346]: segfault at 30 ip 00007fcd195c69bf sp 00007ffcb234ff20 error 4 in libKF5CoreAddons.so.5.18.0[7fcd19592000+96000]

I found two threads on the manjaro forum that mention my exact issue:

https://forum.manjaro.org/index.php?topic=29830.0
https://forum.manjaro.org/index.php?topic=29857.0

It seems that the issue is a bug in the Breeze theme. Using another theme works flawlessly. The bug has already been submitted.

Looks like it's just a matter of waiting on a fix. In the mean time, using another theme or using auto-login seem to be the main work arounds.

Thanks everyone for your help and advice.

Offline

#8 2016-01-23 12:21:13

Docbroke
Member
From: India
Registered: 2015-06-13
Posts: 529

Re: [SOLVED] Login flashes console and returns to login screen

Please mark this thread as [solved], by editing your first post.


Arch is home!
i3 rofi w3m mc vim mutt pass
w3m-dmenu

Offline

#9 2016-01-23 17:34:25

chakra-user
Member
Registered: 2010-03-07
Posts: 74

Re: [SOLVED] Login flashes console and returns to login screen

I am facing the same issue. I noticed this issue since I updated around 15-20 days. BTW, I am using oxygen theme and not Breeze workspace theme and yet I get this behaviour. I dont think breeze has anything to do with this since for login breeze has no role to play. I see a log of UserManager stuff on console during those 1-2 sec drops to console and back.

Offline

#10 2016-01-24 01:55:31

Serpente
Member
Registered: 2016-01-19
Posts: 5

Re: [SOLVED] Login flashes console and returns to login screen

Hi Chakra-User,

Workspace theme does not affect the issue. It looks to be caused by using the Breeze Login Screen (SDDM) theme under Startup and Shutdown.
Have a look at what Login Screen theme you are using. I am going to guess that it's Breeze. Try changing to something like Maui and see if you still get the issue.

Offline

#11 2016-01-24 15:46:44

kazimir
Member
Registered: 2012-01-20
Posts: 55

Re: [SOLVED] Login flashes console and returns to login screen

After a little bit of fiddling I found a low tech workaround that works consistently on my laptop: clicking away from the password box then clicking the password box and the login process now works as expected.

Offline

#12 2016-01-25 15:23:36

chakra-user
Member
Registered: 2010-03-07
Posts: 74

Re: [SOLVED] Login flashes console and returns to login screen

Thanks Serpente. Seems changing the Login Theme to non-breeze has worked two times I tried since changing. Definately issue in Breeze Login theme,

Offline

#13 2016-02-01 03:02:21

epsilom
Member
Registered: 2009-04-18
Posts: 29

Re: [SOLVED] Login flashes console and returns to login screen

Based on the last comment on bug reported (https://bugs.kde.org/show_bug.cgi?id=358171) this issue maybe is a intel driver bug, I fixed it (without disable Breeze login theme) set DRI = 3 creating or edit the opcion of the intel driver (/etc/X11/xorg.conf.d/20-intel.conf) with:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "DRI"    "3"
EndSection

Offline

#14 2016-02-10 08:42:02

cedjo
Member
From: Switzerland
Registered: 2015-06-26
Posts: 3
Website

Re: [SOLVED] Login flashes console and returns to login screen

This solution in comment #13 works correctly on my Lenovo S1 Yoga.
Thanks Epsilom

Last edited by cedjo (2016-02-10 08:43:36)

Offline

#15 2016-02-10 11:09:28

jerf
Member
Registered: 2009-06-03
Posts: 29

Re: [SOLVED] Login flashes console and returns to login screen

I have exactly the same problem, but somehow I couldn't manage to enable DRI3 to solve it as suggested. I have a laptop with Intel HD Graphics 4400; fully updated archlinux-x64 (with pf-kernel, but I tried the stock kernel as well and have the same issue, i.e. breeze sddm theme exhibits this bug, and there is no mention of DRI3 in the X11 logs).

Here is my /etc/X11/xorg.conf.d/20-intel.conf :

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "sna"
        Option         "DRI" "3"
EndSection

Here is what X11 log says:

$ cat /var/log/Xorg.0.log
[    14.551] 
X.Org X Server 1.18.0
Release Date: 2015-11-09
[    14.551] X Protocol Version 11, Revision 0
[    14.551] Build Operating System: Linux 4.2.5-1-ARCH x86_64 
[    14.551] Current Operating System: Linux ub 4.4.4-pf #1 SMP PREEMPT Tue Feb 9 20:35:31 CST 2016 x86_64
[    14.551] Kernel command line: BOOT_IMAGE=/vmlinuz-linux-pf root=UUID=0651cbff-60e8-46df-a861-f89b437824d0 rw quiet pcie_aspm=force i915.i915_enable_rc6=7 i915.i915_enable_fbc=1 i915.lvds_downclock=1 acpi_osi=
[    14.551] Build Date: 08 January 2016  05:56:16PM
[    14.551]  
[    14.551] Current version of pixman: 0.34.0
[    14.551]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    14.551] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    14.551] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 10 13:58:56 2016
[    14.551] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    14.551] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    14.551] (==) No Layout section.  Using the first Screen section.
[    14.551] (==) No screen section available. Using defaults.
[    14.551] (**) |-->Screen "Default Screen Section" (0)
[    14.551] (**) |   |-->Monitor "<default monitor>"                                                                                                                                                                                              
[    14.551] (==) No device specified for screen "Default Screen Section".                                                                                                                                                                         
        Using the first device section listed.                                                                                                                                                                                                     
[    14.551] (**) |   |-->Device "card0"                                                                                                                                                                                                           
[    14.551] (**) |   |-->GPUDevice "Intel Graphics"                                                                                                                                                                                               
[    14.551] (==) No monitor specified for screen "Default Screen Section".                                                                                                                                                                        
        Using a default monitor configuration.                                                                                                                                                                                                     
[    14.551] (==) Automatically adding devices                                                                                                                                                                                                     
[    14.551] (==) Automatically enabling devices                                                                                                                                                                                                   
[    14.551] (==) Automatically adding GPU devices                                                                                                                                                                                                 
[    14.551] (==) Max clients allowed: 256, resource mask: 0x1fffff                                                                                                                                                                                
[    14.551] (==) FontPath set to:                                                                                                                                                                                                                 
        /usr/share/fonts/misc/,                                                                                                                                                                                                                    
        /usr/share/fonts/TTF/,                                                                                                                                                                                                                     
        /usr/share/fonts/OTF/,                                                                                                                                                                                                                     
        /usr/share/fonts/Type1/,                                                                                                                                                                                                                   
        /usr/share/fonts/100dpi/,                                                                                                                                                                                                                  
        /usr/share/fonts/75dpi/                                                                                                                                                                                                                    
[    14.551] (==) ModulePath set to "/usr/lib/xorg/modules"                                                                                                                                                                                        
[    14.551] (II) The server relies on udev to provide the list of input devices.                                                                                                                                                                  
        If no devices become available, reconfigure udev or disable AutoAddDevices.                                                                                                                                                                
[    14.551] (II) Loader magic: 0x819d40                                                                                                                                                                                                           
[    14.551] (II) Module ABI versions:
[    14.551]    X.Org ANSI C Emulation: 0.4
[    14.551]    X.Org Video Driver: 20.0
[    14.551]    X.Org XInput driver : 22.1
[    14.551]    X.Org Server Extension : 9.0
[    14.551] (++) using VT number 1

[    14.551] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    14.552] (II) xfree86: Adding drm device (/dev/dri/card0)
[    14.552] (--) PCI:*(0:0:2:0) 8086:0a16:1043:13bd rev 9, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[    14.553] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    14.553] (II) LoadModule: "glx"
[    14.553] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    14.553] (II) Module glx: vendor="X.Org Foundation"
[    14.553]    compiled for 1.18.0, module version = 1.0.0
[    14.553]    ABI class: X.Org Server Extension, version 9.0
[    14.553] (==) AIGLX enabled
[    14.553] (II) LoadModule: "intel"
[    14.553] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    14.554] (II) Module intel: vendor="X.Org Foundation"
[    14.554]    compiled for 1.18.0, module version = 2.99.917
[    14.554]    Module class: X.Org Video Driver
[    14.554]    ABI class: X.Org Video Driver, version 20.0
[    14.554] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    14.554] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    14.554] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    14.554] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    14.554] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20151010
[    14.554] (II) intel(0): SNA compiled from 2.99.917-519-g8229390
[    14.554] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
[    14.554] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[    14.554] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    14.554] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    14.554] (==) intel(0): RGB weight 888
[    14.554] (==) intel(0): Default visual is TrueColor
[    14.554] (**) intel(0): Option "Backlight" "intel_backlight"
[    14.554] (II) intel(0): Output eDP1 has no monitor section
[    14.559] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[    14.559] (II) intel(0): Enabled output eDP1
[    14.559] (II) intel(0): Output DP1 has no monitor section
[    14.559] (II) intel(0): Enabled output DP1
[    14.559] (II) intel(0): Output HDMI1 has no monitor section
[    14.559] (II) intel(0): Enabled output HDMI1
[    14.559] (II) intel(0): Output HDMI2 has no monitor section
[    14.559] (II) intel(0): Enabled output HDMI2
[    14.559] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    14.559] (II) intel(0): Output VIRTUAL1 has no monitor section
[    14.559] (II) intel(0): Enabled output VIRTUAL1
[    14.559] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[    14.559] (==) intel(0): TearFree disabled
[    14.559] (==) intel(0): DPI set to (96, 96)
[    14.559] (II) Loading sub module "dri2"
[    14.559] (II) LoadModule: "dri2"
[    14.559] (II) Module "dri2" already built-in
[    14.559] (II) Loading sub module "present"
[    14.559] (II) LoadModule: "present"
[    14.559] (II) Module "present" already built-in
[    14.559] (==) Depth 24 pixmap format is 32 bpp
[    14.559] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[    14.559] (==) intel(0): Backing store enabled
[    14.559] (==) intel(0): Silken mouse enabled
[    14.559] (II) intel(0): HW Cursor enabled
[    14.559] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    14.559] (==) intel(0): DPMS enabled
[    14.559] (==) intel(0): Display hotplug detection enabled
[    14.559] (II) intel(0): [DRI2] Setup complete
[    14.559] (II) intel(0): [DRI2]   DRI driver: i965
[    14.559] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    14.559] (II) intel(0): direct rendering: DRI2 enabled
[    14.559] (II) intel(0): hardware support for Present enabled
[    14.559] (--) RandR disabled
[    14.568] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    14.568] (II) AIGLX: enabled GLX_ARB_create_context
[    14.568] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    14.568] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[    14.568] (II) AIGLX: enabled GLX_INTEL_swap_event
[    14.568] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    14.568] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    14.568] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    14.568] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    14.568] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[    14.568] (II) AIGLX: Loaded and initialized i965
[    14.568] (II) GLX: Initialized DRI2 GL provider for screen 0
[    14.570] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    14.571] (II) intel(0): Setting screen physical size to 508 x 285
[    14.627] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    14.627] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    14.627] (II) LoadModule: "evdev"
[    14.627] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    14.628] (II) Module evdev: vendor="X.Org Foundation"
[    14.628]    compiled for 1.18.0, module version = 2.10.1
[    14.628]    Module class: X.Org XInput Driver
[    14.628]    ABI class: X.Org XInput driver, version 22.1
[    14.628] (II) Using input driver 'evdev' for 'Power Button'
[    14.628] (**) Power Button: always reports core events
[    14.628] (**) evdev: Power Button: Device: "/dev/input/event2"
[    14.628] (--) evdev: Power Button: Vendor 0 Product 0x1
[    14.628] (--) evdev: Power Button: Found keys
[    14.628] (II) evdev: Power Button: Configuring as keyboard
[    14.628] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    14.628] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    14.628] (**) Option "xkb_rules" "evdev"
[    14.628] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[    14.628] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    14.628] (II) Using input driver 'evdev' for 'Video Bus'
[    14.628] (**) Video Bus: always reports core events
[    14.628] (**) evdev: Video Bus: Device: "/dev/input/event3"
[    14.628] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    14.628] (--) evdev: Video Bus: Found keys
[    14.628] (II) evdev: Video Bus: Configuring as keyboard
[    14.628] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input3/event3"
[    14.628] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    14.628] (**) Option "xkb_rules" "evdev"
[    14.628] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    14.628] (II) No input driver specified, ignoring this device.
[    14.628] (II) This device may have been added with another device file.
[    14.629] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    14.629] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    14.629] (II) Using input driver 'evdev' for 'Sleep Button'
[    14.629] (**) Sleep Button: always reports core events
[    14.629] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[    14.629] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    14.629] (--) evdev: Sleep Button: Found keys
[    14.629] (II) evdev: Sleep Button: Configuring as keyboard
[    14.629] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[    14.629] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[    14.629] (**) Option "xkb_rules" "evdev"
[    14.629] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event9)
[    14.629] (II) No input driver specified, ignoring this device.
[    14.629] (II) This device may have been added with another device file.
[    14.629] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event10)
[    14.629] (II) No input driver specified, ignoring this device.
[    14.629] (II) This device may have been added with another device file.
[    14.630] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event11)
[    14.630] (II) No input driver specified, ignoring this device.
[    14.630] (II) This device may have been added with another device file.
[    14.630] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event5)
[    14.630] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[    14.630] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    14.630] (**) Logitech USB Receiver: always reports core events
[    14.630] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event5"
[    14.681] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52f
[    14.681] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
[    14.681] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[    14.681] (--) evdev: Logitech USB Receiver: Found relative axes
[    14.681] (--) evdev: Logitech USB Receiver: Found x and y relative axes
[    14.681] (II) evdev: Logitech USB Receiver: Configuring as mouse
[    14.681] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[    14.681] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[    14.681] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    14.681] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/0003:046D:C52F.0001/input/input9/event5"
[    14.681] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE, id 9)
[    14.681] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[    14.681] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[    14.681] (**) Logitech USB Receiver: (accel) acceleration profile 0
[    14.681] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[    14.681] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[    14.681] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
[    14.681] (II) No input driver specified, ignoring this device.
[    14.681] (II) This device may have been added with another device file.
[    14.682] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event6)
[    14.682] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[    14.682] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    14.682] (**) Logitech USB Receiver: always reports core events
[    14.682] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event6"
[    14.682] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52f
[    14.682] (--) evdev: Logitech USB Receiver: Found 1 mouse buttons
[    14.682] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[    14.682] (--) evdev: Logitech USB Receiver: Found relative axes
[    14.682] (II) evdev: Logitech USB Receiver: Forcing relative x/y axes to exist.
[    14.682] (--) evdev: Logitech USB Receiver: Found absolute axes
[    14.682] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
[    14.682] (--) evdev: Logitech USB Receiver: Found keys
[    14.682] (II) evdev: Logitech USB Receiver: Configuring as mouse
[    14.682] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[    14.682] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[    14.682] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[    14.682] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    14.682] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1/0003:046D:C52F.0002/input/input10/event6"
[    14.682] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 10)
[    14.682] (**) Option "xkb_rules" "evdev"
[    14.682] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[    14.682] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
[    14.682] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[    14.682] (**) Logitech USB Receiver: (accel) acceleration profile 0
[    14.682] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[    14.682] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[    14.682] (II) config/udev: Adding input device HD WebCam (/dev/input/event15)
[    14.682] (**) HD WebCam: Applying InputClass "evdev keyboard catchall"
[    14.682] (II) Using input driver 'evdev' for 'HD WebCam'
[    14.682] (**) HD WebCam: always reports core events
[    14.682] (**) evdev: HD WebCam: Device: "/dev/input/event15"
[    14.682] (--) evdev: HD WebCam: Vendor 0x1bcf Product 0x2987
[    14.682] (--) evdev: HD WebCam: Found keys
[    14.682] (II) evdev: HD WebCam: Configuring as keyboard
[    14.682] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input22/event15"
[    14.682] (II) XINPUT: Adding extended input device "HD WebCam" (type: KEYBOARD, id 11)
[    14.682] (**) Option "xkb_rules" "evdev"
[    14.683] (II) config/udev: Adding input device Atmel Atmel maXTouch Digitizer (/dev/input/event14)
[    14.683] (**) Atmel Atmel maXTouch Digitizer: Applying InputClass "evdev touchscreen catchall"
[    14.683] (II) Using input driver 'evdev' for 'Atmel Atmel maXTouch Digitizer'
[    14.683] (**) Atmel Atmel maXTouch Digitizer: always reports core events
[    14.683] (**) evdev: Atmel Atmel maXTouch Digitizer: Device: "/dev/input/event14"
[    14.734] (--) evdev: Atmel Atmel maXTouch Digitizer: Vendor 0x3eb Product 0x8a0c
[    14.734] (--) evdev: Atmel Atmel maXTouch Digitizer: Found absolute axes
[    14.734] (--) evdev: Atmel Atmel maXTouch Digitizer: Found absolute multitouch axes
[    14.734] (II) evdev: Atmel Atmel maXTouch Digitizer: No buttons found, faking one.
[    14.734] (--) evdev: Atmel Atmel maXTouch Digitizer: Found x and y absolute axes
[    14.734] (--) evdev: Atmel Atmel maXTouch Digitizer: Found absolute touchscreen
[    14.734] (II) evdev: Atmel Atmel maXTouch Digitizer: Configuring as touchscreen
[    14.734] (**) evdev: Atmel Atmel maXTouch Digitizer: YAxisMapping: buttons 4 and 5
[    14.734] (**) evdev: Atmel Atmel maXTouch Digitizer: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    14.734] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0/0003:03EB:8A0C.0003/input/input21/event14"
[    14.734] (II) XINPUT: Adding extended input device "Atmel Atmel maXTouch Digitizer" (type: TOUCHSCREEN, id 12)
[    14.734] (II) evdev: Atmel Atmel maXTouch Digitizer: initialized for absolute axes.
[    14.734] (**) Atmel Atmel maXTouch Digitizer: (accel) keeping acceleration scheme 1
[    14.734] (**) Atmel Atmel maXTouch Digitizer: (accel) acceleration profile 0
[    14.734] (**) Atmel Atmel maXTouch Digitizer: (accel) acceleration factor: 2.000
[    14.734] (**) Atmel Atmel maXTouch Digitizer: (accel) acceleration threshold: 4
[    14.734] (II) config/udev: Adding input device Atmel Atmel maXTouch Digitizer (/dev/input/mouse2)
[    14.734] (II) No input driver specified, ignoring this device.
[    14.734] (II) This device may have been added with another device file.
[    14.734] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event12)
[    14.734] (II) No input driver specified, ignoring this device.
[    14.734] (II) This device may have been added with another device file.
[    14.735] (II) config/udev: Adding input device Asus WMI hotkeys (/dev/input/event7)
[    14.735] (**) Asus WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    14.735] (II) Using input driver 'evdev' for 'Asus WMI hotkeys'
[    14.735] (**) Asus WMI hotkeys: always reports core events
[    14.735] (**) evdev: Asus WMI hotkeys: Device: "/dev/input/event7"
[    14.735] (--) evdev: Asus WMI hotkeys: Vendor 0 Product 0
[    14.735] (--) evdev: Asus WMI hotkeys: Found keys
[    14.735] (II) evdev: Asus WMI hotkeys: Configuring as keyboard
[    14.735] (**) Option "config_info" "udev:/sys/devices/platform/asus-nb-wmi/input/input11/event7"
[    14.735] (II) XINPUT: Adding extended input device "Asus WMI hotkeys" (type: KEYBOARD, id 13)
[    14.735] (**) Option "xkb_rules" "evdev"
[    14.735] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[    14.735] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    14.735] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    14.735] (**) AT Translated Set 2 keyboard: always reports core events
[    14.735] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event4"
[    14.735] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    14.735] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    14.735] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    14.735] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input4/event4"
[    14.735] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 14)
[    14.735] (**) Option "xkb_rules" "evdev"
[    14.736] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event13)
[    14.736] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
[    14.736] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[    14.736] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[    14.736] (II) LoadModule: "synaptics"
[    14.736] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    14.736] (II) Module synaptics: vendor="X.Org Foundation"
[    14.736]    compiled for 1.18.0, module version = 1.8.3
[    14.736]    Module class: X.Org XInput Driver
[    14.736]    ABI class: X.Org XInput driver, version 22.1
[    14.736] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[    14.736] (**) ETPS/2 Elantech Touchpad: always reports core events
[    14.736] (**) Option "Device" "/dev/input/event13"
[    14.760] (II) synaptics: ETPS/2 Elantech Touchpad: found clickpad property
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 2960 (res 32)
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 1924 (res 32)
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: buttons: left double triple
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[    14.760] (**) Option "TapButton1" "1"
[    14.760] (**) Option "TapButton2" "2"
[    14.760] (**) Option "TapButton3" "3"
[    14.760] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
[    14.760] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[    14.760] (**) ETPS/2 Elantech Touchpad: always reports core events
[    14.772] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input20/event13"
[    14.772] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 15)
[    14.772] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[    14.772] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MaxSpeed is now 1.75
[    14.772] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) AccelFactor is now 0.057
[    14.772] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[    14.772] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
[    14.772] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[    14.772] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[    14.772] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[    14.772] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse1)
[    14.772] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[    14.772] (II) config/udev: Adding input device PC Speaker (/dev/input/event8)
[    14.772] (II) No input driver specified, ignoring this device.
[    14.772] (II) This device may have been added with another device file.
[    16.561] (II) intel(0): EDID vendor "BOE", prod id 1507
[    16.561] (II) intel(0): Printing DDC gathered Modelines:
[    16.561] (II) intel(0): Modeline "1920x1080"x0.0  138.78  1920 1968 2000 2080  1080 1083 1088 1112 +hsync -vsync (66.7 kHz eP)
[    16.848] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable

No mention of DRI3.

Contents of mkinitcpio.conf, just in case:

$ cat /etc/mkinitcpio.conf 
# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="i915 msr"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect block filesystems"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev block filesystems"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev block mdadm encrypt filesystems"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev block lvm2 filesystems"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base consolefont keymap udev autodetect modconf block mdadm_udev filesystems keyboard fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=""

Any ideas on what might be the problem?

Last edited by jerf (2016-02-10 11:16:50)

Offline

#16 2016-02-10 11:58:57

Docbroke
Member
From: India
Registered: 2015-06-13
Posts: 529

Re: [SOLVED] Login flashes console and returns to login screen

please create new thread for new question


Arch is home!
i3 rofi w3m mc vim mutt pass
w3m-dmenu

Offline

Board footer

Powered by FluxBB