You are not logged in.

#1 2016-01-18 23:39:06

zencefil
Member
Registered: 2015-10-20
Posts: 23

Slow MTP transfer with jmtpfs - why?

Hi,

I managed to connect to my Android 4.2 device (Wiko Rainbow) using jmtpfs.

Mounting + accessing the filesystem works fine, I can also browse files in Thunar and copy files to my computer.

However image transfer is suspiciously slow. I'm doing it in the Terminal because Thunar hangs or crashes as soon as I open the image directory.

I checked out the cp process in the Task Manager and it doesn't even seem to be running (displays 0% CPU and 1,9MiB RAM usage).

The images arrive at last but I'm sure this can be improved.

Maybe relevant: unmounting doesn't work as specified in the wiki (with fusermount -u <mountpoint>). It displays "wrong argument".

Any suggestions what I can try / verify?

Thanks!

Last edited by zencefil (2016-01-19 14:05:58)

Offline

#2 2016-01-19 06:34:02

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,391
Website

Re: Slow MTP transfer with jmtpfs - why?

zencefil wrote:

Hi,

I managed to connect to my Android 4.2 device (Wiko Rainbow) using jmtpfs.

Mounting + accessing the filesystem works fine, I can also browse files in Thunar and copy files to my computer.

However image transfer is suspiciously slow. I'm doing it in the Terminal because Thunar hangs or crashes as soon as I open the image directory.

I checked out the cp process in the Task Manager and it doesn't even seem to be running (displays 0% CPU and 1,9MiB RAM usage).

The images arrive at last but I'm sure this can be improved.

Perhaps try contacting the upstream author. Personally, I have had good results with kio-mtp + dolphin.

Maybe relevant: unmounting doesn't work as specified in the wiki (with fusermount -u [devicename]). It displays "wrong argument".

Where does it say "devicename" on the wiki? I can only see

fusermount -u <mountpoint>

Moving to "Applications & Desktop Environments".

Offline

#3 2016-01-19 14:06:50

zencefil
Member
Registered: 2015-10-20
Posts: 23

Re: Slow MTP transfer with jmtpfs - why?

<mountpoint> is what i meant to write - edited.

Offline

#4 2016-01-20 04:59:41

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,391
Website

Re: Slow MTP transfer with jmtpfs - why?

Can you post the output of

df -h

and

findmnt

after you have mounted the mtp device.

Offline

#5 2016-01-20 15:18:39

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,280

Re: Slow MTP transfer with jmtpfs - why?

It has been a while since I've tried the few different options but the one I'm sticking with currently is go-mtpfs-git from the aur. That said linux+mtp+smartphone seems to be a bit of hit and miss and you may have to read the wiki [1] and try the different options until you find one that works.

If you go this route I would suggest that you try the git versions as some problems may have been already fixed or at least might not happen as often.

[1] https://wiki.archlinux.org/index.php/MTP


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#6 2016-01-21 00:21:49

zencefil
Member
Registered: 2015-10-20
Posts: 23

Re: Slow MTP transfer with jmtpfs - why?

outputs after mounting; started filetransfer afterwards and it's still showing the same behaviour.

output of df -h:

[zencefil@tpx301 ~]$ df -h
Dateisystem        Größe Benutzt Verf. Verw% Eingehängt auf
dev                 1,9G       0  1,9G    0% /dev
run                 1,9G    736K  1,9G    1% /run
/dev/sda1            59G     19G   38G   33% /
tmpfs               1,9G    4,0K  1,9G    1% /dev/shm
tmpfs               1,9G       0  1,9G    0% /sys/fs/cgroup
tmpfs               1,9G     24K  1,9G    1% /tmp
/home/zencefil/.Private   59G     19G   38G   33% /home/zencefil
tmpfs               386M     40K  386M    1% /run/user/1001
/dev/sdb1           299G    269G   30G   90% /run/media/zencefil/externalhdd
jmtpfs               33G     11G   22G   33% /home/zencefil/mountpoint
[zencefil@tpx301 ~]$ 

output of findmnt:

[zencefil@tpx301 ~]$ findmnt
TARGET                              SOURCE     FSTYPE  OPTIONS
/                                   /dev/sda1  ext4    rw,relatime,data=ordered
├─/proc                             proc       proc    rw,nosuid,nodev,noexec,re
│ └─/proc/sys/fs/binfmt_misc        systemd-1  autofs  rw,relatime,fd=23,pgrp=1,
├─/sys                              sys        sysfs   rw,nosuid,nodev,noexec,re
│ ├─/sys/kernel/security            securityfs securit rw,nosuid,nodev,noexec,re
│ ├─/sys/fs/cgroup                  tmpfs      tmpfs   ro,nosuid,nodev,noexec,mo
│ │ ├─/sys/fs/cgroup/systemd        cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/blkio          cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/memory         cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/cpu,cpuacct    cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/net_cls        cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/freezer        cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/devices        cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ ├─/sys/fs/cgroup/cpuset         cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ │ └─/sys/fs/cgroup/pids           cgroup     cgroup  rw,nosuid,nodev,noexec,re
│ ├─/sys/fs/pstore                  pstore     pstore  rw,nosuid,nodev,noexec,re
│ ├─/sys/kernel/config              configfs   configf rw,relatime
│ ├─/sys/kernel/debug               debugfs    debugfs rw,relatime
│ └─/sys/fs/fuse/connections        fusectl    fusectl rw,relatime
├─/dev                              dev        devtmpf rw,nosuid,relatime,size=1
│ ├─/dev/shm                        tmpfs      tmpfs   rw,nosuid,nodev
│ ├─/dev/pts                        devpts     devpts  rw,nosuid,noexec,relatime
│ ├─/dev/hugepages                  hugetlbfs  hugetlb rw,relatime
│ └─/dev/mqueue                     mqueue     mqueue  rw,relatime
├─/run                              run        tmpfs   rw,nosuid,nodev,relatime,
│ ├─/run/media/zencefil/externalhdd /dev/sdb1  fuseblk rw,nosuid,nodev,relatime,
│ └─/run/user/1001                  tmpfs      tmpfs   rw,nosuid,nodev,relatime,
│   └─/run/user/1001/gvfs           gvfsd-fuse fuse.gv rw,nosuid,nodev,relatime,
├─/tmp                              tmpfs      tmpfs   rw
└─/home/zencefil                         /home/zencefil/.Private
                                               ecryptf rw,nosuid,nodev,relatime,
  └─/home/zencefil/mountpoint            jmtpfs     fuse.jm rw,nosuid,nodev,relatime,
[zencefil@tpx301 ~]$ 

Offline

#7 2016-01-21 00:23:04

zencefil
Member
Registered: 2015-10-20
Posts: 23

Re: Slow MTP transfer with jmtpfs - why?

@R00KIE : thanks for advice, i'll try if i have to give up on jmtpfs wink

Offline

#8 2016-01-21 04:54:43

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,391
Website

Re: Slow MTP transfer with jmtpfs - why?

Oh, I didn't notice earlier, does this happen only with images? Everything else works fine? If you have an SD card, can you try moving the images there and then copy them to your computer. This way we can tell if the problem is only linked to the internal storage.

Offline

#9 2016-01-21 08:15:39

zencefil
Member
Registered: 2015-10-20
Posts: 23

Re: Slow MTP transfer with jmtpfs - why?

The images are stored on the SD card.
I don't know if it only happens with images - I was convinced the problem is just with large files. Will try with music later.

Offline

#10 2016-01-25 23:03:42

zencefil
Member
Registered: 2015-10-20
Posts: 23

Re: Slow MTP transfer with jmtpfs - why?

I tried copying some mp3 files from the SD card to my computer. It went fine, could even do it through thunar. The files were around 3 MB, twice as big as the average photo stored on my phone.

So can this problem be connected to specific formats - in this case, .jpg?

Edit:
Unmounting properly via fusermount also worked after the music transfer.
However, I got a i/o error after remounting. But this might be connected to other issues with external storage (I experienced the same with a USB stick).

Last edited by zencefil (2016-01-25 23:06:15)

Offline

#11 2016-01-26 00:19:37

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,280

Re: Slow MTP transfer with jmtpfs - why?

You may be on to something, but image files should work fine. The reason I say this is because if you try to transfer (to the phone) a file without extension or with unknown extension it will refuse to receive it without so much as a warning.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#12 2016-02-11 22:26:08

zencefil
Member
Registered: 2015-10-20
Posts: 23

Re: Slow MTP transfer with jmtpfs - why?

I don't understand what you mean.
It's possible to transfer (text) files without extension (no warning but gets transfered).

And "image files should work fine" - but the topic of this post is that they don't?

Offline

#13 2016-02-12 11:12:59

sekret
Member
Registered: 2013-07-22
Posts: 204

Re: Slow MTP transfer with jmtpfs - why?

For me every filetype is slow! I also use jmtpfs, because it's the only one that seems to work here...

But I can also say that in recovery (I run CM13 with TWRP as recovery) mtp is a LOT faster!

Offline

Board footer

Powered by FluxBB