You are not logged in.

#1 2016-01-11 19:23:44

Ecaz
Member
Registered: 2016-01-10
Posts: 4

Loud fans on fresh install. Kernel 4.3.3-2-ARCH

I just installed Arch on my laptop, an old HP ProBook 4510s. Whenever I boot the fans are extremely loud, they either run at 100% or at ~70%.
I tried setting up lm_sensors to see if I could somehow control them but it doesn't recognize my chipset and it doesn't report any fans.
I'm not sure what else to try, I saw an old post that this was an issue in Kernel 3.8-something but it says it has been fixed.

It works fine in Ubuntu and most other distributions unless I put the laptop in sleep mode, in which case the fans goes up to 100% no matter which distro it is.

Sometimes after 30 mins or so the fans go back to normal but that happens very rarely, otherwise I can reboot until they're quiet but I'd rather not spend an hour just rebooting my laptop hoping for the fans to behave normally.
Any advice would be greatly appreciated.

sensors

acpitz-virtual-0
Adapter: Virtual device
temp1:        +16.0°C  (crit = +108.0°C)
temp2:        +33.0°C  (crit = +105.0°C)
temp3:        +35.0°C  (crit = +108.0°C)
temp4:        +35.0°C  (crit = +105.0°C)
temp5:        +20.0°C  (crit = +108.0°C)
temp6:        +75.0°C  (crit = +110.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +33.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +31.0°C  (high = +105.0°C, crit = +105.0°C)

Temp6 is either +90 or +75, if I reboot this instant it will probably change to +90. Even after a cold start it reports +90 or +75.
Most likely not a "real" sensor.

Hardware

Intel(R) Core(TM)2 Duo CPU T6570 @ 2.10GHz
Mobile Intel(R) GM45 Express Chipset
Mobile 4 Series Chipset Integrated Graphics

Offline

#2 2016-01-11 19:35:57

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 246

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

Not sure if it's relevant, but I was wondering if your CPU's are constantly running at maximum speed so the fans are running at full speed to compensate?
https://wiki.archlinux.org/index.php/CP … cy_scaling

On my HP ProBook 450, I have to "intel_pstate=disable" on boot and use acpi-cpufreq

Offline

#3 2016-01-11 19:43:01

Ecaz
Member
Registered: 2016-01-10
Posts: 4

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

I installed cpupower and ran cpupower frequency-info.
This is the output

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1.20 GHz - 2.10 GHz
  available frequency steps: 2.10 GHz, 2.10 GHz, 1.60 GHz, 1.20 GHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 1.20 GHz and 2.10 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.20 GHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes

Seems like it's already using acpi-cpufreq?

Edit
Should I add "intel_pstate=disable"  to the cpupower config? /etc/default/cpupower?

Last edited by Ecaz (2016-01-11 19:45:45)

Offline

#4 2016-01-11 19:45:49

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 246

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

Yes it is and your cpu has ramped down to 1.2GHz, so it can't be that!

and no to your edit (I had to do that as intel_pstate wasn't working properly on my laptop)!

Last edited by paulkerry (2016-01-11 19:47:53)

Offline

#5 2016-01-11 19:48:18

Ecaz
Member
Registered: 2016-01-10
Posts: 4

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

paulkerry wrote:

Yes it is and your cpu has ramped down to 1.2GHz, so it can't be that!

When I first ran the command it was at 2.1GHz, all the other times I ran the command it was at 1.2GHz.
Either way, I rebooted after I installed it and at first it seemed liked it was going to be a loud start but at the login screen the fans slowly slowed down, like its normal behavior.

Don't know if it was a lucky reboot or if having cpupower could have solved it by itself.

Last edited by Ecaz (2016-01-11 19:49:32)

Offline

#6 2016-01-11 20:01:46

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 246

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

Hopefully it's installing cpupower that's sorted it! See how it goes and report back.

Offline

#7 2016-01-14 15:01:51

Ecaz
Member
Registered: 2016-01-10
Posts: 4

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

Hmm, hasn't sorted it completely. It definitely behaves normal more often but there are still times when I have to reboot once or twice because the fans run att 100%.
And if I suspend it the fans goes to 100% when I wake it up.

Any other ideas?

Offline

#8 2016-01-23 23:52:25

dopey68
Member
From: Adelaide, Australia
Registered: 2012-06-21
Posts: 12

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

My HP Compaq 6715b has the same issue since the update to kernel 4.3.3.
I also saw this problem before, possibly with 3.18.
Hopefully it will be resolved again like it was then, and it's not that my hardware is just too old.

Offline

#9 2016-01-24 19:16:50

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 246

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

Have you both tried the lts kernel (pacman -S linux-lts) ?

Offline

#10 2016-01-26 00:34:31

dopey68
Member
From: Adelaide, Australia
Registered: 2012-06-21
Posts: 12

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

I'm sure it would, as its at kernel 4.1.16.
As does downgrading to linux-4.2.3, which is what I did.
linux-4.2.5 had backlight issues for me.

Offline

#11 2016-02-21 11:11:55

teika
Member
From: Japan
Registered: 2011-05-23
Posts: 25
Website

Re: Loud fans on fresh install. Kernel 4.3.3-2-ARCH

Kernel.org may fix it, but I'm not sure if our problems are exactly the same, so let me be pricise:

Official bug report:
https://bugzilla.kernel.org/show_bug.cgi?id=110451

It says that boot fails on HP 6715s with kernel 3.19.0 + ubuntu patches.

My symptoms
With 4.1.17 the system hangs during booting, typically as soon as it goes to initramfs. 4.3.0 boots, but the fan is at its max speed.

Cause and patch
In dmesg, there's a line like this:
---
ACPI BIOS Warning (bug): 32/64X address mismatch in FADT/Pm2ControlBlock: 0x00008800/0x0000000000008100, using 32-bit address (20150410/tbfadt-588)
---
Originally 32-bit address was used, but in the "bad" kernels, 64-bit address is used instead. Reverting to 32-bit address will fix. Such a patch is submitted in the comment #22:
https://bugzilla.kernel.org/show_bug.cgi?id=110451#c22

It works for me too, when applied to 4.1.17. I won't test >= 4.2.

How to help kernel developers
If the above patch works, be sure to compare your acpidump with the submitted one. If the two differ, report yours to the bugzilla, together with your model name. Kernel detects buggy chipsets and apply special workaronds. You should tell them your hardware info in order to receive an automatic fix.

See e.g.
* <kernel source>/arch/x86/kernel/early-quirks.c, and search for "sb600".
* <kernel source>/drivers/acpi/thermal.c, and search for "HP Compaq 6715".
* <kernel source>/drivers/gpu/drm/redeon/redeon_irq_kms.c, and search for "RS690".
They do give fixes for my PC.

Workaround without patching
For 4.1.17, I can boot it with a boot parameter processor.max_cstate=2. You'll lose a bit of power saving, but that's all. It doesn't work for 4.3.0.

Other comments
We have to thank Carl Englund, the original reporter, who undertook the labor of bisecting, and Lv Zheng, a long time developer in ACPI field.

@dopey68:
"Hopefully [...] it's not that my hardware is just too old."
Well, our PCs are indeed old, so there're less chances for fixes these days. Remember that some user actually has to track down the cause, and developers have to devise a fix. But this time two Ubuntu users did dig into the mess. It seems we can still use ours for a few years on.
6715b is almost identical to 6715s, so probably you don't have to report anything.

@Ecaz: I wonder if you could edit the initial post to make a link to my comment here? Thanks for raising the issue.


Easy Shift / Ctrl / AltGr ... hack; save your pinkies, type without drudgery.

Offline

Board footer

Powered by FluxBB