You are not logged in.

#1 2004-02-25 15:43:18

Bobonov
Member
From: Roma - Italy
Registered: 2003-05-07
Posts: 295

Grub configuration.

I finaly decide to give a try to kernel26.
I use grub as boot loader.
My problem is how to have grub read System.map26 when kernel26 is loaded.
I know under lilo there is

map /boot/System.map26

but I didn't find an equivalent under grub...

Offline

#2 2004-02-26 02:09:59

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

Re: Grub configuration.

I've always been lazy and simply had something like
kernel /boot/vmlinuz

and then for the 2.6
kernel /boot/vmlinuz26

I've never had problems ignoring the system map (I probably just jinxed myself, but...)


So, perhaps you can simply ignore that and have the two grub entries point to the two different kernels.

(This is not guaranteed--it's just that it works for me)

Scott

Offline

#3 2004-02-26 08:40:52

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,441

Re: Grub configuration.

Only files you need to boot kernels with grub are:

- the grub stages and menu list
- the kernel image file itself

You may ignore / delete the rest. Those files are created because the package maintainer can not know wether you use lilo or grub. You might have both installed, but only use one. Therefore, the whole package supports both.

If you would create your own kernel, and install grub, you would see the base files needed, they are the ones I told you above.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#4 2004-02-26 15:15:12

Bobonov
Member
From: Roma - Italy
Registered: 2003-05-07
Posts: 295

Re: Grub configuration.

I asked this because hwen I boot via grub kernel 2.6, in kernel log it complain as follow:

Feb 25 11:51:32 localhost kernel: klogd 1.4.1, log source = /proc/kmsg started.
Feb 25 11:51:32 localhost kernel: Inspecting /boot/System.map
Feb 25 11:51:32 localhost kernel: Symbol table has incorrect version number.
Feb 25 11:51:32 localhost kernel: Cannot find map file.
Feb 25 11:51:32 localhost kernel: No module symbols loaded - kernel modules not enabled.
Feb 25 11:51:32 localhost kernel: Linux version 2.6.3 (root@mars) (gcc version 3.3.3) #1 SMP Wed Feb 18 00:08:24 PST 2004

As you ca see it try to load System.map and it find System.map24 from kernel24.
So I tried to simply rename System.map26 to System.map and here is the result:

Feb 25 13:31:54 localhost kernel: klogd 1.4.1, log source = /proc/kmsg started.
Feb 25 13:31:54 localhost kernel: Inspecting /boot/System.map
Feb 25 13:31:54 localhost kernel: Loaded 31967 symbols from /boot/System.map.
Feb 25 13:31:54 localhost kernel: Symbols match kernel version 2.6.3.
Feb 25 13:31:54 localhost kernel: No module symbols loaded - kernel modules not enabled.
Feb 25 13:31:54 localhost kernel: Linux version 2.6.3 (root@mars) (gcc version 3.3.3) #1 SMP Wed Feb 18 00:08:24 PST 2004

So it seem it load System.map so I guess its needed.

Offline

#5 2004-02-26 15:54:03

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,441

Re: Grub configuration.

Your proof is impressing. I wonder why making your own kernel won't create a system.map then... ?
:shock:

http://www.dirac.org/linux/system.map/

I bet when we look inside /usr/src/linux-2.6.3/arch/i386/boot, we'll find a system.map file, waiting for to be copied to /boot. Good to know...


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB