You are not logged in.

#1 2015-01-28 12:36:16

Nektarios
Member
Registered: 2013-02-19
Posts: 75

Konsole is not displaying bold text in bold

I use Konsole with Liberation Mono font and the bold text is not displaying as bold but as normal. I have these settings:

Smooth fonts: ON
Draw intense colors in bold font: OFF

I tried various fonts and neither of them work.

I test with this:

echo "`tput sgr0`this is `tput bold`bold`tput sgr0`"

Anyone know why?

Offline

#2 2015-01-29 14:46:22

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,664

Re: Konsole is not displaying bold text in bold

same here with several other fonts.

"Monospace - normal"  works as intended, haven't found others that work sofar.

Are you using konsole or konsolepart4 ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2015-01-29 15:04:18

Nektarios
Member
Registered: 2013-02-19
Posts: 75

Re: Konsole is not displaying bold text in bold

Here "Monospace - normal" does not work. Maybe because it's only a copy of Consolas, what is your Monospace copy of?

Offline

#4 2015-01-29 15:25:09

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,664

Re: Konsole is not displaying bold text in bold

$ fc-match monospace
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
$

That font comes from ttf-dejavu package.
/etc/fonts/conf.avail/57-dejavu-sans-mono.conf indicates DejaVu does take over everything monospace related.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2015-01-29 18:17:35

Nektarios
Member
Registered: 2013-02-19
Posts: 75

Re: Konsole is not displaying bold text in bold

Well, I tried "DejaVu Sans Mono" "Book" (I had it installed) and not even that works with bolds.

Offline

#6 2015-01-29 21:03:15

Med
Member
Registered: 2011-08-08
Posts: 7

Re: Konsole is not displaying bold text in bold

It looks like it is a small bug. Click on Settings/Edit current profile/Appearance. The option “Draw intense colors in bold font” should be checked. For some reason it is checked but not activated. If you uncheck it and check it again, it works.

Offline

#7 2016-01-19 15:18:04

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,552

Re: Konsole is not displaying bold text in bold

It doesn't for me.
Anybody found a solution?
--edit
i solved by removing a probably bad file:

cat ~/.config/fontconfig/conf.d/10-fix-calibri.conf
<?xml version='1.0'?>
<!-- To fix Calibri font - http://forums.fedoraforum.org/showthread.php?p=1045807#post1045807 -->
<match target="font">
 <edit mode="assign" name="embeddedbitmap">
  <bool>false</bool>
 </edit>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>false</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintnone</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</match>

-Edit2: nope, it still does not work.

Last edited by kokoko3k (2016-01-19 16:43:55)

Offline

#8 2016-03-24 04:03:34

wh00
Member
Registered: 2016-03-24
Posts: 9

Re: Konsole is not displaying bold text in bold

Did anyone ever find the root of the problem? I'm having this same issue.

All fonts exhibit this issue except 'monospace'.
If i manually set the font-style to 'bold' in Konsole, I see bold fonts.
However, when I set the style to 'normal', the font does not bold when directed with:

$ echo -e "text \033[1mbold\033[0m text"

Changing the 'monospace' preference in '/etc/fonts/conf.d/60-latin-free.conf' allows me to use whatever monospace family font I want with bold working, but this seems quite hacky.

  <alias>
    <family>monospace</family>
    <prefer>
      <family>Consolas</family>
      <family>Liberation Mono</family>
      <family>DejaVu Sans Mono</family>
      <family>Nimbus Mono</family>
      <family>Courier</family>
    </prefer>
  </alias>

gnome-terminal also does not have this problem.
I'm using infinality, if that makes a difference.

Last edited by wh00 (2016-03-24 10:25:36)

Offline

#9 2016-03-24 13:21:15

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,552

Re: Konsole is not displaying bold text in bold

Given that your font has a bold style (some fonts are missing it); i noticed that after changing font, restarting konsole is needed for bold to work; this happens with kde 4 and kf5 konsole as well.

Last edited by kokoko3k (2016-03-24 13:21:39)

Offline

#10 2016-03-24 19:27:30

wh00
Member
Registered: 2016-03-24
Posts: 9

Re: Konsole is not displaying bold text in bold

kokoko3k wrote:

Given that your font has a bold style (some fonts are missing it); i noticed that after changing font, restarting konsole is needed for bold to work; this happens with kde 4 and kf5 konsole as well.

Well I'll be darned. That indeed solves the symptoms.

Offline

Board footer

Powered by FluxBB