You are not logged in.

#1 2006-05-05 18:24:07

molinero
Member
From: Copenhagen/Denmark
Registered: 2004-09-19
Posts: 110

wmv - mss2

Hi

I have some wmv files that I would like to watch but neither xine or mplayer wants to play them. Xine tells me that it isn't able to play mss2 files. Does anyone know how to solve this?
I have the win32 codecs installed.
The videos are some homemade pokervideos from pokertips.org

For example I can't play this one:
http://media.pokertips.org/download-vid … 0Sizes.wmv[/code]

Offline

#2 2006-05-05 18:37:43

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: wmv - mss2

it's working fine here. i have mplayer-1.0pre7-6 and codecs-20050412-2 installed via pacman.

perhaps your download was corrupted somehow?

Offline

#3 2006-05-05 19:35:40

molinero
Member
From: Copenhagen/Denmark
Registered: 2004-09-19
Posts: 110

Re: wmv - mss2

Thats strange - I have those packages in the same versions but I still cant play the file. I've downloaded that file and others several times without being able to play them. What could it be?

This is my mplayer output when trying to play the file

MPlayer 1.0pre7try2-4.0.3 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium M Banias (Family: 6, Stepping: 5)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

85 audio & 196 video codecs
Failed to open /dev/rtc: No such file or directory (it should be readable by the user.)
Playing TwoGun - Stack Sizes.wmv.
ASF file format detected.
VIDEO:  [MSS2]  804x632  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 1 ch, s16le, 32.0 kbit/4.54% (ratio: 4006->88200)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:1524384  align:1
StreamCount r=0x0  1  1
Decoder supports the following YUV formats:   
VDec: vo config request - 804 x 632 (preferred csp: Packed YUY2)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using BGRA as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 1 -> 1
SwScaler: reducing / aligning filtersize 9 -> 8

SwScaler: BICUBIC scaler, from BGRA to Planar YV12 using MMX2
VO: [xv] 804x632 => 804x632 Planar YV12
Selected video codec: [wmsdmod] vfm:dmo (Windows Media Screen Codec 2)
==========================================================================
Checking audio filter chain for 44100Hz/1ch/s16le -> 44100Hz/2ch/s16le...
AF_pre: 44100Hz/1ch/s16le
AO: [oss] 44100Hz 2ch s16le (2 bps)
Building audio filter chain for 44100Hz/1ch/s16le -> 44100Hz/2ch/s16le...
Starting playback...
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0


MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

I see some strange things in there but I don't know what they mean.

Offline

#4 2006-05-06 14:48:01

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: wmv - mss2

The original video size is 804 x 632 and you're using Xv? Chances are that the Xv driver of your video card cannot handle it, happens to me too on intel 855. Does it crash with mplayer -vo x11 ?

Offline

#5 2006-05-06 19:30:59

molinero
Member
From: Copenhagen/Denmark
Registered: 2004-09-19
Posts: 110

Re: wmv - mss2

With mplayer -vo x11 the video plays fine   big_smile Thanks man

But what is xv? and why am I using it? I don't recall me changing anything in mplayer.

Offline

#6 2006-05-06 22:09:52

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: wmv - mss2

molinero wrote:

With mplayer -vo x11 the video plays fine   big_smile Thanks man

But what is xv? and why am I using it? I don't recall me changing anything in mplayer.

Xv stands for the XVideo extension. It allows the X server to perform some computationally intensive tasks (scaling of video, colorspace conversions) in the graphics card. The x11 option does all these tasks in software (thus consuming more CPU power). Xv is the default option because the hardware acceleration makes it much faster than x11, but x11 can be fine if you have a powerful CPU or don't scale the video.

It seems that the Xv driver on some cards cannot handle high resolution videos. My card (intel 855) plays DVD content (resolution 720×576) fine, but chokes on 800x600 videos.

Offline

Board footer

Powered by FluxBB