You are not logged in.

#1 2016-04-07 20:09:22

int13h
Member
Registered: 2015-10-06
Posts: 6

Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

Hello,

After upgrading system fonts in the browser became terrible.

The thick , blurred.

This happened after the update packages from testing.


The problem was 'solved' by disabling testing repos.



Some problem in


Packages (54) adwaita-icon-theme-3.20-1  android-tools-6.0.1_r24-1  archlinux-keyring-20160402-1  at-spi2-atk-2.20.0-1  at-spi2-core-2.20.0-1  atk-2.20.0-1
              colord-1.3.2-1  cracklib-2.9.6-1  dconf-0.26.0-1  device-mapper-2.02.149-1  elfutils-0.166-1  firefox-45.0.1-4  fontconfig-2.11.95-1
              glib-networking-2.48.0-1  glib2-2.48.0-1  glibmm-2.48.1-1  gnome-themes-standard-3.20-1  gobject-introspection-runtime-1.48.0-1
              gsettings-desktop-schemas-3.20.0-1  gst-plugins-base-1.8.0-1  gst-plugins-base-libs-1.8.0-1  gst-plugins-good-1.8.0-1  gstreamer-1.8.0-1
              gtk-update-icon-cache-3.20.2-1  gtk3-3.20.2-1  iproute2-4.4.0-2  iptables-1.6.0-1  iputils-20160308.0db72a4-1  json-glib-1.2.0-1  krb5-1.13.4-1
              lib32-libglvnd-0.1.0.20160329-2  lib32-mesa-11.2.0-1  lib32-mesa-libgl-11.2.0-1  libelf-0.166-1  libgit2-1:0.24.0-1  libglvnd-0.1.0.20160329-2
              libsoup-2.54.0.1-1  libxml2-2.9.3-2  linux-4.5-1  linux-firmware-20160315.deb1d83-1  logrotate-3.9.2-1  lvm2-2.02.149-1  mesa-11.2.0-1
              mesa-libgl-11.2.0-1  pango-1.40.0-1  pangomm-2.40.0-1  pygobject-devel-3.20.0-1  python2-gobject-3.20.0-1  vte-common-0.44.0-1  vte3-0.44.0-1
              xf86-input-libinput-0.18.0-1  xf86-video-amdgpu-1.1.0-1  xf86-video-ati-1:7.7.0-1  xf86-video-intel-1:2.99.917+604+gff0ab2c-1

I think, it is a fontconfig-2.11.95-1

Offline

#2 2016-04-07 20:56:31

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,092

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

Infanality - just do it/


[img]https://www.speedtest.net/result/10030141098.png[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#3 2016-04-08 05:33:48

x33a
Forum Fellow
Registered: 2009-08-15
Posts: 4,586
Website

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

@int13h,

Unexpected issues can come up on using the testing repos. You are only supposed to use them if you want to help out the packagers.

Moving to NC.

Offline

#4 2016-04-11 20:14:00

trichards
Member
From: Tennessee, USA
Registered: 2013-12-10
Posts: 4
Website

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

@int13h and @x33a,

fontconfig-2.11.95-1 was released to extra today, and after performing a full system upgrade I experienced the same issue. Downgrading to 2.11.94-1 restored the fonts back to a legible state. I'd take a screenshot, but I'm afraid my eyes have bled enough for today.

Offline

#5 2016-04-11 20:29:51

trichards
Member
From: Tennessee, USA
Registered: 2013-12-10
Posts: 4
Website

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

Okay, I gave in and took some screenshots. In my opinion, 2.11.95-1 looks 9000% worse. Especially the monospace font.

2.11.94-1: https://i.imgur.com/p9b4TtF.png
2.11.95-1: https://i.imgur.com/apxxEAT.png

Reminds me very much of Ubuntu 8.04. hmm

Offline

#6 2016-04-12 05:16:44

oinkl
Member
Registered: 2010-01-13
Posts: 43

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

The upgrade to fontconfig-2.11.95-1 did something to my fonts as well.
It doesn't look worse, just... different.

Was wondering if there's any way to revert to the previous look if possible.

FYI:

/home/user/.config/fontconfig/fonts.conf

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
  <alias>
    <family>serif</family>
    <prefer>
      <family>BitStream Vera Serif</family>
    </prefer>
  </alias>
  <alias>
    <family>sans-serif</family>
    <prefer>
      <family>BitStream Vera Sans</family>
    </prefer>
  </alias>
  <alias>
    <family>sans</family>
    <prefer>
      <family>BitStream Vera Sans</family>
    </prefer>
  </alias>
  <alias>
    <family>monospace</family>
    <prefer>
      <family>Source Code Pro</family>
    </prefer>
  </alias>
</fontconfig>

[edit] Fixed: https://bbs.archlinux.org/viewtopic.php … 8#p1619318

Last edited by oinkl (2016-04-12 07:06:15)

Offline

#7 2016-04-20 08:02:34

r12624
Member
Registered: 2014-10-21
Posts: 14

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

Have you also noticed font changes in gedit and terminal?

Offline

#8 2016-04-26 20:54:02

Carfax
Member
Registered: 2013-10-30
Posts: 30

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

Will that explain why i'm experiencing these terrible changes as well? I tried the solution in the link above....... still didn't change nothing. Especially with whats happening in the title bar of my terminal. http://imgur.com/lEKPHWC

Last edited by Carfax (2016-04-26 20:54:30)

Offline

#9 2016-06-01 19:38:40

stahl
Member
Registered: 2013-04-03
Posts: 5

Re: Terrible fonts in browser [Google Chrome / Chromium/ FF / etc]

trichards wrote:

Okay, I gave in and took some screenshots. In my opinion, 2.11.95-1 looks 9000% worse. Especially the monospace font.

2.11.94-1: https://i.imgur.com/p9b4TtF.png
2.11.95-1: https://i.imgur.com/apxxEAT.png

Reminds me very much of Ubuntu 8.04. hmm

Same here. Besides chrome also other software look much worse including the console (terminator), double commander and other.

From the posts above i created the mentioned config file ~/.config/fontconfig/fonts.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
        <!-- Disable the effects of 10-hinting-slight.conf -->
        <match target="font">
                <test name="hintstyle" compare="eq">
                        <const>hintslight</const>
                </test>
                <edit name="hintstyle" mode="delete"/>
        </match>
</fontconfig>

However, this did not solve or change anything. sad
What am I missing?

Offline

Board footer

Powered by FluxBB