You are not logged in.

#26 2016-04-12 16:36:39

stef_204
Member
Registered: 2014-08-15
Posts: 33

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

Vain wrote:

fontconfig-2.11.95 left testing, problem's gone -- but all non-bitmap fonts look different now. tongue sad *sigh* ... which is caused by the new "10-hinting-slight.conf" being active by default. I'll be putting this in my ~/.config/fontconfig/fonts.conf and I'm back to "normal":

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Disable the effects of 10-hinting-slight.conf -->
	<match target="pattern">
		<edit name="hintstyle" mode="delete"><const>hintslight</const></edit>
	</match>
</fontconfig>

Nice job!  This works for me as well.
I usually like to understand what the fix actually does so as not to use it blindly.
I see the docs here.
And changelog here; commit 98434b3392172233094cac25ade7225c93da9f1c
Did I miss anything?

Last edited by stef_204 (2016-04-12 17:01:21)

Offline

#27 2016-04-12 18:06:36

letni69
Member
Registered: 2015-09-21
Posts: 17

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

stef_204 wrote:
Vain wrote:

fontconfig-2.11.95 left testing, problem's gone -- but all non-bitmap fonts look different now. tongue sad *sigh* ... which is caused by the new "10-hinting-slight.conf" being active by default. I'll be putting this in my ~/.config/fontconfig/fonts.conf and I'm back to "normal":

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Disable the effects of 10-hinting-slight.conf -->
	<match target="pattern">
		<edit name="hintstyle" mode="delete"><const>hintslight</const></edit>
	</match>
</fontconfig>

Nice job!  This works for me as well.
I usually like to understand what the fix actually does so as not to use it blindly.
I see the docs here.
And changelog here; commit 98434b3392172233094cac25ade7225c93da9f1c
Did I miss anything?

d179cbc2536af16cf0f4992e0a4b2d751437ee6c
Revert "Workaround another race condition issue"

Offline

#28 2016-04-12 19:15:19

kokoko3k
Member
Registered: 2008-11-14
Posts: 2,052

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

stef_204 wrote:
Vain wrote:

fontconfig-2.11.95 left testing, problem's gone -- but all non-bitmap fonts look different now. tongue sad *sigh* ... which is caused by the new "10-hinting-slight.conf" being active by default. I'll be putting this in my ~/.config/fontconfig/fonts.conf and I'm back to "normal":

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Disable the effects of 10-hinting-slight.conf -->
	<match target="pattern">
		<edit name="hintstyle" mode="delete"><const>hintslight</const></edit>
	</match>
</fontconfig>

Nice job!  This works for me as well.
I usually like to understand what the fix actually does so as not to use it blindly.
I see the docs here.
And changelog here; commit 98434b3392172233094cac25ade7225c93da9f1c
Did I miss anything?

Two different issues are discussed in this thread:
d179cbc2536af16cf0f4992e0a4b2d751437ee6c fixes the slowness
98434b3392172233094cac25ade7225c93da9f1c blindly makes hintslight the default for every font, even bitmap ones(if i understood properly)

Both were pushed in the 2.11.95 release.


Help me to improve ssh-rdp !

Offline

#29 2016-04-12 21:01:08

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

kokoko3k wrote:

blindly makes hintslight the default for every font

Relax, it's *only* a default (and it's actually one of the first rules I use, before e.g. font-family-specific tweaking). Feel free to use numbers 11-99 for fontconfig configuration files, to tweak fontconfig to your liking.

Offline

#30 2016-04-13 13:07:06

Nyarcel
Member
Registered: 2012-03-06
Posts: 2

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

Vain wrote:

fontconfig-2.11.95 left testing, problem's gone -- but all non-bitmap fonts look different now. tongue sad *sigh* ... which is caused by the new "10-hinting-slight.conf" being active by default. I'll be putting this in my ~/.config/fontconfig/fonts.conf and I'm back to "normal":

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Disable the effects of 10-hinting-slight.conf -->
	<match target="pattern">
		<edit name="hintstyle" mode="delete"><const>hintslight</const></edit>
	</match>
</fontconfig>

The syntax should actually be the following:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
        <!-- Disable the effects of 10-hinting-slight.conf -->
        <match target="font">
                <test name="hintstyle" compare="eq">
                        <const>hintslight</const>
                </test>
                <edit name="hintstyle" mode="delete"/>
        </match>
</fontconfig>

See this, for example: http://permalink.gmane.org/gmane.comp.f … onfig/4672

Offline

#31 2016-04-13 14:07:10

kokoko3k
Member
Registered: 2008-11-14
Posts: 2,052

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

brebs wrote:
kokoko3k wrote:

blindly makes hintslight the default for every font

Relax, it's *only* a default (and it's actually one of the first rules I use, before e.g. font-family-specific tweaking). Feel free to use numbers 11-99 for fontconfig configuration files, to tweak fontconfig to your liking.

Yes, yes, i'm completely relaxed, i don't even use any bitmap font atm.
But from what i understand about hinting, it should never be used for bitmap font rendering; maybe is freetype that should ignore that "hint" in that case (?)

Last edited by kokoko3k (2016-04-13 14:07:30)


Help me to improve ssh-rdp !

Offline

#32 2016-04-13 18:53:32

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

kokoko3k wrote:

freetype that should ignore that "hint" in that case (?)

There's multiple hints to consider, especially whether any hinting at all is applied wink

E.g. my defaults:

    <match target="font">
        <edit mode="assign" name="rgba"><const>rgb</const></edit>
        <edit mode="assign" name="autohint"><bool>true</bool></edit>
        <edit mode="assign" name="hintstyle"><const>hintslight</const></edit>
        <edit mode="assign" name="hinting"><bool>true</bool></edit>
        <edit mode="assign" name="antialias"><bool>true</bool></edit>
        <edit mode="assign" name="lcdfilter"><const>lcddefault</const></edit>
    </match>

(I don't use bitmap fonts, because I'm not a masochist.)

Offline

#33 2016-05-15 08:38:57

lightbeam
Member
Registered: 2016-05-15
Posts: 3

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

***Deleted*** Posted in the wrong thread. hmm

Last edited by lightbeam (2016-05-16 03:30:28)

Offline

#34 2016-05-15 12:08:34

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,035

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

lightbeam wrote:

The temporary workaround I found to this problem was to remove libbluray and install libbluray-git.  Not ideal, but doing so allowed me to forego installing freetype2 and keep freetype2-ubuntu and fontconfig-ubuntu installed.

That is completely unrelated, and a really silly workaround.

Offline

#35 2016-05-16 03:28:07

lightbeam
Member
Registered: 2016-05-15
Posts: 3

Re: [SOLVED] fontconfig 2.11.94 slows down programs startup

Scimmia wrote:
lightbeam wrote:

The temporary workaround I found to this problem was to remove libbluray and install libbluray-git.  Not ideal, but doing so allowed me to forego installing freetype2 and keep freetype2-ubuntu and fontconfig-ubuntu installed.

That is completely unrelated, and a really silly workaround.

My bad. I posted on the wrong thread. It was late. Meant to post that response here. Fixed now.

Offline

Board footer

Powered by FluxBB