You are not logged in.

#1 2016-01-22 18:17:02

davy_crockett
Member
Registered: 2015-10-21
Posts: 57

[SOLVED] Can't get HDMI audio to work

Hi there,

I can't get HDMI audio to work from my laptop. I'm running KDE5 and have the xf86-video-ati graphics drivers installed. The output of lspci as it relates to my graphics is:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Heathrow XT [Radeon HD 7870M]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]

I've also updated /etc/default/grub kernel parameters with this and ran sudo grub-mkconfig -o /boot/grub/grub.cfg

GRUB_CMDLINE_LINUX_DEFAULT="cryptdevice=/dev/md/internal_0p2:system root=/dev/mapper/system-root resume=/dev/mapper/system-swap quiet ipv6.disable=1 radeon.audio=1"

I've also added MODULES="radeon" to /etc/mkinitcpio.conf and rebuilt the initramfs.

One thing I've noticed is in alsamixer, I can select sound cards - (default), 0 HDA Intel PCH and 1 HDA ATI HDMI. When I select 1 HDA ATI HDMI, I'm presented with six boxes labelled S/PDIF (S/PDIF, S/PDIF 1, S/PDIF 2 etc) with the volumes all at 00 and it doesn't let me adjust this, with or without an HDMI cable plugged in.

Can you please tell me what's going on here and how do I resolve it?

There are also some settings in vlc media player for specifying HDMI or built-in audio. I'll get to that later.

Last edited by davy_crockett (2016-02-16 06:45:45)

Offline

#2 2016-01-22 19:24:33

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 79

Re: [SOLVED] Can't get HDMI audio to work

I've always had hdmi auido issues with the open source ati driver. Have you tried the closed source driver?

Offline

#3 2016-01-22 21:45:53

michis
Member
Registered: 2015-12-12
Posts: 77

Re: [SOLVED] Can't get HDMI audio to work

davy_crockett wrote:

When I select 1 HDA ATI HDMI, I'm presented with six boxes labelled S/PDIF (S/PDIF, S/PDIF 1, S/PDIF 2 etc) with the volumes all at 00 and it doesn't let me adjust this, with or without an HDMI cable plugged in.

Have you unmuted all of them?

what is the output of

aplay -l
dmesg | grep snd
lsmod | grep snd

EDIT: have you tried to disable / deactivate the non-HDMI device in KDE audio settings?

Last edited by michis (2016-01-22 21:47:44)

Offline

#4 2016-01-22 22:06:17

michis
Member
Registered: 2015-12-12
Posts: 77

Re: [SOLVED] Can't get HDMI audio to work

piratebill wrote:

I've always had hdmi auido issues with the open source ati driver.

Here it works fine with the open source driver on a Radeon HD 8330.

Offline

#5 2016-01-22 23:04:32

cirrus
Member
From: Glasgow Scotland
Registered: 2012-08-24
Posts: 142
Website

Re: [SOLVED] Can't get HDMI audio to work

Hi
I Just want to chime in and say that i too have no problems with HDMI audio with the radeon driver so long as pulseaudio is installed.
HD4750


We do not choose, we are chosen, those that dont understand dont matter, those that understand need no explanation. We are the chosen few.
http://cirrusminor.info
http://www.danasoft.com/sig/7972427251.jpg

Offline

#6 2016-01-22 23:46:31

davy_crockett
Member
Registered: 2015-10-21
Posts: 57

Re: [SOLVED] Can't get HDMI audio to work

michis wrote:
davy_crockett wrote:

When I select 1 HDA ATI HDMI, I'm presented with six boxes labelled S/PDIF (S/PDIF, S/PDIF 1, S/PDIF 2 etc) with the volumes all at 00 and it doesn't let me adjust this, with or without an HDMI cable plugged in.

Have you unmuted all of them?

what is the output of

aplay -l
dmesg | grep snd
lsmod | grep snd

EDIT: have you tried to disable / deactivate the non-HDMI device in KDE audio settings?

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: 92HD93BXX Analog [92HD93BXX Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

dmesg | grep snd

[   33.353077] snd_hda_intel 0000:01:00.1: Handle VGA-switcheroo audio client
[   33.353080] snd_hda_intel 0000:01:00.1: Force to non-snoop mode
[   33.530762] snd_hda_codec_idt hdaudioC0D0: autoconfig for 92HD93BXX: line_outs=1 (0xe/0x0/0x0/0x0/0x0) type:line
[   33.530765] snd_hda_codec_idt hdaudioC0D0:    speaker_outs=1 (0xd/0x0/0x0/0x0/0x0)
[   33.530767] snd_hda_codec_idt hdaudioC0D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
[   33.530768] snd_hda_codec_idt hdaudioC0D0:    mono: mono_out=0x0
[   33.530769] snd_hda_codec_idt hdaudioC0D0:    inputs:
[   33.530770] snd_hda_codec_idt hdaudioC0D0:      Dock Mic=0xf
[   33.530772] snd_hda_codec_idt hdaudioC0D0:      Internal Mic=0x11
[   33.530773] snd_hda_codec_idt hdaudioC0D0:      Mic=0xa

lsmod | grep snd

snd_hda_codec_idt      49152  1
snd_hda_codec_generic    69632  1 snd_hda_codec_idt
snd_hda_codec_hdmi     49152  1
snd_hda_intel          32768  5
snd_hda_codec         106496  4 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           49152  5 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                86016  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_timer              28672  1 snd_pcm
snd                    65536  18 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              16384  1 snd

And yes I've tried clicking the speaker button in the KDE system tray and muting built-in analogue stereo. In Alsamixer for HDA ATI HDMI the channels aren't muted but they're stuck on 00 for volume.

Last edited by davy_crockett (2016-01-22 23:48:37)

Offline

#7 2016-01-23 00:57:45

MoSal
Member
Registered: 2015-09-23
Posts: 31

Re: [SOLVED] Can't get HDMI audio to work

First, make sure linux-firmware is installed. And undo all changes you made in grub, mkinitcpio.conf, ... etc.
Those changes shouldn't be needed nowadays.

Assuming your enabled output device name is HDMI-0. Just try running this command:

xrandr --output HDMI-0 --set audio on

This should be enough if your card is supported, and KDE is not causing more harm than good!

Last edited by MoSal (2016-01-23 00:58:15)


saldl - a lightweight yet well-featured CLI downloader optimized for speed and early preview.

Offline

#8 2016-01-23 06:39:24

davy_crockett
Member
Registered: 2015-10-21
Posts: 57

Re: [SOLVED] Can't get HDMI audio to work

I noticed an error on startup of my PC. It was

[5.711826] radeon 0000:01:00.0: Invalid ROM contents

The output of xrandr --output HDMI-0 --set audio on resulted in this (the HDMI cable was disconnected when I ran that command; I'll try it with it connected next)

arning: output HDMI-0 not found; ignoring
X Error of failed request:  BadRROutput (invalid Output parameter)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  15 (RRGetOutputProperty)
  Serial number of failed request:  46
  Current serial number in output stream:  46

I was able to actually get the test audio working over HDMI in KDE. I went to system settings -> Hardware -> Multimedia and went to the configuration tab and changed the entry for Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] from Digital Surround 5.1 (HDMI 2) Output to Digital Stereo (HDMI) Output. I then went to the Audio and Video tab and then the Audio hardware setup tab and clicked the speaker placement and testing. The result was I could play test audio, however I couldn't get the audio working for any of my applications.

Should I try getting HDMI audio working from the console first (not in KDE) and then get it working in KDE? Another option is to install the Catalyst driver; I had HDMI audio and video working previously on OpenSUSE with the Catalyst driver. My graphics had been fine with the xf86-video-ati graphics up until I connected a Dell docking station and monitor; now the graphics occasionally play up when powering on sometimes (happens in about 1 in 4 boots) and sometimes now I get system hangs with error messages relating to the graphics.

Offline

#9 2016-01-23 13:27:45

michis
Member
Registered: 2015-12-12
Posts: 77

Re: [SOLVED] Can't get HDMI audio to work

MoSal wrote:

First, make sure linux-firmware is installed. And undo all changes you made in grub, mkinitcpio.conf, ... etc.
Those changes shouldn't be needed nowadays.

If you do this and the output of dmesg and lsmod is the same you posted it should be ok.
(modules are loaded)

davy_crockett wrote:

In Alsamixer for HDA ATI HDMI the channels aren't muted but they're stuck on 00 for volume.

I think that's normal.

davy_crockett wrote:

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: 92HD93BXX Analog [92HD93BXX Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Do you get hdmi sound with this command?

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav

Try all listed hdmi devices.
1,3 in above command means card 1 device 3 -> HDMI 0

... maybe you have to use hw:1,3 instead of plughw:1,3

Last edited by michis (2016-01-23 13:28:27)

Offline

#10 2016-01-23 13:37:36

michis
Member
Registered: 2015-12-12
Posts: 77

Re: [SOLVED] Can't get HDMI audio to work

michis wrote:
MoSal wrote:

First, make sure linux-firmware is installed. And undo all changes you made in grub, mkinitcpio.conf, ... etc.
Those changes shouldn't be needed nowadays.

If you do this and the output of dmesg and lsmod is the same you posted it should be ok.
(modules are loaded)

Oh, wait. I think in dmesg there should be some lines with snd_hda_codec_hdmi in it.
something like this (just an example)

[    4.379096] snd_hda_codec_hdmi hdaudioC0D0: HDMI ATI/AMD: no speaker allocation for ELD
[    4.675938] snd_hda_codec_hdmi hdaudioC0D0: HDMI ATI/AMD: no speaker allocation for ELD
[    4.975860] snd_hda_codec_hdmi hdaudioC0D0: HDMI ATI/AMD: no speaker allocation for ELD

Offline

#11 2016-02-16 06:45:22

davy_crockett
Member
Registered: 2015-10-21
Posts: 57

Re: [SOLVED] Can't get HDMI audio to work

I resolved this by installing the package "pavucontrol" for pulse audio volume control. I now have HDMI audio working, and I've tested it with both the open-source graphics driver and the catalyst driver.

Offline

#12 2016-04-20 00:36:44

v0!d
Member
Registered: 2016-04-20
Posts: 2

Re: [SOLVED] Can't get HDMI audio to work

Thanks, MoSal.

xrandr --output HDMI-0 --set audio on

got my audio working.

MoSal wrote:

First, make sure linux-firmware is installed. And undo all changes you made in grub, mkinitcpio.conf, ... etc.
Those changes shouldn't be needed nowadays.

Assuming your enabled output device name is HDMI-0. Just try running this command:

xrandr --output HDMI-0 --set audio on

This should be enough if your card is supported, and KDE is not causing more harm than good!

Offline

Board footer

Powered by FluxBB