You are not logged in.

#1 2016-04-28 23:50:21

grufo
Member
Registered: 2012-08-09
Posts: 81

[SOLVED] Failed to start Load/Save Screen Backlight Brightness

Hi everyone!

It may seems that this is a duplicate of this topic, but just because this is a duplicate of that topic indeed.

The problem is that, after years of working fine without problems, some recent update of systemd made that message to appear again:

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0
See 'systemctl status systemd-backlight@backlight:acpi_video0.service' for details.
[OK] Started Load/Save Screen Backlight Brightness of backlight:radeon_b10

The difference with the previous topic is that this time neither

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=\"!Windows 2012\""

nor

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=\"Linux\""

works for my /etc/default/grub.

My laptop is an HP Pavilion 15-e056sl Notebook PC.

Any clue?

--grufo

Last edited by grufo (2016-04-29 00:59:31)

Offline

#2 2016-04-28 23:53:15

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,743
Website

Re: [SOLVED] Failed to start Load/Save Screen Backlight Brightness

And?

See 'systemctl status systemd-backlight@backlight:acpi_video0.service' for details.

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#3 2016-04-28 23:55:47

grufo
Member
Registered: 2012-08-09
Posts: 81

Re: [SOLVED] Failed to start Load/Save Screen Backlight Brightness

jasonwryan wrote:

And?

See 'systemctl status systemd-backlight@backlight:acpi_video0.service' for details.
● systemd-backlight@backlight:acpi_video0.service - Load/Save Screen Backlight Brightness of backlight:acpi_video0
   Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since ven 2016-04-29 01:38:49 CEST; 17min ago
     Docs: man:systemd-backlight@.service(8)
  Process: 341 ExecStart=/usr/lib/systemd/systemd-backlight load %i (code=exited, status=1/FAILURE)
 Main PID: 341 (code=exited, status=1/FAILURE)

Last edited by grufo (2016-04-28 23:56:16)

Offline

#4 2016-04-28 23:59:27

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,743
Website

Re: [SOLVED] Failed to start Load/Save Screen Backlight Brightness

Look at the journal entry for that PID...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#5 2016-04-29 00:03:05

grufo
Member
Registered: 2012-08-09
Posts: 81

Re: [SOLVED] Failed to start Load/Save Screen Backlight Brightness

jasonwryan wrote:

Look at the journal entry for that PID...

@jasonwryan

journalctl -b _PID=341
-- Logs begin at sab 2016-04-23 03:36:55 CEST, end at ven 2016-04-29 02:01:02 CEST. --
apr 29 01:38:49 alba systemd-backlight[341]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device

Offline

#6 2016-04-29 00:18:42

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,743
Website

Re: [SOLVED] Failed to start Load/Save Screen Backlight Brightness

So has it been renamed, or is no longer appearing?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#7 2016-04-29 00:41:26

grufo
Member
Registered: 2012-08-09
Posts: 81

Re: [SOLVED] Failed to start Load/Save Screen Backlight Brightness

@jasonwryan

I really don't know what happend, I just know that I have exactly the same machine of two years ago.

If I launch

systemctl status systemd-backlight@backlight:radeon_bl0.service

I get:

● systemd-backlight@backlight:radeon_bl0.service - Load/Save Screen Backlight Brightness of backlight:radeon_bl0
   Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static; vendor preset: disabled)
   Active: active (exited) since ven 2016-04-29 01:38:49 CEST; 56min ago
     Docs: man:systemd-backlight@.service(8)
  Process: 343 ExecStart=/usr/lib/systemd/systemd-backlight load %i (code=exited, status=0/SUCCESS)
 Main PID: 343 (code=exited, status=0/SUCCESS)

-------- EDIT --------

Solved!! smile

I just added acpi_backlight=vendor to the arguments of the kernel and everything seems to work now!

/etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor"

@jasonwryan

Thank you very much for your time and your help! smile

-- grufo

Last edited by grufo (2016-04-29 01:00:43)

Offline

Board footer

Powered by FluxBB