You are not logged in.

#1 2016-05-25 21:15:18

From: Flagstaff AZ/Chongqing CN
Registered: 2016-03-24
Posts: 3

Encrypted disk unbootable, reason unclear

Hey all,

Two days ago I was watching some videos on VLC while running pacman -Syu and trying to install some software from npm. My laptop suddenly overheated, crashed to console, and I had to force a shutdown. Normally no big deal, but when I turned the thing back on I found I couldn't boot from my SSD. The BIOS doesn't recognize it as bootable, and I can't get to GRUB. The SSD is set up as a single logical partition with an encrypted LVM group on it, and I have GRUB configured to decrypt the drive so that I can leave /boot encrypted along with the rest of the system.

To try to find out more, I flashed the latest Arch boot media to a flash drive and booted from it successfully. Using fdisk I found that my hard drive is only reading as 20MB large (it's 64GB in reality), and the drive's type flag has apparently become nonsense. Additionally, when I ran the hardware check included with the boot media, and tried to look at the list of hard drives, the drive list displayed a bunch of nonsense characters and crashed. Which was interesting.

So ordinarily in this situation I would just reinstall GRUB, but I'm fairly new at full-disk encryption (been running the setup like this for 2-3 months tops) and I'm worried that I could end up losing access to my drive. The system is set up according to a popular guide on running a single-partition fully encrypted setup with LVM/LUKS and GRUB crypto modules. Starting over from scratch wouldn't be the apocalypse, but it would be a pretty major PITA.

This is going to be my "and then I realized why regular backups are important" story.

I'm not really sure where to start with this, and I'd appreciate any help y'all can offer. Thanks for your time.


#2 2016-05-25 21:29:32

From: Ancapistan
Registered: 2010-07-12
Posts: 2,810

Re: Encrypted disk unbootable, reason unclear

Unfortunately I think something is toast. Probably SSD, but possibly the laptop or some integral component. First try reseating the SSD. If that doesn't change anything, connect the SSD to another machine. If it works correctly there, there's probably something wrong with your laptop. If it doesn't work correctly there, you have to decide if you want to risk another disk in your laptop.

OTOH, I had a similar thing happen with an Intel SSD several months ago: PC crash, afterwards SSD reported 8MB capacity. According to Intel it was possible (but unlikely) that a secure erase would bring it back to life. It didn't work for me, and of course even if it had worked all data would be lost. Just FYI.

But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner


Board footer

Powered by FluxBB