You are not logged in.

#1 2006-05-10 21:24:39

mcmillan
Member
Registered: 2006-04-06
Posts: 688

Configuring KDE (aterm transparency/double-click opening)

I had fluxbox working and setup so aterm was pinned and transparent to look like it's part of the desktop. I recently decided to try out kde and wanted to do the same thing, but it opens with a black background instead of transparent. I can set  it to other colors though. I was curious if anyone else has experienced this and knew how to solve it.

I'd be open to using other terminals, though I haven't been quite been satisifed with other ones I've tried. Konsole and Eterm almost work. Konsole leaves a small white line around the outline, even when I used the KDE menu to configure it to have no window border, that just removes the window decorations. Eterm also leaves a grey menu on top, which I'd prefer not to have, but didn't see an option to turn this off, though I'll admit I haven't looked too hard. I did get gnome-terminal to look the way I want, but it seems like running that probably loads more than I'd really like it to if I'm running KDE.

Also while I'm posting, I thought I'd ask a probably simple question. I want to change the setting so double-clicking opens directories instead of single clicking. I remember from when I tested out knoppix when I first started there was an obvious place, but I can't seem to find it in the new version. There was a wizard when I first started KDE that let me choose, but I deleted it from the menu, and now can't seem to find it again.

Offline

#2 2006-05-11 02:56:09

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: Configuring KDE (aterm transparency/double-click opening)

mcmillan wrote:

I had fluxbox working and setup so aterm was pinned and transparent to look like it's part of the desktop. I recently decided to try out kde and wanted to do the same thing, but it opens with a black background instead of transparent. I can set  it to other colors though. I was curious if anyone else has experienced this and knew how to solve it.

You didn't mention your previous method so I'm not sure how to try and duplicate your issue. I've never desired to eliminate the borders, but something like this should get you transparency (just advance the trailing number to increase transparency):

$ aterm -tr -sh 70

mcmillan wrote:

Also while I'm posting, I thought I'd ask a probably simple question. I want to change the setting so double-clicking opens directories instead of single clicking.

KDE Contol Center > Peripherals > Mouse > General


/path/to/Truth

Offline

#3 2006-05-11 04:50:44

mcmillan
Member
Registered: 2006-04-06
Posts: 688

Re: Configuring KDE (aterm transparency/double-click opening)

What I was originally using was just aterm -tr, which works fine in fluxbox, but not KDE. I'm pretty sure this is the equivalent of -sh 0. Anyway, using what you had suggesting gives the same results, aterm with a black background.

I did get it to show the background of my fluxbox desktop, but the next time I tried opening it, it was black again. I haven't been able to replicate this yet to figure out exactly what was different. Also I have my KDE desktop set to change after a period of time, and I noticed gnome-terminal didn't update the shown background. This makes me wonder if these two are looking for some other source for what the desktop looks like than KDE does. Don't know if that makes any sense or not.

Thanks for the double click configuration. I knew it had to be someplace obvious that I was missing.

Offline

#4 2006-05-11 11:38:39

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: Configuring KDE (aterm transparency/double-click opening)

mcmillan wrote:

What I was originally using was just aterm -tr, which works fine in fluxbox, but not KDE.

Yes, that does only give me a black background in aterm on the KDE desktop. Odd how the command I posted doesn't work in your envrionment as I've commonly used it on several distros without issue. As you alluded to, there might be something in your user config that is hampering this from occuring.


/path/to/Truth

Offline

#5 2006-05-12 01:58:42

mcmillan
Member
Registered: 2006-04-06
Posts: 688

Re: Configuring KDE (aterm transparency/double-click opening)

Thanks for the help anyway. I think I might stick with Eterm for KDE.

Offline

Board footer

Powered by FluxBB