You are not logged in.

#1 2016-06-07 14:39:37

asg1448
Member
Registered: 2014-04-12
Posts: 73

Disable single ATA port

I have a laptop, which has a built-in drive on ata2, which went bad. During init, the `udevadm --settle` spins the wheels for over a minute. This is very annoying, and I have not found any way to solve this

`libata.force=2.00:disable` does not have any effect on udevadm, although this option works, when I disable the main drive, the system naturally won't boot.

After udevadm done settling, the system is fully operational, port disabled, and there's no more problems. In other words, `udevadm --settle` somehow disables the port, and it stops becoming a problem

I want to know what it does, so that I could do this myself, and not have to wait for it to probe the knowingly dysfunctional port. I know this could be done by injecting commands into `/usr/lib/initcpio/hooks/udev`

Offline

#2 2016-06-07 17:17:11

Ropid
Member
Registered: 2015-03-09
Posts: 1,065

Re: Disable single ATA port

Something different: did you check in the BIOS menus to see if there's a screen where you can disable individual SATA ports?

Offline

#3 2016-06-07 21:02:09

JohnBobSmith
Member
From: Canada
Registered: 2014-11-29
Posts: 804

Re: Disable single ATA port

asg1448 wrote:

...
I have a laptop, which has a built-in drive on ata2, which went bad.
...

So open the laptop and pull the offending drive? smile


I am diagnosed with bipolar disorder. As it turns out, what I thought was my greatest weakness is now my greatest strength.

Everyday, I make a conscious choice to overcome my challenges and my problems. It's not easy, but its better than the alternative...

Offline

#4 2016-06-08 01:47:30

asg1448
Member
Registered: 2014-04-12
Posts: 73

Re: Disable single ATA port

bios has no such option

drive is not removable

need to disable drive with software-only means.

Offline

Board footer

Powered by FluxBB