You are not logged in.

#1 2006-05-11 11:58:56

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

@Skype users: What's your (working) config?

Sorry for this extra-thread, but I'm not able to skype with friends because they never hear me.

Here is my config: ALSA with /etc/asound.conf + /etc/libao.conf

Listening to mpd, watching a movie in mplayer + a flash-clip in opera works wonderfully (thanks to "aoss opera").

There are 3 methods to start skype (from cmdline):

1. plain old "skype"
2. "aoss skype"
3. skype_dsp_hijacker

Neither of them changes the result that i hear the ringing if I call a friend, but they can't hear me.

The permissions on my /dev/dsp

lrwxrwxrwx  1 root root      9 11. Mai 13:55 /dev/dsp -> sound/dsp
crw-rw----  1 root audio 14, 3 11. Mai 13:55 /dev/sound/dsp

Of course, my user IS in the audio-group.

what do I do wrong?

Offline

#2 2006-05-11 12:46:17

lessthanjake
Member
From: Norway
Registered: 2005-11-09
Posts: 319
Website

Re: @Skype users: What's your (working) config?

I'm using skype_dsp_hijack, but even then I need to close all other apps for skype to wokt.

Tips: call echo123, then you do not have to bother your friends.

Offline

#3 2006-05-11 13:09:05

skeeter
Member
From: Woodstock, CT
Registered: 2003-02-01
Posts: 77

Re: @Skype users: What's your (working) config?

Tried to run Skype as root, good or no good?
Tried alsamixer or aumix and checked "MIC" port for mute?
Try Mic or Headset w/Mic in another computer to verify hwd is good?
Let us know if you have already done so or what the outcome was.


Skeeter

Rule #1:  There are NO RULES!

Offline

#4 2006-05-11 14:09:17

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: @Skype users: What's your (working) config?

+1

And if you have an audigy card, you have two views for your microphone:
playback and capture. Check that the capture is on and full

Offline

#5 2006-05-11 14:15:37

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: @Skype users: What's your (working) config?

Ah I forgot to mention that: Mic is unmuted in alsamixer and so is mic boost.
I can hear myself from my boxes when I talk into the mic. Therefore, I think it IS ok.

Thanks for the tip with echo123, very good service.

I'll now try to run skype as root. I've only done "sudo skype_dsp_hijacker" yet.
Ok now i started as root: "aoss skype", "skype" and "skype_dsp_hijacker".
Then with sudo: "aoss skype", "skype", "skype_dsp_hijacker"

None of them worked...

//edit: My soundcard is a soundblaster 128 pci

Offline

#6 2006-05-11 14:58:52

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: @Skype users: What's your (working) config?

hellwoofa wrote:

Ah I forgot to mention that: Mic is unmuted in alsamixer and so is mic boost.
I can hear myself from my boxes when I talk into the mic. Therefore, I think it IS ok.

If you can hear yourself, it means the "Playback" of your microphone is on, check if you have a "Capture" (use the tabkey in alsamixer) and if it is on.

Offline

#7 2006-05-11 15:15:17

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: @Skype users: What's your (working) config?

Hm, according to this, it should be on (never knew that there are more settings through Tab)

http://home.arcor.de/hellwoofa/alsa.png

Offline

#8 2006-05-11 15:42:54

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: @Skype users: What's your (working) config?

Me neither but when I wanted to use Skype big_smile
And it can be useful to mute the playback on the microphone not to hear yourself

Don't know what your problem is, your alsa output are fine.

Offline

#9 2006-05-12 01:18:30

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: @Skype users: What's your (working) config?

Try oss2jack in the AUR.


·¬»· i am shadowhand, powered by webfaction

Offline

#10 2006-05-12 09:38:30

sebcactus
Member
From: Germany
Registered: 2005-01-27
Posts: 277

Re: @Skype users: What's your (working) config?

By the way what modules are loaded (have you snd_pcm_oss for example)?

Offline

#11 2006-05-13 12:31:37

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: @Skype users: What's your (working) config?

I have them in my custom kernel

CONFIG_SND=y
CONFIG_SND_TIMER=y
CONFIG_SND_PCM=y
CONFIG_SND_RAWMIDI=y
CONFIG_SND_SEQUENCER=y
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=y
CONFIG_SND_PCM_OSS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_SUPPORT_OLD_API=y

# Generic devices
#     
CONFIG_SND_MPU401_UART=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_AC97_BUS=m

#
# PCI devices
CONFIG_SND_ENS1370=y
CONFIG_SND_VIA82XX=m

OSS-Emulation (with alsa) seems to work since (as already said  big_smile ) i CAN listen to mpd and watch flash-movies in opera (when i started opera with "aoss opera").

I've played with oss2jack before I got dmix working, but had no success with it. I may try it again... smile

Offline

#12 2006-05-13 22:38:37

jaboua
Member
Registered: 2005-11-05
Posts: 634

Re: @Skype users: What's your (working) config?

Also, try using "rec test.ogg" (you need "sox" installed) and say something - then press control-c and try play the file. If you can hear yourself, you know for sure that the problem is not the microphone configuration.

Offline

#13 2006-05-14 10:51:42

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: @Skype users: What's your (working) config?

Hah now we're coming close to the problem:

jakob@~ $ rec test.ogg
Send break (control-c) to end recording
ALSA lib pcm_dmix.c:801:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
sox: Failed reading default: cannot open audio device

But I also renamed /etc/{libao.conf,asound.conf} and restarted alsa sound daemon, i can't hear anything.

Next thing I'm going to do is oss2jack (had no time yet but after lunch i'll have)

Offline

Board footer

Powered by FluxBB