You are not logged in.

#1 2004-02-28 04:43:45

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

w3m problems and possible resolution

Hopefully this, rather than the makepkg forum is the right place to put this.

If one installs w3m and doesn't have gpm installed, they get an error of missing libraries.

w3m: error while loading shared libraries: libgpm.so.1: cannot open shared object file: No such file or directory

If one then installs gpm, it will open, however, at the top of the page you'll see things like

*debug [lib/libow.c(204)]: 
VC:0 
VC: 0mp/isdigit/option/consolename failed 
Oh, oh, it's an error! possible I die.

This problem can be avoided by calling w3m with the -no-mouse option.

However, playing around with the the PKGBUILD in /var/abs I found that if one removes the --disable-mouse option from the configuration, both problems go away. I've filed this on bugs.archlinux.org but thought I'd pass it along here as well.

Scott

Offline

#2 2004-02-28 16:07:49

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

Re: w3m problems and possible resolution

Put this on bugs and Dorphell commented that it seemed to be a problem on my local machine.  Testing it on another machine proved him correct.

At that point, I uninstalled w3m and gpm and removed the tarballs from /var/cache/pacman/pkg  (Not sure if this was necessary or not)

Reinstalled and he's correct, problem seems to have been fixed.

Scott

Offline

Board footer

Powered by FluxBB