You are not logged in.

#1 2006-05-15 21:17:15

idjut
Member
From: Oslo
Registered: 2006-05-15
Posts: 176

Startx fails with no error

I installed arch base and pacman'd xorg and startx. Downloaded xf86-video-i810. I ran Xorg -configure. Made sure mouse pointed at /dev/input/mice.

Startx produces no errors but just quits.

˝/.xinitrc has one line in it: exec fluxbox  (or exec enlightenment)

Does $PATH have anything to do with it ?

Here is my xorg.conf which I have messed around with many times now:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath      "/usr/share/X11/rgb"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc"
    FontPath     "/usr/share/fonts/75dpi"
    FontPath     "/usr/share/fonts/100dpi"
    FontPath     "/usr/share/fonts/TTF"
    FontPath     "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load  "glx"
    Load  "record"
    Load  "xtrap"
    Load  "dbe"
    Load  "dri"
    Load  "extmod"
    Load  "freetype"
    Load  "type1"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "ColorKey"               # <i>
        #Option     "CacheLines"             # <i>
        #Option     "Dac6Bit"                # [<bool>]
        #Option     "DRI"                    # [<bool>]
        #Option     "NoDDC"                  # [<bool>]
        #Option     "ShowCache"              # [<bool>]
        #Option     "XvMCSurfaces"           # <i>
        #Option     "PageFlip"               # [<bool>]
    Identifier  "Card0"
    Driver      "i810"
    VendorName  "Intel Corporation"
    BoardName   "82852/855GM Integrated Graphics Device"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   1024 768
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   1024 768
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   1024 768
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   1024 768
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   1024 768
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   1024 768
        Depth     24
    EndSubSection
EndSection

[/quote]


Linux user #403491

"Men have called me mad; but the question is not yet settled, whether madness is or is not the loftiest intelligence– whether much that is glorious– whether all that is profound– does not spring from disease of thought– from moods of mind exalted at the expense of the general intellect." - E. A. Poe from Eleonora

Offline

#2 2006-05-15 21:19:46

Titus
Member
From: Izmir
Registered: 2006-05-11
Posts: 120
Website

Re: Startx fails with no error

what is your /etc/inttab file  index. can you paste it here?


In a world without walls,who need windows?

Offline

#3 2006-05-15 21:21:35

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Startx fails with no error

Have you test it with the vesa driver?


Have you tried to turn it off and on again?

Offline

#4 2006-05-15 22:36:15

kill
Member
Registered: 2004-09-30
Posts: 126

Re: Startx fails with no error

/var/log/Xorg.0.log should have why it can't start. Please post any EE lines and the last few.

Offline

#5 2006-05-15 23:05:53

idjut
Member
From: Oslo
Registered: 2006-05-15
Posts: 176

Re: Startx fails with no error

My /etc/inittab:

#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)    Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

id:3:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

c1:2345:respawn:/sbin/agetty 38400 vc/1 linux
c2:2345:respawn:/sbin/agetty 38400 vc/2 linux
c3:2345:respawn:/sbin/agetty 38400 vc/3 linux
c4:2345:respawn:/sbin/agetty 38400 vc/4 linux
c5:2345:respawn:/sbin/agetty 38400 vc/5 linux
c6:2345:respawn:/sbin/agetty 38400 vc/6 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

x:5:respawn:/usr/bin/xdm -nodaemon

# End of file

I found no EE's. The last few of Xorg.0.log:

(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xd093f000 at 0xb78a1000
(WW) I810(0): Successfully set original devices
(WW) I810(0): Setting the original video mode instead of restoring
    the saved state
(II) I810(0): BIOS call 0x5f05 not supported, setting refresh with VBE 3 method.
(II) I810(0): xf86UnbindGARTMemory: unbind key 7
(II) I810(0): xf86UnbindGARTMemory: unbind key 0
(II) I810(0): xf86UnbindGARTMemory: unbind key 1
(II) I810(0): xf86UnbindGARTMemory: unbind key 3
(II) I810(0): xf86UnbindGARTMemory: unbind key 2
(II) I810(0): xf86UnbindGARTMemory: unbind key 4
(II) I810(0): xf86UnbindGARTMemory: unbind key 5
(II) I810(0): xf86UnbindGARTMemory: unbind key 6
(WW) I810(0): Successfully set original devices (2)
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.

Will try to test it with VESA driver. Should I just replace i810 with VESA in xorg.conf then ?


Linux user #403491

"Men have called me mad; but the question is not yet settled, whether madness is or is not the loftiest intelligence– whether much that is glorious– whether all that is profound– does not spring from disease of thought– from moods of mind exalted at the expense of the general intellect." - E. A. Poe from Eleonora

Offline

#6 2006-05-16 04:47:15

kill
Member
Registered: 2004-09-30
Posts: 126

Re: Startx fails with no error

It looks like X is starting right and then exiting like it should. You could try replacing i810 with vesa provided you have the xf86-video-vesa package installed.

idjut wrote:

xinitrc has one line in it: exec fluxbox (or exec enlightenment)

What exactly is in your .xinitrc file? From the looks of it the server is starting normally then exiting because it has nothing to run.

Offline

#7 2006-05-16 06:04:40

ScriptDevil
Member
From: In Front of My PC
Registered: 2006-04-06
Posts: 253

Re: Startx fails with no error

what exactly is in your .xinitrc

Finally there is a possible soultion. But still by default, wmaker is unmaked while the rest are masked in .xinitrc so i think if .xinitrc is used, it will try to exec wmaker and if it is not there it would rturn an error


Be yourself, because you are all that you can be

Offline

#8 2006-05-16 07:16:41

Ipsofacto
Member
Registered: 2006-04-14
Posts: 25
Website

Re: Startx fails with no error

idjut wrote:

My /etc/inittab:

id:3:initdefault:

Hey, i'm new to Arch but will throw in my 2c worth.  Shouldnt the above be

id:5:initdefault:

Thereby putting you into run level 5.

Offline

#9 2006-05-16 07:52:33

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Startx fails with no error

We don't use runlevels other than 0, 1, something else and 6 tongue

0: halt,
1: single user mode
2-5: multi-user, no difference at all
6: reboot

Inittab doesn't have anything to do with startx not working. Guess fluxbox is installed in a /opt prefix and the /etc/profile.d/fluxbox.sh needs to be sourced before starting fluxbox (so log out and login again tongue)

Offline

#10 2006-05-16 10:22:57

idjut
Member
From: Oslo
Registered: 2006-05-15
Posts: 176

Re: Startx fails with no error

Inittab doesn't have anything to do with startx not working. Guess fluxbox is installed in a /opt prefix and the /etc/profile.d/fluxbox.sh needs to be sourced before starting fluxbox (so log out and login again tongue)

Sourced? Add in $PATH?


Linux user #403491

"Men have called me mad; but the question is not yet settled, whether madness is or is not the loftiest intelligence– whether much that is glorious– whether all that is profound– does not spring from disease of thought– from moods of mind exalted at the expense of the general intellect." - E. A. Poe from Eleonora

Offline

#11 2006-05-16 10:27:12

idjut
Member
From: Oslo
Registered: 2006-05-15
Posts: 176

Re: Startx fails with no error

This is my .xinitrc. I masked wmaker and added fluxbox.

#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#

PATH=$PATH:/usr/X11R6/bin:/sw/bin:/usr/local/bin
export PATH

xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
xterm -geometry 80x66+0+0 &

# exec wmaker
# exec startkde
# exec icewm
# exec blackbox

exec fluxbox


Linux user #403491

"Men have called me mad; but the question is not yet settled, whether madness is or is not the loftiest intelligence– whether much that is glorious– whether all that is profound– does not spring from disease of thought– from moods of mind exalted at the expense of the general intellect." - E. A. Poe from Eleonora

Offline

#12 2006-05-16 11:10:11

idjut
Member
From: Oslo
Registered: 2006-05-15
Posts: 176

Re: Startx fails with no error

It`s working now. I just tried it once more to be certain. Apart for some "estethical" changes in .xinitrc I didnt change anything. This is what you were talking about JGC?

Now I am happy to explore more of arch. Cant wait to make me system run single-boot arch.. Now it shares with ubuntu, debian and dsl. Ubuntu is not bad at all actually, but I think the lean arch is more what I want. And its better for learning.

Thanks all!


Linux user #403491

"Men have called me mad; but the question is not yet settled, whether madness is or is not the loftiest intelligence– whether much that is glorious– whether all that is profound– does not spring from disease of thought– from moods of mind exalted at the expense of the general intellect." - E. A. Poe from Eleonora

Offline

#13 2006-05-16 13:04:33

ScriptDevil
Member
From: In Front of My PC
Registered: 2006-04-06
Posts: 253

Re: Startx fails with no error

buntu is not bad at all actually, but I think the lean arch is more what I want. And its better for learning

good choice. Ubuntu is bad though!(But it is the best deban can offer)


Be yourself, because you are all that you can be

Offline

#14 2006-05-16 13:07:27

FUBAR
Member
From: Belgium
Registered: 2004-12-08
Posts: 1,029
Website

Re: Startx fails with no error

idjut wrote:

This is my .xinitrc. I masked wmaker and added fluxbox.

#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#

PATH=$PATH:/usr/X11R6/bin:/sw/bin:/usr/local/bin
export PATH

xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
xterm -geometry 80x66+0+0 &

# exec wmaker
# exec startkde
# exec icewm
# exec blackbox

exec fluxbox

You should replace "exec fluxbox" with "exec startfluxbox". But before doing so, read the docs to know why you should.


A bus station is where a bus stops.
A train station is where a train stops.
On my desk I have a workstation.

Offline

#15 2006-05-16 21:20:26

kill
Member
Registered: 2004-09-30
Posts: 126

Re: Startx fails with no error

idjut wrote:

PATH=$PATH:/usr/X11R6/bin:/sw/bin:/usr/local/bin
export PATH

You don't need either of those lines becase Arch uses xorg 7 which no longer uses /usr/X11R6. Also you shouldn't have anything in /sw/bin or /usr/local/bin unless you've put something there yourself.

Offline

Board footer

Powered by FluxBB