You are not logged in.

#1 2016-07-12 10:55:11

Registered: 2014-10-23
Posts: 26

[SOLVED] Lualatex can't compile KOMA document

I tried to test my document with texlive 2016 and therefore installed Arch with testing repositories in an systemd-nspawn container.

After reducing my document to the following four lines, I noticed that lualatex can't compile documents with a documentclass from the KOMA-script package (e.g., scrartcl or scrbook), while the standard classes (e.g., article or book) compile without an error:

   Lorem Ipsum

Is this only me, or did I hit a bug in testing?


This is not a bug, it's a feature! Lualatex removed many pdf-related commands and, thus, requires many packages to be updated for compatibility.

A workaround is to load one or two additional packages as early as possible:

\RequirePackage{luatex85} % for general compatibility
\RequirePackage{shellesc} % if you want to use shell-escape

Last edited by coruun (2016-07-13 08:15:08)


#2 2016-08-08 04:52:19

Registered: 2008-01-19
Posts: 66

Re: [SOLVED] Lualatex can't compile KOMA document

Thank you very much for sharing! Just adding

\RequirePackage{luatex85} % for general compatibility

made my document work again. Phew!

Care to share where to find out about why  this is and how to prepare for other documents not working?


Board footer

Powered by FluxBB