You are not logged in.

#1 2006-05-16 15:56:10

k.mandla
Member
From: Japan
Registered: 2006-05-16
Posts: 86
Website

Apparently no 3D acceleration

I can't seem to get 3D acceleration of any sort with the onboard graphics on an nForce2 motherboard.

I installed XFCE, the Nvidia drivers and the nForce drivers as per the wiki, and while the desktop is fine, I get nothing from xscreensaver or any 3D games. I've added RenderAccel to my xorg.conf, thinking that might help, but nothing seems to do the trick.

Can anyone offer a suggestion? Here's my xorg.conf, as it stands now.

Section "ServerLayout"
    Identifier     "Simple Layout"
    Screen         "Screen 1" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath         "/usr/share/X11/rgb"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/75dpi"
    FontPath        "/usr/share/fonts/100dpi"
    FontPath        "/usr/share/fonts/TTF"
EndSection

Section "Module"
    Load           "dbe"      # Double buffer extension
    SubSection     "extmod"
        Option         "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Protocol" "Auto"    # Auto detect
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Princeton VL1918"
    HorizSync       31.5 - 64.3
    VertRefresh     50.0 - 70.0
EndSection

# Section "Device"
#     Identifier     "Standard VGA"
#     Driver         "vga"
#     VendorName     "Unknown"
#     BoardName      "Unknown"
# EndSection

Section "Device"
    Identifier     "NVIDIA GeForce4 MX"
    Driver         "nvidia"
    Option        "RenderAccel" "true"
EndSection

Section "Screen"
    Identifier     "Screen 1"
    Device         "NVIDIA GeForce4 MX"
    Monitor        "Princeton VL1918"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       8
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Linux user No. 409907

Offline

#2 2006-05-16 19:16:18

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 801

Re: Apparently no 3D acceleration

Section "DRI"
    Mode 0666
EndSection

Offline

#3 2006-05-16 19:52:12

k.mandla
Member
From: Japan
Registered: 2006-05-16
Posts: 86
Website

Re: Apparently no 3D acceleration

vacant wrote:
Section "DRI"
    Mode 0666
EndSection

I thought DRI was a no-no with Nvidia cards?


Linux user No. 409907

Offline

#4 2006-05-16 21:46:45

Bysshe
Member
Registered: 2004-12-10
Posts: 268

Re: Apparently no 3D acceleration

It's possible for it not to work if you installed nvidia driver before installing latest kernels, which the simple workaround is to reinstall the driver.

I don't have that particular chipset, but theoretically it should work fine with drivers:
nvidia

But...
Did you try:
nvidia-legacy

And yes, "dri" is a no-no with legacy nvidia chipsets.  Which yours shouldn't be, as it's based on the same core as the Geforce4 MX4000.  However, it may be necessary NOT to load dri since it's a neutered onboard chip...but like I said, I don't have this particular configuration.  In that case, it may force you to use nvidia-legacy.

Confused yet?  Good.  Me too.  tongue

pacman -Sy nvidia-legacy

Offline

Board footer

Powered by FluxBB