You are not logged in.

#1 2016-07-25 08:24:53

dedpul
Member
Registered: 2016-07-25
Posts: 11

unable to use nvidia gpu after installing bumblebee

i did a fresh install yesterday. tried setting up hybrid graphics using bumblebee. all goes well and it should work without any configurations afaik.
running optirun glxgears -info gives not output at all.
running optirun glxspheres64 does not show any animation, rather just a text output in terminal as Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)

running optirun -vv glxspheres64 gives the following :

[ 2374.169816] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 2374.170051] [DEBUG]optirun version 3.2.1 starting...
[ 2374.170061] [DEBUG]Active configuration:
[ 2374.170064] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 2374.170074] [DEBUG] X display: :8
[ 2374.170078] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia
[ 2374.170081] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 2374.170084] [DEBUG] Accel/display bridge: auto
[ 2374.170086] [DEBUG] VGL Compression: proxy
[ 2374.170088] [DEBUG] VGLrun extra options:
[ 2374.170089] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 2374.170112] [DEBUG]Using auto-detected bridge virtualgl
[ 2374.170391] [INFO]Response: Yes. X is active.

[ 2374.170398] [INFO]Running application using virtualgl.
[ 2374.170484] [DEBUG]Process vglrun started, PID 2397.
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
[ 2374.218379] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 2374.218417] [DEBUG]Socket closed.
[ 2374.218434] [DEBUG]Killing all remaining processes.

I'm running a HP laptop with Intel HD 5500 and nvidia 940M

running the above commands without optirun works fine.
Any ideas?

Offline

#2 2016-07-25 10:01:46

neulaender
Member
From: Göttingen
Registered: 2016-07-25
Posts: 1

Re: unable to use nvidia gpu after installing bumblebee

Just subscribed to this topic, because I have exactly the same problem hmm
Of course I followed the bumblebee instructions.

My hardware is slightly different:
Nvidia: GTX 860M

Additionally to the thread creator I tried:
optirun -vv -c [all compress methods] glxspheres64/32

Edit(while I'm writing this post big_smile):
- "sudo pacman -Sy primus lib32-primus"
- "primusrun glxspheres64" works
- "optirun -b primus glxspheres64" works too

Now I had the problem that it was just about 60fps
- "vblank_mode=0 primusrun glxspheres64" gave me about 220fps while
- "vblank_mode=0 glxspheres64" gave me about 170fps

In my conclusion and with my specific setup: primusrun instead of optirun, which means, not using virtualgl but primus as renderer.

Offline

#3 2016-07-25 18:21:14

Arachnid92
Member
From: Chile
Registered: 2011-05-02
Posts: 39
Website

Re: unable to use nvidia gpu after installing bumblebee

I had the same problem, can confirm that using primus instead of virtualgl works.

Hardware:
ASUS ROG G501 - NVIDIA GTX 960M


Keep it simple, stupid.

Offline

#4 2016-07-26 01:58:44

ezzetabi
Member
Registered: 2006-08-27
Posts: 947

Re: unable to use nvidia gpu after installing bumblebee

Same problem here, yet another hardware.

% lspci -k | grep -A 2 -E '(VGA|3D)'
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
        Subsystem: CLEVO/KAPOK Computer Device 3537
        Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev ff)
        Kernel modules: nouveau, nvidia_drm, nvidia
03:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)

Also here, primusrun works.

A little out topic for @neulaender, be careful installing with pacman -Sy <prg>; it possible that you get a half updated system with broken ABI deps. It's safer to install with pacman -S and if it fails because the system is not updated just update -Syu and install -S <prg>.

Offline

#5 2016-07-26 21:57:55

Arachnid92
Member
From: Chile
Registered: 2011-05-02
Posts: 39
Website

Re: unable to use nvidia gpu after installing bumblebee

I have updated the wiki with the workaround posted here.

https://wiki.archlinux.org/index.php/Bu … bug_output


Keep it simple, stupid.

Offline

#6 2016-07-27 18:51:06

dedpul
Member
Registered: 2016-07-25
Posts: 11

Re: unable to use nvidia gpu after installing bumblebee

I installed primus. how do I know if my gpu is being used

EDIT: holy shit it works. although my FPS for CSGO do not go above 50 at 1080p, all settings very low. ubuntu gave me about 70fps, keeping other things same. windows gave me ~100

anyway so

Last edited by dedpul (2016-07-27 19:09:56)

Offline

#7 2016-07-28 12:29:33

dedpul
Member
Registered: 2016-07-25
Posts: 11

Re: unable to use nvidia gpu after installing bumblebee

it seems my fps are capped at 50 hmm

Offline

#8 2016-07-28 12:59:39

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,068

Re: unable to use nvidia gpu after installing bumblebee

https://wiki.archlinux.org/index.php/Bu … able_VSYNC if your monitor only is capable of 50Hz it makes no sense to waste processing power on rendering more frames, you can disable it however if you feel this not to be smooth enough.

Online

#9 2016-07-30 21:11:26

juego
Member
Registered: 2015-04-13
Posts: 41
Website

Re: unable to use nvidia gpu after installing bumblebee

Thanks all for the Primus solution.
Had the same problem.
Here is my graphic card: Nvidia GeForce GTX 850M
Anybody filed a bug somewhere? The corresponding issue in the bug tracker: https://bugs.archlinux.org/task/50067

Last edited by juego (2016-07-30 21:15:29)

Offline

#10 2017-04-18 09:55:14

ustone07
Member
Registered: 2017-04-17
Posts: 3

Re: unable to use nvidia gpu after installing bumblebee

I have the same problem, I've tried using the primus fix also.
There is no glx window opeing but I can feel the GPU switching on, heating up, and the fan going into overwork mode.

┌─ 03:18 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun glxgears -info
┌─ 03:19 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun glxspheres64
┌─ 03:19 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun -vv glxspheres64
[71836.592737] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[71836.593322] [DEBUG]optirun version 3.2.1 starting...
[71836.593343] [DEBUG]Active configuration:
[71836.593347] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[71836.593352] [DEBUG] X display: :8
[71836.593357] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[71836.593362] [DEBUG] Socket path: /var/run/bumblebee.socket
[71836.593370] [DEBUG] Accel/display bridge: auto
[71836.593375] [DEBUG] VGL Compression: proxy
[71836.593383] [DEBUG] VGLrun extra options: 
[71836.593391] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[71836.593431] [DEBUG]Using auto-detected bridge virtualgl
[71836.712487] [INFO]Response: Yes. X is active.

[71836.712501] [INFO]Running application using virtualgl.
[71836.712598] [DEBUG]Process vglrun started, PID 2514.
[71836.845393] [DEBUG]SIGCHILD received, but wait failed with No child processes
[71836.845417] [DEBUG]Socket closed.
[71836.845430] [DEBUG]Killing all remaining processes.
┌─ 03:19 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > primusrun glxspheres64
^C
┌─ 03:19 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun -b primus glxspheres64 
^C[71897.420549] [WARN]Received Interrupt signal.
┌─ 03:20 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun -b -vv primus glxspheres64
[71902.051878] [ERROR]Unknown accel/display bridge: -vv
┌─ 03:20 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun -vv -b primus glxspheres64
[71923.184390] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[71923.184788] [DEBUG]optirun version 3.2.1 starting...
[71923.184801] [DEBUG]Active configuration:
[71923.184804] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[71923.184807] [DEBUG] X display: :8
[71923.184809] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[71923.184812] [DEBUG] Socket path: /var/run/bumblebee.socket
[71923.184815] [DEBUG] Accel/display bridge: primus
[71923.184818] [DEBUG] VGL Compression: proxy
[71923.184823] [DEBUG] VGLrun extra options:
[71923.184829] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[71923.305126] [INFO]Response: Yes. X is active.

[71923.305142] [INFO]Running application using primus.
[71923.305232] [DEBUG]Process glxspheres64 started, PID 2588.
^C[71945.428512] [WARN]Received Interrupt signal.
[71945.428524] [DEBUG]Socket closed.
[71945.428687] [DEBUG]SIGCHILD received, but wait failed with No child processes
[71945.428699] [DEBUG]Socket closed.
[71945.428703] [DEBUG]Killing all remaining processes.
┌─ 03:21 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > optirun -vv -b primus glxsgears
[71950.467857] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[71950.468274] [DEBUG]optirun version 3.2.1 starting...
[71950.468289] [DEBUG]Active configuration:
[71950.468294] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[71950.468298] [DEBUG] X display: :8
[71950.468303] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[71950.468312] [DEBUG] Socket path: /var/run/bumblebee.socket
[71950.468320] [DEBUG] Accel/display bridge: primus
[71950.468328] [DEBUG] VGL Compression: proxy
[71950.468334] [DEBUG] VGLrun extra options:
[71950.468342] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[71950.585581] [INFO]Response: Yes. X is active.

[71950.585594] [INFO]Running application using primus.
[71950.585688] [DEBUG]Process glxsgears started, PID 2621.
[71950.585791] [ERROR]Error running "glxsgears": No such file or directory
[71950.585911] [DEBUG]SIGCHILD received, but wait failed with No child processes
[71950.585921] [DEBUG]Socket closed.
[71950.585929] [DEBUG]Killing all remaining processes.
┌─ 03:21 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ >
┌─ 03:21 PM :: utkarsh@TheBatcavePC in [ ~ ]
└─ $ > lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 755M] (rev a1)

Last edited by ustone07 (2017-04-18 09:59:36)

Offline

Board footer

Powered by FluxBB