You are not logged in.

#1 2016-08-30 11:39:06

harunou
Member
Registered: 2016-08-30
Posts: 4

xfce4-power-manager 1.6.0 does not update battery icons

After update from 1.4.4-2 up to 1.6.0 version, battery icons stopped updating while charging/discharging. Icons in the power manager plugin, in the power manager plugin menu and in the devices tab of the power manager window show only 100%. Downgrade resolves the issue.

Screenshot.png

Any ideas?

Last edited by harunou (2016-08-30 12:43:33)

Offline

#2 2016-08-31 01:55:52

Mindstormscreator
Member
Registered: 2012-07-01
Posts: 186

Re: xfce4-power-manager 1.6.0 does not update battery icons

I've noticed the same thing. The tray icon now doesn't even seem to reflect my icon theme (Numix Circle), and I also notice it takes a while for a menu to pop up when clicking on it.

Offline

#3 2016-08-31 02:54:20

Turgon
Member
Registered: 2009-01-14
Posts: 19

Re: xfce4-power-manager 1.6.0 does not update battery icons

Confrim issue with a xfce4-power-manager.
Lid functions and icons changes don't work properly.
Downgrade indeed help me.

Last edited by Turgon (2016-08-31 02:54:48)


My life is my message.

Offline

#4 2016-08-31 09:14:22

harunou
Member
Registered: 2016-08-30
Posts: 4

Re: xfce4-power-manager 1.6.0 does not update battery icons

Finally icon changes, but not as accurate as it was before.

Discharging screenshots:
60%-59% shows full
30%-29% shows about a half
10%-9% shows critical

Last edited by harunou (2016-09-02 07:08:53)

Offline

#5 2016-08-31 10:19:34

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: xfce4-power-manager 1.6.0 does not update battery icons

Did anyone report this in our bugtracker or upstream?


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#6 2016-08-31 10:45:37

toz
Member
Registered: 2011-10-28
Posts: 431

Re: xfce4-power-manager 1.6.0 does not update battery icons

xfce4-power-manager icon handling was changed as of 1.5.0 (See this commit). It now uses upower icon names ("upower -d") to generate the icon. Instead of 6 levels (0, 20, 40, 60, 80, 100) there are now 4 (empty, low, good, full).

If the tray icon is not matching your icon theme, make sure you are using the "power manager plugin" on the panel. Also make sure your icon theme has the proper icon files (see previous commit link).

There is a current outstanding issue regarding lid actions. See https://bugzilla.xfce.org/show_bug.cgi?id=12088, https://bugzilla.xfce.org/show_bug.cgi?id=12756, https://bugzilla.xfce.org/show_bug.cgi?id=12728).

Offline

#7 2016-08-31 11:30:32

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: xfce4-power-manager 1.6.0 does not update battery icons

Here I'm seeing the power manager plugin taking a long time to start and when right clicking it also takes a long time for the menu to show up.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#8 2016-08-31 12:50:35

toz
Member
Registered: 2011-10-28
Posts: 431

Re: xfce4-power-manager 1.6.0 does not update battery icons

R00KIE wrote:

Here I'm seeing the power manager plugin taking a long time to start and when right clicking it also takes a long time for the menu to show up.

Try running xfce4-panel in debug mode to see whats happening. First remove the power manager plugin from the panel (to make the debug messages cleaner) and then quit the panel "xfce4-panel -q", restart it debug mode "PANEL_DEBUG=1 xfce4-panel" then re-add the plugin and right-click on it.

Offline

#9 2016-08-31 16:00:14

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: xfce4-power-manager 1.6.0 does not update battery icons

Well ... I think I've blamed the wrong component, it's not the power manager panel plugin. What I'm seeing misbehaving after the update to xfce4-power-manager 1.6.0-2 is the systray icon, it takes good while to show up after starting xfce and when right clicking it takes a while for the menu to show up. I don't see any messages when running "PANEL_DEBUG=1 xfce4-panel" (as expected I suppose). I also don't see anything on dmesg or xorg logs.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#10 2016-09-01 07:45:23

BlkChockr
Member
Registered: 2016-09-01
Posts: 13

Re: xfce4-power-manager 1.6.0 does not update battery icons

Nonetheless the problem with the "external" panel plugin exists.

There are reddit posts here and here regarding the same problem.

Can anyone tell me why numix doesn't work with the new icons?

Last edited by BlkChockr (2016-09-01 07:48:11)

Offline

#11 2016-09-01 13:04:02

toz
Member
Registered: 2011-10-28
Posts: 431

Re: xfce4-power-manager 1.6.0 does not update battery icons

BlkChockr wrote:

Can anyone tell me why numix doesn't work with the new icons?

The power manager plugin uses symbolic icons and the systray icon does not. It appears that the Numix icon theme is missing the non-symbolic icons. You can copy/link the symbolic to the non-symbolic if you want to use the same icon (or add new ones if you wish). The ones that appear to be missing are:

battery-caution-charging.svg
battery-caution.svg   
battery-empty-charging.svg
battery-empty.svg
battery-full-charged.svg
battery-full-charging.svg
battery-full.svg
battery-good-charging.svg
battery-good.svg
battery-low.svg

Offline

#12 2016-09-01 14:13:35

toz
Member
Registered: 2011-10-28
Posts: 431

Re: xfce4-power-manager 1.6.0 does not update battery icons

R00KIE wrote:

Well ... I think I've blamed the wrong component, it's not the power manager panel plugin. What I'm seeing misbehaving after the update to xfce4-power-manager 1.6.0-2 is the systray icon,

Yes, I see that as well. However, if I build the package directly from the git tree, the problem no longer exists. Perhaps its already been fixed in a post-1.6.0 commit? This appears to be the only commit related to the systray.

Offline

#13 2016-09-01 16:30:56

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: xfce4-power-manager 1.6.0 does not update battery icons

toz wrote:

Yes, I see that as well. However, if I build the package directly from the git tree, the problem no longer exists. Perhaps its already been fixed in a post-1.6.0 commit? This appears to be the only commit related to the systray.

I have just finished doing a git bisect and that indeed seems to be the commit that fixes things, however this also seems to be needed, otherwise the systray icon might still take a long time to show up. It also seems there are a few commits before the one you pointed out that might be important.

It would be nice if there would be a new upstream release of xfce4-power-manager, that way Arch would not need to cherry pick patches.

Edit:
Bug report here: https://bugs.archlinux.org/task/50627

Last edited by R00KIE (2016-09-01 16:42:11)


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#14 2016-09-02 06:55:36

harunou
Member
Registered: 2016-08-30
Posts: 4

Re: xfce4-power-manager 1.6.0 does not update battery icons

As far as Power manager plugin uses upower icon names and upower has four states (full, good, low, critical/caution), the icon will be shown next way:

  1. 100%-60% - full

  2. 59%-30% - good

  3. 29%-10% - low

  4. 10%-1% - critical/caution

Based on the list above, now it's clear why the icon updates became so rough compared to the previous version, where icon had 6 states (100, 80, 60, 40, 20, 0).

Upower code (link)

get_device_charge_icon (gdouble  percentage,
			gboolean charging)
{
	if (percentage < 10)
		return charging ? "battery-caution-charging-symbolic" : "battery-caution-symbolic";
	else if (percentage < 30)
		return charging ? "battery-low-charging-symbolic" : "battery-low-symbolic";
	else if (percentage < 60)
		return charging ? "battery-good-charging-symbolic" : "battery-good-symbolic";
	return charging ? "battery-full-charging-symbolic" : "battery-full-symbolic";
}

So it means the plugin works proper way. But the ranges in the list are more suitable for colouring battery bar in a plugin like Battery monitor.

Remaining question: what needs to be improved upower or xfce power manager plugin?

Offline

#15 2016-09-03 06:56:44

BlkChockr
Member
Registered: 2016-09-01
Posts: 13

Re: xfce4-power-manager 1.6.0 does not update battery icons

toz wrote:

[The power manager plugin uses symbolic icons and the systray icon does not. It appears that the Numix icon theme is missing the non-symbolic icons. You can copy/link the symbolic to the non-symbolic if you want to use the same icon (or add new ones if you wish). The ones that appear to be missing are:

battery-caution-charging.svg
battery-caution.svg   
battery-empty-charging.svg
battery-empty.svg
battery-full-charged.svg
battery-full-charging.svg
battery-full.svg
battery-good-charging.svg
battery-good.svg
battery-low.svg

That's where I get confused, because they appear to be there: https://github.com/numixproject/numix-i … 48/devices hmm

The Power-Manager plugin only seems to be linking to the hicolor icon set, doesn't it? (At least in this file)

Offline

#16 2016-09-03 11:26:22

toz
Member
Registered: 2011-10-28
Posts: 431

Re: xfce4-power-manager 1.6.0 does not update battery icons

BlkChockr wrote:

That's where I get confused, because they appear to be there: https://github.com/numixproject/numix-i … 48/devices hmm

The plugin would use the icons from the <size>/status folder. For my panel, I added the files to Numix/22/status, re-built the cache (gtk-update-icon-cache) and they took effect. The correct folder is related to the size of your panel (e.g. is your panel is 22, or 23, use 22; if the panel is 24-31, use 24; etc).

cd /usr/share/icons/Numix/24/status/
cp battery-low-symbolic.svg battery-low.svg
cp battery-good-symbolic.svg battery-good.svg
cp battery-good-charging-symbolic.svg battery-good-charging.svg 
cp battery-full-symbolic.svg battery-full.svg
cp battery-full-charging-symbolic.svg battery-full-charging.svg 
cp battery-full-charged-symbolic.svg battery-full-charged.svg 
cp battery-empty-symbolic.svg battery-empty.svg
cp battery-empty-charging-symbolic.svg battery-empty-charging.svg 
cp battery-caution-symbolic.svg battery-caution.svg
cp battery-caution-charging-symbolic.svg battery-caution-charging.svg 
cp battery-low-charging-symbolic.svg battery-low-charging.svg 
gtk-update-icon-cache /usr/share/icons/Numix

The Power-Manager plugin only seems to be linking to the hicolor icon set, doesn't it? (At least in this file)

It installs a default set of fallback icons if the theme doesn't provide ones. Those are the ones you are probably seeing.

Offline

Board footer

Powered by FluxBB