You are not logged in.

#1 2016-09-22 09:52:04

noobusdeer
Member
Registered: 2016-08-24
Posts: 5

[SOLVED] curl sertifcate error while makepkg -s

Hi
I'm try to install php with pthreads extension
https://wiki.archlinux.org/index.php/PH … _extension

but have error with curl certificat

➜  extra-x86_64 git:(master) ✗ makepkg -s                                        
==> Making package: php 7.0.11-1 (Thu Sep 22 12:36:58 MSK 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading php-7.0.11.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (60) SSL certificate problem: self signed certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.
==> ERROR: Failure while downloading https://www.php.net/distributions/php-7.0.11.tar.xz
    Aborting...
➜  extra-x86_64 git:(master) ✗ sudo curl -v https://www.php.net/distributions/php-7.0.11.tar.xz
*   Trying 84.234.75.250...
* TCP_NODELAY set
* Connected to www.php.net (84.234.75.250) port 443 (#0)
* ALPN, offering http/1.1
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (OUT), TLS alert, Server hello (2):
* SSL certificate problem: self signed certificate
* Curl_http_done: called premature == 1
* Closing connection 0
* TLSv1.2 (OUT), TLS alert, Client hello (1):
curl: (60) SSL certificate problem: self signed certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.

I install cacertificate

pacman -Q ca-certificates
ca-certificates 20160507-1

Last edited by noobusdeer (2016-09-22 12:08:09)

Offline

#2 2016-09-22 11:38:50

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,150
Website

Re: [SOLVED] curl sertifcate error while makepkg -s

The problem isn't with your system, it's that PHP's website doesn't currently serve https. Download the file manually form the PHP website: http://php.net/distributions/php-7.0.11.tar.xz

Put the download in the same directory as the PKGBUILD, then try again.


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2016-09-22 12:07:48

noobusdeer
Member
Registered: 2016-08-24
Posts: 5

Re: [SOLVED] curl sertifcate error while makepkg -s

WorMzy wrote:

The problem isn't with your system, it's that PHP's website doesn't currently serve https. Download the file manually form the PHP website: http://php.net/distributions/php-7.0.11.tar.xz

Put the download in the same directory as the PKGBUILD, then try again.

It work thx!!

Offline

Board footer

Powered by FluxBB