You are not logged in.

#1 2016-10-10 06:02:28

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 213
Website

Plasma 5.8 should open application launcher with meta key by default

After watching LAS review KDE Plasma 5.8 today, I decided to see if the meta key opens the launcher: it doesn't. There's no way to assign anything to the meta key either, as far as I can tell. Is this feature available on Arch?

Of course, I verified that I've got 5.8 installed:

/home/colin %pacman -Q kwin
kwin 5.8.0-1
 /home/colin %pacman -Q plasma-desktop
plasma-desktop 5.8.0-1
 /home/colin %

I also tried putting the default launcher back on the panel and removed what I was using. Still nothing.

Offline

#2 2016-10-10 09:55:23

Mowalle
Member
Registered: 2016-06-30
Posts: 1

Re: Plasma 5.8 should open application launcher with meta key by default

To assign the menu to the Meta-Key you have to bind it to the Alt+F1 shortcut, as if you were using ksuperkey. Also, according to this reddit post, there might be problems when upgrading from an existing KDE version.

Offline

#3 2016-10-10 19:10:58

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 213
Website

Re: Plasma 5.8 should open application launcher with meta key by default

I can't get meta only (or shift only) to do anything. Alt+F1 doesn't work as meta only for me (I never had ksuperkey installed). Changing the kwinrc file, as in these instructions https://bucharjan.cz/blog/plasma-custom … tcuts.html, doesn't work either.

Offline

#4 2016-10-10 19:16:27

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,657

Re: Plasma 5.8 should open application launcher with meta key by default

It should work out of the box. At least after login, there's a bug that makes it stop working after some time.

Offline

#5 2016-10-10 19:56:33

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 213
Website

Re: Plasma 5.8 should open application launcher with meta key by default

I got that from reading the reddit posts, but it's not working at all for me. I have logged out and in and rebooted many times after trying different settings. Because I know about the bug, I've tried the meta key first thing after logging in, but nothing makes it work for me, and certainly not "out of the box".

Offline

#6 2016-11-30 12:35:05

marcottedan
Member
Registered: 2016-11-30
Posts: 1

Re: Plasma 5.8 should open application launcher with meta key by default

I had the same exact problem with Plasma 5.8.x with ksuperkey enabled.

Here's how I solved it:

In `~/.config/kwinrc` instead of setting `Meta=` fully remove the configuration line from the file:

[ModifierOnlyShortuts]


Relog, you should be fine. It seems like kwinrc conflicted with Plasma new Meta key shortcut when updating Plasma with ksuperkey enabled.


Also make sure that in your `~/.config/kglobalshortcutsrc`, the right Application Launcher has the ALT + F1 shortcut enabled (you can validate it by making sure your ALT + F1 properly opens the Launcher)

Last edited by marcottedan (2016-11-30 12:36:55)

Offline

#7 2016-11-30 16:50:42

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 213
Website

Re: Plasma 5.8 should open application launcher with meta key by default

Thanks,

I'm sure that will help somebody else, but I never had ksuperkey installed. I actually am not interested in using the meta key for opening the menu. I just want to be able to assign single-key hotkeys.

Offline

#8 2016-12-14 12:07:20

ixi
Member
Registered: 2013-09-11
Posts: 8

Re: Plasma 5.8 should open application launcher with meta key by default

colinkeenan wrote:

I actually am not interested in using the meta key for opening the menu. I just want to be able to assign single-key hotkeys.

AFAIK the only thing the update allows you to do is open the menu with the meta key, just like ksuperkey did.

Instead try Xbindkeys. It allows you to bind your meta key to a command. And by extension to any already existing keyboard shortcut, using xvkbd. For example, if you want your meta key to activate the shortcut for krunner add the following to your .xbindkeysrc file:

"xvkbd -text "\A\[F2]""
Super_L

Offline

Board footer

Powered by FluxBB