You are not logged in.

#1 2016-10-25 06:44:32

nonZero
Member
Registered: 2015-05-17
Posts: 51

[SOLVED] Blank Screen After Lock/Sleep

Hi!

Whenever my laptop returns from sleep, and even after a manual screen lock, a blank screen appears.
The only way to wake it up is by pressing Ctrl+Alt+F1.

I am using a IdeaPad Z580 laptop with gnome 3.22.

$ xset -q
...
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
...
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

The display driver details are:

        *-display
             description: VGA compatible controller
             product: 3rd Gen Core processor Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:30 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:3000(size=64) memory:c0000-dffff


Any help?

Thanks!

Last edited by nonZero (2016-11-23 22:06:56)

Offline

#2 2016-10-25 08:17:45

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

Gnome on wayland? (the default - and in case, the xset output is rubbish)

Offline

#3 2016-10-25 12:27:03

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

I am not running Wayland (It caused trouble when launching gnome apps and was disabled via /etc/gdm/custom.conf).

Offline

#4 2016-10-25 13:44:28

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

"disabled via /etc/gdm/custom.conf"
That disables wayland for *gdm*, but the default gnome session is now gnome on wayland - you got to explicitly select "gnome on xorg". Confirmative?

Offline

#5 2016-10-25 18:08:42

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

I don't have prior experience with wayland, but I can reload gnome with Alt+F2, "r", I have $DISPLAY and not $WAYLAND_DISPLAY and I don't suffer from all the problems I had before disabling wayland, so I guess it is xorg gnome, right?

Offline

#6 2016-10-25 18:58:52

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

Right, so this is not it.
Can you ssh into the system, "export DISPLAY=:0" and query the dpms state as well as "xset dpms force on" if it's not.
Then try to open a new eg. xterm.

The question is whether the the output is suspended and doesn't wake for eg. input or the compositor simply displays some invalidated textures.

Offline

#7 2016-10-26 06:26:27

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

Did you mean to ssh when the computer is locked? I'll check this out later today when I got another PC.

Just to be clear: The monitor is off until I hit Ctrl+Alt+F1.  For example: An external monitor will displays the monitor's built in "no signal". (But this is not related to the external monitor - the same problem occurs also when there is no external monitor attached.)

Offline

#8 2016-10-26 06:36:11

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

Yes. The idea is to inspect and try on the system w/o changing the systems state (which inevitably will happen when altering the VT)

The "No Signal" message suggests you're simply still in dpms.

Offline

#9 2016-10-26 06:51:01

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

When sshing into the locked PC, xset -q does return "Monitor is Off". DPMS is always on.
Only Ctrl+Alt+F1 turns it on, and not a regular keystroke (or mouse move).

Offline

#10 2016-10-26 06:56:06

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

Tried

xset dpms force on

(This should activate the screen)

Offline

#11 2016-10-26 06:58:04

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

It does turn on the monitor, but when it goes to lock/sleep again, it turns off again, and does not wake up on keystroke (as it should).

Offline

#12 2016-10-26 07:02:05

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

Yes, that means the entire problem is that input doesn't impact the dpms state (but everything else is just fine)

What's the output of "xinput" while the screen is off, notably, does it differ from the output while on?
Next test would be whether simply "xset dpms force off" (ie. avoiding whatever gnome does to suspend the screen) allows you to reactivate it with input events.

Offline

#13 2016-10-26 07:37:18

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

After running "xset -dpms", DPMS is turned off, and my monitor is always on, even if blank, and I can wake up the computer with any key - so this is related to DPMS.
xinput returns a list of devices, which does not change on lock.  I couldn't make `xinput test` print any event information.

Offline

#14 2016-10-26 07:52:58

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

Correction: xset dpms force on does not wake up the monitor!
I tried:

sleep 1 && xset dpms force standby && sleep 8 && xset dpms force on

Which does not wake my monitor.

See also:
https://bbs.archlinux.org/viewtopic.php?id=215930
Which is around when I started suffering from this.

I am running:

$ uname -r
4.8.4-1-ARCH

Offline

#15 2016-10-26 13:43:14

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

Do you use the intel or the modesetting Xorg driver? (i somehow doubt the kernel thing)
Does it happen with the other?

Offline

#16 2016-10-26 17:00:17

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

Hi!

I use:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

Offline

#17 2016-10-26 18:31:27

seth
Member
Registered: 2012-09-03
Posts: 28,811

Re: [SOLVED] Blank Screen After Lock/Sleep

just uninstalling xf86-video-intel and restarting X11 should get you the modesetting driver.

Offline

#18 2016-11-23 22:06:31

nonZero
Member
Registered: 2015-05-17
Posts: 51

Re: [SOLVED] Blank Screen After Lock/Sleep

Offline

Board footer

Powered by FluxBB