You are not logged in.

#1 2016-07-10 22:02:11

CTXz
Member
Registered: 2015-11-16
Posts: 5

[SOLVED] Hopperv3: qt5-enginio dependency

Hey guys, I'm a big fan of the hopper disassembler. Unfortunately qt5-enginio is required as an dependency, which is no longer available on the arch repos. Is there any way I can still obtain qt5-enginio. I've been trying to find the source for qt5-enginio, tough didn't find too much.

[ctxz@GLaDOS Downloads]$ sudo pacman -U hopper-3.11.17-1-x86_64.pkg.tar.xz 
loading packages...
resolving dependencies...
warning: cannot resolve "qt5-enginio", a dependency of "hopperv3"
warning: cannot resolve "qt5-quick1", a dependency of "hopperv3"
:: The following package cannot be upgraded due to unresolvable dependencies:
      hopperv3

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: hopperv3: requires qt5-enginio
:: hopperv3: requires qt5-quick1

Last edited by CTXz (2016-07-10 22:25:01)

Offline

#2 2016-07-10 22:24:21

CTXz
Member
Registered: 2015-11-16
Posts: 5

Re: [SOLVED] Hopperv3: qt5-enginio dependency

Ok, seems like the issue got solved. I compiled the library from source https://gitorious.org/qt/qtenginio, and removed qtenginio from the .PKGINFO list

Offline

#3 2016-07-13 11:25:19

mssun
Member
Registered: 2013-04-06
Posts: 33

Re: [SOLVED] Hopperv3: qt5-enginio dependency

It works. Thanks CTXz. Hope someone work out a AUR package.

Offline

#4 2016-12-20 16:07:42

virtualark
Member
Registered: 2016-12-20
Posts: 2

Re: [SOLVED] Hopperv3: qt5-enginio dependency

Hi guys i may be abit late but how exactly do i install the qt5enginio from the source provided? Thanks in advance. smile

Offline

#5 2016-12-20 17:20:21

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED] Hopperv3: qt5-enginio dependency

Using the AUR package...


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#6 2016-12-20 20:01:01

jonathon
Member
Registered: 2016-09-19
Posts: 23

Re: [SOLVED] Hopperv3: qt5-enginio dependency

Here's potentially a better solution. I put together a script to download the official package and patch the PKGINFO to remove all of its unnecessary depends. It generates a new package file ready for checking and installation.

My changes remove most of namcap's complaints. I contacted the software author a few months ago with these changes but he only removed qt5-enginio.

#!/bin/bash
set -euo pipefail
set -x

declare -r pkgver=3.13.0
declare -r pkgrel=1

declare -r curdir=$(pwd)
declare -r workdir=$(mktemp -d)

wget -c "https://d1f8bh81yd16yv.cloudfront.net/hopper-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz"
tar -xf "hopper-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz" -C "${workdir}"
cd "${workdir}"

patch -b <<EOF
--- .PKGINFO
+++ .PKGINFO
@@ -1,4 +1,4 @@
 pkgname = hopperv3
-pkgver = ${pkgver}-${pkgrel}
+pkgver = ${pkgver}-${pkgrel}.1
 pkgdesc = Reverse engineering tool that lets you disassemble and decompile 32/64 bits intel and ARM executables
 url = http://www.hopperapp.com
@@ -8,23 +8,9 @@
 arch = x86_64
 license = Commercial
-depend = bash
-depend = qt5-base
-depend = qt5-connectivity
-depend = qt5-graphicaleffects
-depend = qt5-imageformats
-depend = qt5-location
-depend = qt5-multimedia
-depend = qt5-svg
-depend = qt5-tools
-depend = qt5-translations
-depend = qt5-webkit
-depend = qt5-websockets
-depend = qt5-x11extras
-depend = qt5-xmlpatterns
-depend = graphviz
-depend = xdg-utils
-depend = libtiff
+depend = hicolor-icon-theme
+depend = libbsd
 depend = python2
+depend = qt5-base
 makepkgopt = strip
 makepkgopt = docs
 makepkgopt = libtool
EOF

fakeroot tar -Jcf "${curdir}/hopper-${pkgver}-${pkgrel}.1-x86_64.pkg.tar.xz" usr .PKGINFO .INSTALL
cd "${curdir}"
rm -fR "${workdir}"

(edit: qualify 'quick script')
(edit2: actually, let's just tidy this up a bit and at least make it look reasonable)
(edit3: spotted some unquoted variables)

Last edited by jonathon (2016-12-20 23:52:31)

Offline

#7 2016-12-20 21:52:17

virtualark
Member
Registered: 2016-12-20
Posts: 2

Re: [SOLVED] Hopperv3: qt5-enginio dependency

Thank you Jonathon this is what i was looking for.

Offline

#8 2017-04-16 18:48:55

jonathon
Member
Registered: 2016-09-19
Posts: 23

Re: [SOLVED] Hopperv3: qt5-enginio dependency

Just to finish this off, `hopper` is in the AUR: https://aur.archlinux.org/packages/hopper/

The 4.1.2 PKGBUILD repacks the official package with narrower dependencies and a couple of tweaks. If anyone specifically wants a hopperv3 PKGBUILD let me know.

Last edited by jonathon (2017-04-16 18:50:39)

Offline

Board footer

Powered by FluxBB