You are not logged in.

#1 2016-12-20 22:47:53

menfie
Member
Registered: 2016-12-18
Posts: 12

[SOLVED] Can't upgrade xorg-server to 1.19

Hello,
I'm trying to upgrade Xorg server to testing but it conficts with libxfont2 and it seems like I have libxfont not libxfont2. Here is what I'm trying:

#sudo pacman -Syyu                           
:: Synchronizing package databases...
 testing                                                47.7 KiB   351K/s 00:00 [##############################################] 100%
 core                                                  122.8 KiB   566K/s 00:00 [##############################################] 100%
 extra                                                1746.7 KiB  1372K/s 00:01 [##############################################] 100%
 community                                               3.7 MiB  1189K/s 00:03 [##############################################] 100%
 multilib                                              184.0 KiB  1278K/s 00:00 [##############################################] 100%
 archlinuxfr                                            14.6 KiB   228K/s 00:00 [##############################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (20) curl-7.51.0-3  dhcpcd-6.11.5-1  gdk-pixbuf2-2.36.1+31+gecea71eb6-1  git-2.11.0-2  grep-2.27-1  libbluray-0.9.2-3
              libpsl-0.16.1-1  libutil-linux-2.29-1  libxfont2-2.0.1-1  linux-firmware-20161205.91ddce4-1  openssh-7.4p1-1
              perl-5.24.0-3  util-linux-2.29-1  xf86-input-evdev-2.10.4-2  xf86-input-libinput-0.23.0-1
              xf86-video-intel-1:2.99.917+746+g169c74f-2  xorg-server-1.19.0-3  xorg-server-common-1.19.0-3
              xorg-server-devel-1.19.0-3  zeromq-4.2.0-1

Total Installed Size:  276.85 MiB
Net Upgrade Size:        2.39 MiB

:: Proceed with installation? [Y/n] 
(20/20) checking keys in keyring                                                [##############################################] 100%
(20/20) checking package integrity                                              [##############################################] 100%
(20/20) loading package files                                                   [##############################################] 100%
(20/20) checking for file conflicts                                             [##############################################] 100%
error: failed to commit transaction (conflicting files)
libxfont2: /usr/include/X11/fonts/libxfont2.h exists in filesystem
libxfont2: /usr/lib/libXfont2.so exists in filesystem
libxfont2: /usr/lib/libXfont2.so.2 exists in filesystem
libxfont2: /usr/lib/libXfont2.so.2.0.0 exists in filesystem
libxfont2: /usr/lib/pkgconfig/xfont2.pc exists in filesystem
Errors occurred, no packages were upgraded.

Thanks in advance!

Last edited by menfie (2016-12-21 00:14:23)

Offline

#2 2016-12-20 23:36:27

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,146
Website

Re: [SOLVED] Can't upgrade xorg-server to 1.19

https://wiki.archlinux.org/index.php/Pa … 9.22_error

Mod note: Moving to Testing.

EDIT: As you're using testing, you're probably not too concerned by potential breakage, however I would still recommend that you remove archlinuxfr.

Last edited by WorMzy (2016-12-20 23:40:36)


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2016-12-20 23:40:50

menfie
Member
Registered: 2016-12-18
Posts: 12

Re: [SOLVED] Can't upgrade xorg-server to 1.19

WorMzy wrote:

I already saw that wiki page. But I don't know if it can cause issues simply forcing it or renaming / moving file. What do you think I should do? (I'm fairly new to Arch and Linux)

Offline

#4 2016-12-20 23:43:26

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,424
Website

Re: [SOLVED] Can't upgrade xorg-server to 1.19

menfie wrote:
WorMzy wrote:

I already saw that wiki page. But I don't know if it can cause issues simply forcing it or renaming / moving file. What do you think I should do? (I'm fairly new to Arch and Linux)

Why are you using [testing] if you don't know how to administer your machine?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2016-12-20 23:45:18

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,804

Re: [SOLVED] Can't upgrade xorg-server to 1.19

The link tells you exactly what to do; it doesn't just say to use --force.

Offline

#6 2016-12-20 23:49:46

menfie
Member
Registered: 2016-12-18
Posts: 12

Re: [SOLVED] Can't upgrade xorg-server to 1.19

jasonwryan wrote:
menfie wrote:
WorMzy wrote:

I already saw that wiki page. But I don't know if it can cause issues simply forcing it or renaming / moving file. What do you think I should do? (I'm fairly new to Arch and Linux)

Why are you using [testing] if you don't know how to administer your machine?

Because I want to get rid of tearing as I read that the latest xorg-server can fix this. I know how to administer my machine but I'm just not that advanced to know what it can cause to ignore this error.

https://devtalk.nvidia.com/default/topi … gt620-m-/9


Scimmia wrote:

The link tells you exactly what to do; it doesn't just say to use --force.

I simply asked for it in here because I don't know what this package doing exactly and is it safe to ignore this error.

Last edited by menfie (2016-12-20 23:50:59)

Offline

Board footer

Powered by FluxBB