You are not logged in.

#1 2017-01-07 21:38:57

jdoggsc
Member
Registered: 2011-08-15
Posts: 91

Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

Hey all,

I've had this problem for a while now--over a year. When it initially happened, I couldn't find any useful info here or google, so I just switched to a different desktop environment for a while.  Now i'm back to wanting to use Cinnamon again, and I get the exact same issue when starting.  I get a black screen with a single message box without decorations in Adwaita(?) theme that says

Could not connect to session bus: Failed to connect to socket /run/user/1000/bus: Connection refused

the only option is a "Log Out" button, which takes me back to the display manager or terminal, depending on my login method.

the journalctl output:

cinnamon-session[1416]: WARNING: t+0.00012s: Could not make bus activated clients aware of DISPLAY=:1 environment variable: Failed to connect to socket /run/user/1000/bus: Connection refused
cinnamon-session[1416]: WARNING: t+0.00025s: Could not make bus activated clients aware of GNOME_DESKTOP_SESSION_ID=this-is-deprecated environment variable: Failed to connect to socket /run/user/1000/bus: Connection refused
cinnamon-session[1416]: WARNING: t+0.00031s: Could not make bus activated clients aware of QT_QPA_PLATFORMTHEME=qt5ct environment variable: Failed to connect to socket /run/user/1000/bus: Connection refused
cinnamon-session[1416]: WARNING: t+0.00049s: Could not make bus activated clients aware of GTK_OVERLAY_SCROLLING=1 environment variable: Failed to connect to socket /run/user/1000/bus: Connection refused

I did a

# pacman -Rnsc cinnamon

and additionally

$ cd ~
$ find . | grep cinnamon

and

# find / | grep cinnamon

searching for and removing any sort of Cinnamon-related files both user-related and systemwide.

I then reinstalled, but to no avail.  Everything looks exactly the same as before.

I know precious little about dbus--I've never had any problems with it otherwise!  I have no idea what to do, and obviously no idea what to to google, because I haven't seen any solutions for problems that look similar to this one.

Any help is appreciated.  Thanks!

Last edited by jdoggsc (2017-01-16 01:24:56)

Offline

#2 2017-01-07 22:17:03

ayekat
Member
Registered: 2011-01-17
Posts: 1,462
Website

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

Hi - please paste the output of these commands:

ls -l /run/user/1000/bus
ps up $(pgrep dbus)
echo $DBUS_SESSION_BUS_ADDRESS

Last edited by ayekat (2017-01-07 22:17:33)


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#3 2017-01-07 22:58:24

jdoggsc
Member
Registered: 2011-08-15
Posts: 91

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

thanks for the response!

Here's the output of those commands:

$ ls -l /run/user/1000/bus
srw-rw-rw- 1 jdoggsc users 0 Jan  7 17:03 /run/user/1000/bus
ps up $(pgrep dbus)
dbus       288  0.0  0.0  40464  4428 ?        Ss   17:03   0:00 /usr/bin/dbus-d
jdoggsc       478  0.0  0.0  40436  4652 ?        Ss   17:04   0:00 /usr/bin/dbus-d
jdoggsc       629  0.0  0.0  39752  3820 ?        S    17:04   0:00 /usr/bin/dbus-d
echo $DBUS_SESSION_BUS_ADDRESS
unix:path=/run/user/1000/bus

Last edited by jdoggsc (2017-01-08 00:13:51)

Offline

#4 2017-01-07 23:58:06

Batou
Member
Registered: 2017-01-03
Posts: 243

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

Interestingly, my output is the same as yours except for this:

$  ps up $(pgrep dbus)
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
dbus       475  0.0  0.0  40460  4628 ?        Ss   18:36   0:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
batou        614  0.0  0.0  40212  4352 ?        Ss   18:36   0:00 /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation
batou        637  0.0  0.0  39748  3836 ?        S    18:36   0:00 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3

Is your output cut off? My cinnamon works fine. Maybe this will help you track down the issue...

Last edited by Batou (2017-01-08 00:05:03)


Please vote for all the AUR packages you're using. You can mass-vote for all of them by doing: "pacman -Qqm | xargs aurvote -v" (make sure to run "aurvote --configure"  first)

Offline

#5 2017-01-08 00:13:05

jdoggsc
Member
Registered: 2011-08-15
Posts: 91

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

hmm.  the output must have been cut off at the end of the screen.  My output is actually similar to yours:

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
dbus       288  0.0  0.0  40464  4428 ?        Ss   17:03   0:00 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
jdoggsc       478  0.0  0.0  40432  4652 ?        Ss   17:04   0:03 /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation
jdoggsc       629  0.0  0.0  39752  3820 ?        S    17:04   0:00 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3

Last edited by jdoggsc (2017-01-08 00:13:29)

Offline

#6 2017-01-09 08:56:56

seth
Member
Registered: 2012-09-03
Posts: 23,845

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

https://bbs.archlinux.org/viewtopic.php … 1#p1650451 ?

Otherwise: How do yor run the session?

Offline

#7 2017-01-09 14:10:35

jdoggsc
Member
Registered: 2011-08-15
Posts: 91

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

Thanks for the response. I don't have any .pacnew files in that directory.  Thanks for the suggestion, though.

How do I run the session? I have used gdm,kdm,sddm,slim, and lxdm but the result is the same. I was trying them out just to test them out--not necessarily for the purpose of troubleshooting this issue.  More recently I have been foregoing a DM for other reasons and just use startx. My .xinitrc file calls

exec cinnamon-session

just as the wiki instructs.

Last edited by jdoggsc (2017-01-09 14:11:01)

Offline

#8 2017-01-09 16:47:08

seth
Member
Registered: 2012-09-03
Posts: 23,845

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

when this happens, don't logout. move to VT1 and run

ps fax | grep -B5 dbus-lauch

If this matches anything but the grep, follow the other thread. get rid of the dbus-launch invocation.
Otherwise: do you have  /etc/systemd/user/(dbus.service, dbus.socket)?

Offline

#9 2017-01-16 01:24:03

jdoggsc
Member
Registered: 2011-08-15
Posts: 91

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

So I didn't approach it very methodically, but I tried various things to determine what was hindering me. I tried logging in right after a boot and got as far as desktop icons being loaded. There were no window decorations or any sort of system window that would show up (no trays, no launchers, no alt+f2 menu).  There was a window saying that cinnamon crashed and was running in fallback mode.  I then tried using nouveau drivers instead of nvidia and that didn't make a difference. journalctl simply said

Jan 12 19:37:45 jdoggsc cinnamon-session[610]: WARNING: t+36.68297s: Application 'cinnamon.desktop' failed to register before timeout
Jan 12 19:37:45 jdoggsc cinnamon-session[610]: CRITICAL: t+36.68319s: We failed, but the fail whale is dead. Sorry....

  Some dev has a sense of humor...  Also, nothing in /var/logs

To make a long story short, I took some drastic action. There were some other things that were cluttery and the problem was affecting other DEs as well.  I felt like I wanted a fresh start and used pacman to remove all but the base packages--essentially taking me down to a clean install except for config files.  I installed nvidia drivers, xorg, and cinnamon--so the bare minimum to be able to run cinnamon--rebooted and tried start a graphical session.  Still the same stupid problem about dbus.

I created a new user and tried logging in to a graphical session as the new user. Voila! Success!! (I'd actually forgotten how much I like cinnamon). The problem was being caused by some sort of cache or config file in my home directory.  I compared all files in my original user folder and the files in my new folder, and deleted all files that existed in both.  This includes files in .cinnamon, .config and .cache, and others that I don't remember anymore.  I then tried logging in on my original user account and the problem persisted. I emptied my home folder completely and started a graphical session.  Success again.  I then loaded my non-hidden folders and files back in, as well as folders I am more familiar with like .ssh.  All other per-program config settings are lost now, so it's like I have a fresh install, but that's fine.

In short, I'm not sure what was ultimately responsible for the issues I was having with dbus.  I did, however, find out that it's related to some config or cache file in the user home folder, and that a fresh home folder will eliminate the problem. It's not worth it to me to add stuff in one-at-a-time and test ability to login, so I let this suffice.

Offline

#10 2017-01-19 03:22:31

jdoggsc
Member
Registered: 2011-08-15
Posts: 91

Re: Cinnamon startup error: "Failed to connect to session bus" [SOLVED]

So I'm posting after I marked this [SOLVED] several days ago. Doing so is probably frowned upon by moderators, but I just located the source of my problem.

in my journalctl output, I ignored the following line:

Jan 18 22:10:45 jdoggsc cinnamon-session[833]: WARNING: t+0.01214s: Unable to find required component 'polkit-gnome-authentication-agent-1

a quick search for a resolution to this led me to https://wiki.archlinux.org/index.php/Polkit where I learned to reinstall gnome-polkit.

gnome-polkit was in conflict with xfce-polkit-git.  removing the xfce polkit and installing the gnome polkit worked like a charm and now everything works perfectly.

I may be the only person on the planet with this issue, but at least it's documented here with a real resolution so perchance there's a poor soul with the same problem, they don't have to waste most of a week work of evenings trying to solve this blindly like I did.

Last edited by jdoggsc (2017-01-19 03:23:54)

Offline

Board footer

Powered by FluxBB