You are not logged in.

#1 2017-01-30 14:46:47

Registered: 2017-01-30
Posts: 6

[SOLVED] Lenovo Yoga 500 - Broadcom BCM43162 driver doesn't work

Hi, I have Lenovo Yoga 500 and I can't detect my wifi adapter Broadcom BCM43162.

[thyrst@melone ~]$ sudo lspci -vnn -d 14e4:
[sudo] password for thyrst: 
02:00.0 Network controller [0280]: Broadcom Limited BCM43162 802.11ac Wireless Network Adapter [14e4:43ae] (rev 02)
	Subsystem: Lenovo Device [17aa:0622]
	Flags: bus master, fast devsel, latency 0, IRQ 18
	Memory at c1400000 (64-bit, non-prefetchable) [size=32K]
	Memory at c1000000 (64-bit, non-prefetchable) [size=4M]
	Capabilities: [48] Power Management version 3
	Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [68] Vendor Specific Information: Len=44 <?>
	Capabilities: [ac] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [13c] Device Serial Number 00-00-08-ff-ff-00-30-0e
	Capabilities: [150] Power Budgeting <?>
	Capabilities: [160] Virtual Channel
	Capabilities: [1b0] Latency Tolerance Reporting
	Capabilities: [220] #15
	Kernel modules: wl

[thyrst@melone ~]$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 54:ee:75:98:6d:23 brd ff:ff:ff:ff:ff:ff
    inet brd scope global enp3s0
       valid_lft forever preferred_lft forever
    inet6 fe80::5b28:20e:1044:191/64 scope link 
       valid_lft forever preferred_lft forever

I don't know what to do.. I have tried either b43-firmware and broadcom-wl drivers.

Last edited by Thyrst (2017-02-02 12:15:44)


#2 2017-02-02 12:13:59

Registered: 2017-01-30
Posts: 6

Re: [SOLVED] Lenovo Yoga 500 - Broadcom BCM43162 driver doesn't work

I found out that there aren't kernel drivers available for BCM43162, so I was trying to find drivers for Windows, so I could make it work with ndiswrapper. However there aren't necessary drivers for ndiswrapper also (source: … 1#p1273509).

Solved by buying TP-Link TL-WN722N.


Board footer

Powered by FluxBB