You are not logged in.

#1 2017-02-05 10:13:29

Arhangel64
Member
Registered: 2016-12-13
Posts: 6

Qt 5.8? Plasma 5.9? radeon driver update?

Hello everyone.
I'm not quite sure what exactly happened but looks like something broke in my system around qt apps.

I have radeon HD 6850M graphic card and for some time i used catalyst drivers. Day before yesterday i decided to switch back on opensource driver. At first it looked like it worked fine, may be i just haven't noticed any issue. This morning i noticed that fonts in chromium are kinda blurred. I found out that KMail and QupZilla dont work at all - they open up and there is a complete salad of pieces of screen inside of the window, mixing into new templates with every window refresh. Before i noticed this behaviour i made pacman -Syu. After i noticed all those crap i made -Syu again and there was xf86-video-ati in the list of the packages. So, after i reboot the laptop the the same salad of broken peices of screen was instead of my plasma workspace. It goes the same with plasma on wayland, and, what's more interesting, sddm worked fine! Some of qt apps work - like kate, some don't like kmail, akregator. Those who don't work write to console this "pp: Failed to translate a shader for blend2fs".
So, i'm not sure what exactly caused this, but i need help. Thanks for your atention.

Offline

#2 2017-02-05 13:50:56

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,390

Re: Qt 5.8? Plasma 5.9? radeon driver update?

pp stands for "post processing" and i have had similar issues.

If foo is one of the affected programs try running like this :

PP_DEBUG=1 pp_jimenezmlaa=0 pp_jimenezmlaa_color=0 foo

if that solves the issue, post processing is broken for you like it was for me mesa bug #99549 .

the package driconf can help to disable post processing per-user.

Are you using stock mesa ? if so, try downgrading the xf86-video-ati driver to the previous version from your /var/cache/pacman/pkg folder.

Last edited by Lone_Wolf (2017-02-05 13:51:31)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2017-02-05 14:35:05

Arhangel64
Member
Registered: 2016-12-13
Posts: 6

Re: Qt 5.8? Plasma 5.9? radeon driver update?

Thank you, man! You just saved my day. Installing driconf and pulling everything about post processing to zero completely solved all of the problems!

Offline

Board footer

Powered by FluxBB