You are not logged in.

#1 2017-02-17 15:03:28

TenShiN
Member
Registered: 2017-02-17
Posts: 4

nvidia-dkms probably fails

After today's update I can't get into X on my zen kernel. dmesg gives an error about nvidia modules being of version 375, while rest of nvidia related packages is 378. I tried to regenerate dkms and reinstall packages, but it still gives me the same error. Anyone with the same issue?

Offline

#2 2017-02-17 15:07:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,875

Re: nvidia-dkms probably fails

What, exactly, happens when you reinstall it? What kernel are you running specifically (check uname -r and pacman -Q linux-zen)?

Offline

#3 2017-02-17 15:09:39

TenShiN
Member
Registered: 2017-02-17
Posts: 4

Re: nvidia-dkms probably fails

Not on zen right now, so can't do uname -r, but both linux-zen and linux-zen-headers packages are of version 4.9.9-1, so I assume latest.
And actually nothing suspicious happens. It just finishes installation silently.

Last edited by TenShiN (2017-02-17 15:13:39)

Offline

#4 2017-02-17 16:29:06

TenShiN
Member
Registered: 2017-02-17
Posts: 4

Re: nvidia-dkms probably fails

I reinstalled everything again and got this after installation of linux-zen (nvidia-dkms was already present):

==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly
(3/3) Arming ConditionNeedsUpdate...

After reinstallation of linux-zen and linux-zen-headers it finishes ok though. But doesn't work after reboot with error that I specified in a first post.

Last edited by TenShiN (2017-02-17 16:38:05)

Offline

#5 2017-02-17 16:41:51

TenShiN
Member
Registered: 2017-02-17
Posts: 4

Re: nvidia-dkms probably fails

okay. After another try it worked for some reason. I don't know what happened and how it got fixed, but I'll take it.

Offline

#6 2017-02-23 21:41:14

lothar_m
Member
From: Portugal
Registered: 2010-04-25
Posts: 29
Website

Re: nvidia-dkms probably fails

There is an issue with the mkinitcpio being run prior to to the dkms modules being rebuild. I haven't found any solution for this and have to run mkinitcpio manually after the linux package updates, otherwise I'll end up with an unbootable system.

check this bugreport


“Clearly, Field Marshal Haig is about to make yet another gargantuan effort to move his drinks cabinet six inches closer to Berlin.”
-----------------------------------------------------------------------------
GitHub

Offline

Board footer

Powered by FluxBB