You are not logged in.

#1 2006-06-04 11:53:09

Archeree
Member
Registered: 2006-05-29
Posts: 17

again X Acceleration in XGL

This is on my other Dell Inspiron 8100 lappy nVidia GeForce2Go 32 MB video card.

I've managed to get everything running in less than 15 mins ( Video + 3D Accel + KDE + XGL)

All that on a stock kernel.

Now as I am always running a custom build kernel (used the supplied .config file as a base and have the arch appended) the only thing that is bothering me now is the glxinfo output which is NO TO DIRECT RENDERING

I've also installed the driver on NVIDIA website

And YES I have different versions to Client/Server in GLXINFO 1.2 1.4 ...

I've tried what's on the wiki pages about solving this by linking the libs:

ln -s /usr/lib/libGL.so.1.0.8762 /usr/X11R6/lib/libGL.so

ln -s /usr/lib/libGL.so.1.0.8762 /usr/X11R6/lib/libGL.so.1

ln -s /usr/lib/libGL.so.1.0.8762 /usr/lib/libGL.so.1.2


tried with both drivers (pacman -S nvidia and the one in the nVidia website..) I was inclined to try with the nVidia installer as I'm using the latest non-stock kernel.

Noticed that I've no Load "dri" in my xconf.org , added it but again nothing in glxinfo

XGL is RUNNING PERFECTLY AND .... SEEMS A BIT FASTER!!  :shock:

EDIT:
I've also noticed that when I startxgl it says amongst the other things that is "using card: Other" , Now if IIRC it was nvidia smth like that before, not 100% sure though.. somehow it's just crossing my mind whther I should re-install XGL after the custom kernel build? What do you reckon?


LAST EDIT: Well after my last contemplation I've decided to do just startx and see what's in glxinfo .... YES.. big_smile

and run glxgears -- 800 FPS  :shock:  (well at first I said to myself it's an old card....)

exit, startxgl, glxinfo direct rendering again is not working, then glxgears and 1400 FPS  :shock:
this is roughly 80% improvement without any tweaks, and my Radeon M9 64MB is giving 2200-2400 in Slackware 10.2 current

Thinking about re-installing XGL but will wait for your opinions

Thanks guys.

Offline

#2 2006-06-04 12:29:46

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

And here's the weirdest thing I found out..

startx and I'm in gnome then in a console I typed startxgl and guesss what(at least I never expected that) I'm running KDE in an XGLx window (basically both gnome and kde) smile

I open console in each of these and glxinfo is giveing the same results, glxgears different results but as mmentioned above..

In any case this is an OLD VIDEO CARD but there is no low performance at all.... - It just flies over everything and again surprisingly no decrease in performance at all..

Bascially I'm rotating my KDE desktop in a CUBE in a window in Gnome at a remarkable speed and high quality graphics....NO EDGES anywhere in the rendering....

That's Bloody Brilliant!

Offline

#3 2006-06-04 12:52:50

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: again X Acceleration in XGL

Archeree wrote:

And here's the weirdest thing I found out..

startx and I'm in gnome then in a console I typed startxgl and guesss what(at least I never expected that) I'm running KDE in an XGLx window (basically both gnome and kde) smile

I open console in each of these and glxinfo is giveing the same results, glxgears different results but as mmentioned above..

In any case this is an OLD VIDEO CARD but there is no low performance at all.... - It just flies over everything and again surprisingly no decrease in performance at all..

Bascially I'm rotating my KDE desktop in a CUBE in a window in Gnome at a remarkable speed and high quality graphics....NO EDGES anywhere in the rendering....

That's Bloody Brilliant!


This is why linux loves love linux, we can spend close to nothing on what everyone considers to be crappy hardware and have them pumping out more FPS and better rendering than their new cards wink

Offline

#4 2006-06-05 08:42:23

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

In Summary:

Custom 2.6.16.19 kernel

And

nVidia driver from website

in startx -> 3D Acceleration -> Yes glxgears 800 FPS

in startxgl -> 3D Accelaeration -> No glxgears 1400 FPS

Any ideas?

Offline

#5 2006-06-05 14:43:39

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

I think I've traced the problem

when I startxgl it does output using card other (as opposed to nvidia) and when I go through the source of /usr/bin/startxgl it seems that it goes to "other" as it can't find the "nvidia" driver

Any ideas from now on how to solve it?
Thanks

Offline

#6 2006-06-05 16:08:34

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

come on guys, what the hell > 150 people have read this thread..

should I ask on a Slackware forum :mrgreen:

Offline

#7 2006-06-05 18:35:01

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

is there anyone out there who has the 3D acceleration enabled on XGL?i.e. glxinfo -> yes to direct rendering

at least 170 people have read this thread and there should be people running XGL

(I have 2 laptops and roughly the same result with nvidia & ati cards)

On a side note I feel like I am going crazy chatting to myself in here..

Offline

#8 2006-06-05 20:13:24

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: again X Acceleration in XGL

I think that, when you use XGL, glxinfo will erroneously report that you have  no direct rendering even though you have it enabled. I don't use XGL myself but I think it was mentionned in the big XGL thread.

EDIT: I think this is the thread: http://bbs.archlinux.org/viewtopic.php?t=20488

Offline

#9 2006-06-05 20:39:42

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: again X Acceleration in XGL

@snowman if you did try XGL ten minutes later you would be bored by wobbly windows & stop using it ...


Mr Green

Offline

#10 2006-06-05 21:48:03

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

MrGreen I am showing off that graphic thingy to my mates, in addition I'll be sending a laptop to my dad who is into all sorts of tech gadgets and without doubt this is revoultionary and he will like/loves the way a desktop looks like.

I am also not bored using it for a month.

Snowman - I've had a very quick look through the thread but can't see anything about that, will browse it again though,in the mean time correct me if I'm wrong please.

Offline

#11 2006-06-05 23:31:57

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: again X Acceleration in XGL

@Mr Green: That's what I thought after looking at the screenshots. I didn't bothered reading about it or installing it. I'm not really into that eye-candy stuff.

@Archeree: It could be in another thread. Do a forum search for xgl and glxinfo.

Offline

#12 2006-06-06 07:30:30

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: again X Acceleration in XGL

some of the features of XGL are cool ..... but the main thing is the use of graf card memory which makes desktop quicker ....

But I use OB its light enough & fast enough

No I have tried XGL & you are right to show off yes .... but to use everyday its not for me


Mr Green

Offline

#13 2006-06-06 10:06:02

Archeree
Member
Registered: 2006-05-29
Posts: 17

Re: again X Acceleration in XGL

@Mr Green What is OB? tried googling it for arch but it seems an abbreviation to me. Thanks.

Offline

#14 2006-06-06 10:27:32

kps
Member
Registered: 2006-04-30
Posts: 30

Re: again X Acceleration in XGL

OB = Openbox

Offline

#15 2006-06-06 17:35:57

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: again X Acceleration in XGL

lol .... oops sorry  :oops:


Mr Green

Offline

#16 2006-06-06 19:10:22

sweiss
Member
Registered: 2004-02-16
Posts: 635

Re: again X Acceleration in XGL

Why are XGL and the likes always regarded as useless eye candy?

I want it for the sake of the expose effect. That effect is simply useful.

Offline

#17 2006-06-06 19:42:52

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: again X Acceleration in XGL

then why not try Skippy ;-)


Mr Green

Offline

#18 2006-06-07 18:11:18

sweiss
Member
Registered: 2004-02-16
Posts: 635

Re: again X Acceleration in XGL

I have. Didn't like it, though.

Offline

Board footer

Powered by FluxBB