You are not logged in.

#1 2016-12-29 13:54:27

cappuccino
Member
Registered: 2012-12-26
Posts: 83

[SOLVED] Plasma crash

Plasma desktop suddenly crashed and now after I login, I can only see the wallpaper, mouse does not work, panel is gone. After 30s screen becomes black and everything freezes. I tried with another user, but it doesn´t help.
The only thing still working is krunner. So when I restart plasma, this is what I get:

Reusing existing ksycoca
Recreating ksycoca file ("/home/thenudiebear/.cache/ksycoca5_C_gICp_oqj95IeMQRczKmVyerFDww=", version 303)
Still in the time dict (i.e. deleted files) ("apps")
Menu "applications-kmenuedit.menu" not found.
Saving
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml:83: TypeError: Cannot read property 'Layout' of null
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property of null
file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property of null                                                                                                                 
file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property of null                                                                                                                 
file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property of null                                                                                                                 
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:78:27: Unable to assign [undefined] to QStringList                                                                         
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined                                                                
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml:443:5: QML Text: Cannot anchor to a null item.                                                                     
Notifications service registered                                                                                                                                                                               
file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property of null                                                                                                                 
libkcups: Create-Printer-Subscriptions last error: 0 successful-ok                                                                                                                                             
libkcups: Get-Jobs last error: 0 successful-ok                                                                                                                                                                 
libkcups: Get-Jobs last error: 0 successful-ok                                                                                                                                                                 
Plasma Shell startup completed                                                                                                                                                                                 
libkcups: 2                                                                                                                                                                                                    
KCrash: Attempting to start /usr/bin/plasmashell from kdeinit                                                                                                                                                  
sock_file=/run/user/1000/kdeinit5__0                                                                                                                                                                           
KCrash: Application 'plasmashell' crashing...                                                                                                                                                                  
KCrash: Attempting to start /usr/lib/drkonqi from kdeinit                                                                                                                                                      
sock_file=/run/user/1000/kdeinit5__0                                                                                                                                                                           
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...                                                                                                                                                
QSocketNotifier: Invalid socket 17 and type 'Read', disabling...

My system/fully updated:

Kernel: 4.8.13-1-ARCH x86_64 (64 bit gcc: 6.2.1)
Desktop: KDE Plasma 5.8.5 (Qt 5.7.1)
Device: laptop System: Hewlett-Packard product: HP Compaq 6730b
Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0
Display Server: N/A drivers: intel (unloaded: modesetting,vesa) Resolution: 207x60

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
        Subsystem: Hewlett-Packard Company Device 30dd
        Kernel driver in use: i915
        Kernel modules: i915

lsmod
i915                 1241088  12
i2c_algo_bit           16384  1 i915
button                 16384  1 i915
intel_gtt              20480  2 intel_agp,i915
drm_kms_helper        126976  1 i915
drm                   294912  8 i915,ttm,drm_kms_helper

Any thoughts?

Last edited by cappuccino (2017-01-26 02:13:36)

Offline

#2 2016-12-29 13:59:10

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: [SOLVED] Plasma crash

Is the filesystem corrupt? Did you just do an upgrade or install some packages? If so, what was upgraded/installed?


Matt

"It is very difficult to educate the educated."

Offline

#3 2016-12-29 14:56:46

cappuccino
Member
Registered: 2012-12-26
Posts: 83

Re: [SOLVED] Plasma crash

It actually started to crash after this update:

starting full system upgrade
running '70-dkms-remove.hook'...
==> dkms remove vboxguest/5.1.10_OSE -k 4.8.12-2-ARCH
==> dkms remove vboxhost/5.1.10_OSE -k 4.8.12-2-ARCH
transaction started
removed konsolekalendar (16.08.3-1)
removed kdepim-common (16.08.3-1)
removed ktnef (16.08.3-1)
removed kdeutils-kgpg (16.08.3-1)
removed kdegraphics-okular (16.08.3-2)
removed kdebase-konq-plugins (16.08.3-1)
removed kdebase-konqueror (16.08.3-1)
removed kdebase-kfind (16.08.3-1)
removed kdebase-keditbookmarks (16.08.3-1)
removed kdebase-kdialog (16.08.3-1)
removed fuse (2.9.7-1)
removed libastro (16.08.3-1)
upgraded filesystem (2015.09-1 -> 2016.12-2)
upgraded ncurses (6.0+20161112-1 -> 6.0+20161203-1)
upgraded readline (7.0-1 -> 7.0.001-1)
upgraded bash (4.4.005-1 -> 4.4.005-2)
upgraded icu (58.1-2 -> 58.2-1)
upgraded libgcrypt (1.7.3-1 -> 1.7.5-1)
upgraded libsystemd (232-4 -> 232-6)
upgraded coreutils (8.25-2 -> 8.26-1)
upgraded systemd (232-4 -> 232-6)
upgraded libinput (1.5.2-1 -> 1.5.3-1)
upgraded libtiff (4.0.7-1 -> 4.0.7-2)
upgraded gnutls (3.4.16-1 -> 3.4.17-1)
upgraded llvm-libs (3.9.0-3 -> 3.9.1-1)
upgraded qt5-base (5.7.0-7 -> 5.7.1-1)
upgraded qt5-xmlpatterns (5.7.0-2 -> 5.7.1-1)
upgraded qt5-declarative (5.7.0-3 -> 5.7.1-1)
upgraded udisks2 (2.1.7-1 -> 2.1.8-1)
upgraded solid (5.28.0-1 -> 5.29.0-1)
upgraded kcoreaddons (5.28.0-1 -> 5.29.0-1)
upgraded kwidgetsaddons (5.28.0-1 -> 5.29.0-1)
upgraded qt5-x11extras (5.7.0-1 -> 5.7.1-1)
upgraded kjobwidgets (5.28.0-1 -> 5.29.0-1)
upgraded qt5-script (5.7.0-1 -> 5.7.1-1)
upgraded ki18n (5.28.0-1 -> 5.29.0-1)
upgraded kconfig (5.28.0-1 -> 5.29.0-1)
upgraded kwindowsystem (5.28.0-1 -> 5.29.0-1)
upgraded kcrash (5.28.0-1 -> 5.29.0-1)
upgraded kdbusaddons (5.28.0-1 -> 5.29.0-1)
upgraded kservice (5.28.0-1 -> 5.29.0-1)
upgraded kglobalaccel (5.28.0-1 -> 5.29.0-1)
upgraded kcompletion (5.28.0-1 -> 5.29.0-1)
upgraded qt5-svg (5.7.0-1 -> 5.7.1-1)
upgraded kauth (5.28.0-1 -> 5.29.0-1)
upgraded kcodecs (5.28.0-1 -> 5.29.0-1)
upgraded kguiaddons (5.28.0-1 -> 5.29.0-1)
upgraded kconfigwidgets (5.28.0-1 -> 5.29.0-1)
upgraded kitemviews (5.28.0-1 -> 5.29.0-1)
upgraded karchive (5.28.0-1 -> 5.29.0-1)
upgraded kiconthemes (5.28.0-1 -> 5.29.0-1)
upgraded sonnet (5.28.0-3 -> 5.29.0-1)
upgraded ktextwidgets (5.28.0-1 -> 5.29.0-1)
upgraded attica-qt5 (5.28.0-1 -> 5.29.0-1)
upgraded kxmlgui (5.28.0-1 -> 5.29.0-1)
upgraded kbookmarks (5.28.0-1 -> 5.29.0-1)
upgraded alsa-lib (1.1.2-1 -> 1.1.3-1)
upgraded cairo (1.14.6-2 -> 1.14.8-1)
upgraded knotifications (5.28.0-1 -> 5.29.0-1)
upgraded gnupg (2.1.16-1 -> 2.1.17-3)
upgraded kwallet (5.28.0-1 -> 5.29.0-1)
upgraded kinit (5.28.0-1 -> 5.29.0-1)
upgraded kio (5.28.0-1 -> 5.29.0-1)
upgraded kitemmodels (5.28.0-1 -> 5.29.0-1)
upgraded libmariadbclient (10.1.19-1 -> 10.1.20-1)
upgraded mariadb-clients (10.1.19-1 -> 10.1.20-1)
upgraded mariadb (10.1.19-1 -> 10.1.20-1)
upgraded akonadi (16.08.3-1 -> 16.12.0-1)
upgraded kmime (16.08.3-1 -> 16.12.0-1)
upgraded akonadi-mime (16.08.3-1 -> 16.12.0-1)
upgraded kpackage (5.28.0-2 -> 5.29.1-1)
upgraded kdeclarative (5.28.0-1 -> 5.29.0-1)
upgraded kcmutils (5.28.0-1 -> 5.29.0-1)
upgraded kunitconversion (5.28.0-1 -> 5.29.0-1)
upgraded kemoticons (5.28.0-1 -> 5.29.0-1)
upgraded kded (5.28.0-1 -> 5.29.0-1)
upgraded kparts (5.28.0-1 -> 5.29.0-1)
upgraded kdelibs4support (5.28.0-1 -> 5.29.0-1)
upgraded kmailtransport (16.08.3-1 -> 16.12.0-1)
upgraded kcalcore (16.08.3-1 -> 16.12.0-1)
installed syntax-highlighting (5.29.0-1)
upgraded kpimtextedit (16.08.3-1 -> 16.12.0-1)
upgraded kidentitymanagement (16.08.3-1 -> 16.12.0-1)
upgraded kcalutils (16.08.3-1 -> 16.12.0-1)
upgraded kcontacts (16.08.3-1 -> 16.12.0-1)
upgraded qt5-webchannel (5.7.0-1 -> 5.7.1-1)
upgraded qt5-location (5.7.0-1 -> 5.7.1-1)
upgraded openjpeg2 (2.1.2-1 -> 2.1.2-2)
upgraded libssh (0.7.3-1 -> 0.7.3-2)
upgraded speex (1.2rc2-1 -> 1.2.0-1)
upgraded libpsl (0.15.0-6 -> 0.16.1-1)
upgraded curl (7.51.0-2 -> 7.52.1-1)
upgraded qt5-webengine (5.7.0-7 -> 5.7.1-1)
upgraded prison (5.28.git20161116-1 -> 5.29.0-1)
upgraded akonadi-contacts (16.08.3-1 -> 16.12.0-1)
upgraded akonadi-calendar (16.08.3-1 -> 16.12.0-1)
upgraded akonadi-notes (16.08.3-1 -> 16.12.0-1)
upgraded qt5-quickcontrols (5.7.0-1 -> 5.7.1-1)
upgraded kactivities (5.28.0-1 -> 5.29.0-1)
upgraded plasma-framework (5.28.0-1 -> 5.29.0-1)
upgraded threadweaver (5.28.0-1 -> 5.29.0-1)
upgraded krunner (5.28.0-1 -> 5.29.0-1)
upgraded akonadi-search (16.08.3-1 -> 16.12.0-1)
installed qgpgme (1.7.1-2)
upgraded libkleo (16.08.3-2 -> 16.12.0-1)
upgraded kmbox (16.08.3-1 -> 16.12.0-1)
upgraded kldap (16.08.3-1 -> 16.12.0-1)
upgraded libkdepim (16.08.3-1 -> 16.12.0-1)
upgraded knewstuff (5.28.0-1 -> 5.29.0-1)
upgraded kimap (16.08.3-1 -> 16.12.0-1)
upgraded pimcommon (16.08.3-1 -> 16.12.0-1)
upgraded grantleetheme (16.08.3-1 -> 16.12.0-1)
upgraded kdepim-apps-libs (16.08.3-1 -> 16.12.0-1)
upgraded kholidays (16.08.3-1 -> 16.12.0-1)
upgraded calendarsupport (16.08.3-1 -> 16.12.0-1)
upgraded libgravatar (16.08.3-1 -> 16.12.0-1)
upgraded qt5-sensors (5.7.0-1 -> 5.7.1-1)
upgraded qt5-webkit (5.7.0-3 -> 5.7.1-1)
upgraded messagelib (16.08.3-1 -> 16.12.0-1)
upgraded akonadiconsole (16.08.3-1 -> 16.12.0-1)
upgraded alsa-utils (1.1.2-1 -> 1.1.3-1)
upgraded kpty (5.28.0-1 -> 5.29.0-1)
upgraded libarchive (3.2.1-2 -> 3.2.2-1)
upgraded ark (16.08.3-1 -> 16.12.0-1)
upgraded poppler (0.49.0-1 -> 0.50.0-1)
upgraded poppler-qt5 (0.49.0-1 -> 0.50.0-1)
upgraded kfilemetadata (5.28.0-1 -> 5.29.0-1)
upgraded kidletime (5.28.0-1 -> 5.29.0-1)
upgraded baloo (5.28.0-1 -> 5.29.0-1)
upgraded baloo-widgets (16.08.3-1 -> 16.12.0-1)
upgraded bluez-qt (5.28.0-1 -> 5.29.0-1)
upgraded breeze-icons (5.28.0-1 -> 5.29.0-1)
upgraded kdesu (5.28.0-1 -> 5.29.0-1)
upgraded cervisia (16.08.3-1 -> 16.12.0-1)
upgraded chromaprint (1.4-2 -> 1.4.1-1)
upgraded ocl-icd (2.2.9-1 -> 2.2.10-1)
upgraded imagemagick (6.9.6.6-2 -> 6.9.6.8-1)
upgraded cups-filters (1.12.0-1 -> 1.13.1-1)
upgraded libkipi (16.08.3-1 -> 16.12.0-1)
upgraded intel-tbb (2017_20161004-1 -> 2017_20161128-1)
upgraded xine-lib (1.2.6-10 -> 1.2.6-11)
upgraded jasper (1.900.5-1 -> 1.900.31-1)
upgraded gdk-pixbuf2 (2.36.0+2+ga7c869a-1 -> 2.36.1+31+gecea71eb6-1)
upgraded gtk-update-icon-cache (3.22.4-1 -> 3.22.5-1)
upgraded opencv (3.1.0-3 -> 3.1.0-6)
upgraded knotifyconfig (5.28.0-1 -> 5.29.0-1)
upgraded libxpm (3.5.11-1 -> 3.5.12-1)
upgraded python2 (2.7.12-2 -> 2.7.13-1)
upgraded libksane (16.08.3-1 -> 16.12.0-1)
upgraded qt5-multimedia (5.7.0-1 -> 5.7.1-1)
 upgraded marble-data (16.08.3-1 -> 16.12.0-1)
upgraded quazip (0.7.2-3 -> 0.7.2-4)
upgraded marble (16.08.3-1 -> 16.12.0-1)
upgraded digikam (5.3.0-1 -> 5.3.0-6)
upgraded kjs (5.28.0-1 -> 5.29.0-1)
upgraded khtml (5.28.0-1 -> 5.29.0-1)
upgraded kdnssd (5.28.0-1 -> 5.29.0-1)
upgraded tdb (1.3.11-1 -> 1.3.12-1)
upgraded libwbclient (4.5.1-2 -> 4.5.3-1)
upgraded ldb (1.1.27-1 -> 1.1.29-1)
upgraded smbclient (4.5.1-2 -> 4.5.3-1)
upgraded kio-extras (16.08.3-1 -> 16.12.0-1)
upgraded dolphin (16.08.3-1 -> 16.12.0-1)
upgraded dolphin-plugins (16.08.3-1 -> 16.12.0-1)
upgraded dragon (16.08.3-1 -> 16.12.0-2)
installed kdiagram (2.6.0-1)
upgraded eventviews (16.08.3-1 -> 16.12.0-1)
upgraded ffmpeg2.8 (2.8.8-1 -> 2.8.9-1)
upgraded ffmpegthumbs (16.08.3-1 -> 16.12.0-1)
upgraded filelight (16.08.3-1 -> 16.12.0-1)
upgraded gtk3 (3.22.4-1 -> 3.22.5-1)
upgraded firefox (50.0.2-1 -> 50.1.0-1)
upgraded firefox-i18n-de (50.0.2-1 -> 50.1.0-1)
upgraded flashplugin (11.2.202.644-1 -> 24.0.0.186-1)
upgraded frameworkintegration (5.28.0-1 -> 5.29.0-1)
installed fuse-common (3.0.0-1)
installed fuse2 (2.9.7-3)
upgraded gegl02 (0.2.0-4 -> 0.2.0-7)
upgraded geoip-database (20161004-1 -> 20161206-1)
upgraded gimp (2.8.18-1 -> 2.8.18-3)
upgraded git (2.10.2-1 -> 2.11.0-2)
upgraded grep (2.26-1 -> 2.27-1)
upgraded gstreamer0.10-bad (0.10.23-18 -> 0.10.23-20)
upgraded libgme (0.6.0-5 -> 0.6.1-1)
upgraded gstreamer0.10-bad-plugins (0.10.23-18 -> 0.10.23-20)
upgraded libraw (0.17.2-1 -> 0.17.2-3)
upgraded libkdcraw (16.08.3-1 -> 16.12.0-1)
upgraded gwenview (16.08.3-1 -> 16.12.0-1)
upgraded incidenceeditor (16.08.3-1 -> 16.12.0-1)
upgraded inxi (2.3.4-1 -> 2.3.5-1)
upgraded iproute2 (4.8.0-1 -> 4.9.0-1)
upgraded signon-kwallet-extension (16.08.3-1 -> 16.12.0-1)
upgraded kaccounts-integration (16.08.3-1 -> 16.12.0-1)
upgraded kactivities-stats (5.28.0-1 -> 5.29.0-1)
upgraded kontactinterface (16.08.3-1 -> 16.12.0-1)
upgraded mailimporter (16.08.3-1 -> 16.12.0-1)
upgraded mailcommon (16.08.3-1 -> 16.12.0-1)
upgraded libkgapi (5.3.1-1 -> 5.3.1-2)
upgraded libkolab (1.0.2-2 -> 1.0.2-3)
upgraded kross (5.28.0-1 -> 5.29.0-1)
upgraded kalarmcal (16.08.3-1 -> 16.12.0-1)
upgraded kdepim-runtime (16.08.3-1 -> 16.12.0-1)
upgraded kaddressbook (16.08.3-1 -> 16.12.0-1)
upgraded kalarm (16.08.3-1 -> 16.12.0-1)
upgraded kamera (16.08.3-1 -> 16.12.0-1)
upgraded kapptemplate (16.08.3-1 -> 16.12.0-1)
upgraded ktexteditor (5.28.0-1 -> 5.29.0-1)
upgraded kate (16.08.3-1 -> 16.12.0-1)
upgraded kcalc (16.08.3-1 -> 16.12.0-1)
upgraded kcharselect (16.08.3-1 -> 16.12.0-1)
upgraded kcron (16.08.3-1 -> 16.12.0-1)
upgraded kde-dev-scripts (16.08.3-1 -> 16.12.0-1)
upgraded qt5-translations (5.7.0-1 -> 5.7.1-1)
upgraded kde-l10n-de (16.08.3-1 -> 16.12.0-2)
upgraded kde-syndication (16.08.3-1 -> 16.12.0-1)
upgraded kdelibs (4.14.26-1 -> 4.14.27-1)
upgraded oxygen-icons (1:5.28.0-1 -> 1:5.29.0-1)
upgraded kdebase-runtime (16.08.3-4 -> 16.12.0-1)
upgraded kdeaccessibility-jovie (16.08.3-1 -> 16.12.0-1)
upgraded kdeaccessibility-kaccessible (16.08.3-1 -> 16.12.0-1)
upgraded kdeaccessibility-kmag (16.08.3-1 -> 16.12.0-1)
upgraded kdeaccessibility-kmousetool (16.08.3-1 -> 16.12.0-1)
upgraded kdeaccessibility-kmouth (16.08.3-1 -> 16.12.0-1)
installed kdialog (16.12.0-1)
installed keditbookmarks (16.12.0-1)
installed kfind (16.12.0-1)
installed konqueror (16.12.0-2)
upgraded kdegraphics-ksaneplugin (16.08.3-1 -> 16.12.0-1)
upgraded kdegraphics-mobipocket (16.08.3-1 -> 16.12.0-1)
upgraded libkexiv2 (16.08.3-1 -> 16.12.0-1)
installed okular (16.12.0-1)
upgraded kdegraphics-thumbnailers (16.08.3-1 -> 16.12.0-1)
upgraded kdemultimedia-juk (16.08.3-1 -> 16.12.0-1)
upgraded kdemultimedia-kmix (16.08.3-1 -> 16.12.0-1)
upgraded kdemultimedia-kscd (16.08.3-1 -> 16.12.0-1)
upgraded kdenetwork-filesharing (16.08.3-1 -> 16.12.0-1)
upgraded kdenetwork-kppp (16.08.3-1 -> 16.12.0-1)
upgraded kdenetwork-zeroconf-ioslave (16.08.3-1 -> 16.12.0-1)
upgraded libktnef (16.08.3-1 -> 16.12.0-1)
upgraded kdepim-addons (16.08.3-1 -> 16.12.0-1)
upgraded kdesdk-dev-utils (16.08.3-1 -> 16.12.0-1)
upgraded kdesdk-kcachegrind (16.08.3-1 -> 16.12.0-1)
upgraded libunistring (0.9.6-2 -> 0.9.7-1)
upgraded kdesdk-thumbnailers (16.08.3-1 -> 16.12.0-1)
installed kgpg (16.12.0-1)
upgraded kdeutils-sweeper (16.08.3-1 -> 16.12.0-1)
upgraded kdewebdev-kfilereplace (16.08.3-1 -> 16.12.0-1)
upgraded kdewebdev-kimagemapeditor (16.08.3-1 -> 16.12.0-1)
upgraded kdewebdev-klinkstatus (16.08.3-1 -> 16.12.0-1)
upgraded kdewebdev-kommander (16.08.3-1 -> 16.12.0-1)
upgraded kdf (16.08.3-1 -> 16.12.0-1)
upgraded kdoctools (5.28.0-1 -> 5.29.0-1)
upgraded kfloppy (16.08.3-1 -> 16.12.0-1)
upgraded khelpcenter (16.08.3-1 -> 16.12.0-1)
upgraded kipi-plugins (5.3.0-1 -> 5.3.0-6)
upgraded kjsembed (5.28.0-1 -> 5.29.0-1)
upgraded kleopatra (16.08.3-1 -> 16.12.0-1)
installed kmail-account-wizard (16.12.0-1)
installed akonadi-import-wizard (16.12.0-1)
installed mbox-importer (16.12.0-1)
upgraded libksieve (16.08.3-1 -> 16.12.0-1)
installed pim-sieve-editor (16.12.0-1)
installed pim-storage-service-manager (16.12.0-1)
upgraded kmail (16.08.3-1 -> 16.12.0-1)
upgraded knotes (16.08.3-1 -> 16.12.0-1)
upgraded kolourpaint (16.08.3-1 -> 16.12.0-1)
upgraded libkomparediff2 (16.08.3-1 -> 16.12.0-1)
upgraded kompare (16.08.3-1 -> 16.12.0-1)
upgraded konsole (16.08.3-1 -> 16.12.0-1)
installed akonadi-calendar-tools (16.12.0-1)
upgraded kontact (16.08.3-1 -> 16.12.0-1)
upgraded korganizer (16.08.3-1 -> 16.12.0-1)
upgraded libkdegames (16.08.3-1 -> 16.12.0-1)
upgraded kpatience (16.08.3-1 -> 16.12.0-1)
upgraded kpeople (5.28.0-1 -> 5.29.0-1)
upgraded krdc (16.08.3-1 -> 16.12.0-1)
upgraded krfb (16.08.3-1 -> 16.12.0-1)
upgraded ksystemlog (16.08.3-1 -> 16.12.0-1)
upgraded ktimer (16.08.3-1 -> 16.12.0-1)
upgraded kwalletmanager (16.08.3-1 -> 16.12.0-1)
upgraded kwayland (5.28.0-1 -> 5.29.0-1)
upgraded kwrite (16.08.3-1 -> 16.12.0-1)
upgraded kxmlrpcclient (5.28.0-1 -> 5.29.0-1)
upgraded libcdio (0.93-4 -> 0.94-2)
upgraded libnm-glib (1.4.2-2 -> 1.4.4-1)
upgraded libreoffice-still (5.1.6-3 -> 5.1.6-4)
upgraded linux (4.8.12-2 -> 4.8.13-1)
>>> Updating module dependencies. Please wait ...
upgraded linux-headers (4.8.12-2 -> 4.8.13-1)
upgraded lirc (1:0.9.4.c-1 -> 1:0.9.4.c-2)
upgraded logrotate (3.10.0-1 -> 3.11.0-1)
upgraded lokalize (16.08.3-2 -> 16.12.0-1)
upgraded man-db (2.7.5-4 -> 2.7.6.1-2)
upgraded man-pages (4.08-1 -> 4.09-1)
upgraded modemmanager-qt (5.28.0-1 -> 5.29.0-1)
upgraded nano (2.7.1-1 -> 2.7.2-1)
upgraded wpa_supplicant (1:2.6-2 -> 1:2.6-4)
:: The /etc/wpa_supplicant/wpa_supplicant.conf is file no longer managed by pacman
    and if it was modified, it has been renamed to wpa_supplicant.conf.pacsave.
    Move it to the original location if needed.
upgraded slang (2.3.0-1 -> 2.3.1a-1)
upgraded zeromq (4.1.5-1 -> 4.2.0-1)
upgraded networkmanager (1.4.2-2 -> 1.4.4-1)
upgraded networkmanager-qt (5.28.0-1 -> 5.29.0-1)
upgraded okteta (16.08.3-1 -> 16.12.0-1)
warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
upgraded pacman-mirrorlist (20161203-1 -> 20161214-1)
upgraded poppler-qt4 (0.49.0-1 -> 0.50.0-1)
upgraded poxml (16.08.3-1 -> 16.12.0-1)
upgraded print-manager (16.08.3-1 -> 16.12.0-1)
upgraded python-requests (2.12.3-1 -> 2.12.4-1)
upgraded python-setuptools (1:28.8.0-1 -> 1:32.2.0-1)
upgraded python2-lxml (3.6.4-1 -> 3.7.1-1)
upgraded python2-setuptools (1:28.8.0-1 -> 1:32.2.0-1)
upgraded python2-pip (8.1.2-1 -> 9.0.1-1)
upgraded python2-zope-interface (4.3.2-1 -> 4.3.3-1)
upgraded qt5-graphicaleffects (5.7.0-1 -> 5.7.1-1)
upgraded qt5-tools (5.7.0-2 -> 5.7.1-1)
upgraded spectacle (16.08.3-1 -> 16.12.0-1)
upgraded subversion (1.9.4-1 -> 1.9.5-1)
upgraded systemd-sysvcompat (232-4 -> 232-6)
upgraded umbrello (16.08.3-1 -> 16.12.0-1)
upgraded user-manager (5.8.4-1 -> 5.8.4-2)
upgraded virtualbox-host-dkms (5.1.10-1 -> 5.1.12-1)
upgraded virtualbox (5.1.10-1 -> 5.1.12-1)
upgraded virtualbox-guest-dkms (5.1.10-1 -> 5.1.12-1)
upgraded virtualbox-guest-iso (5.1.10-1 -> 5.1.12-1)
upgraded virtualbox-guest-utils (5.1.10-1 -> 5.1.12-1)
upgraded wavpack (4.80.0-1 -> 5.0.0-1)
upgraded wget (1.18-2 -> 1.18-3)
upgraded xf86-video-intel (1:2.99.917+740+g9ac7a33-1 -> 1:2.99.917+746+g169c74f-1)
upgraded youtube-dl (2016.12.01-1 -> 2016.12.22-1)
transaction completed
running '70-dkms-install.hook'...
==> dkms install vboxguest/5.1.12_OSE -k 4.8.13-1-ARCH
==> dkms install vboxhost/5.1.12_OSE -k 4.8.13-1-ARCH
running '99-linux.hook'...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.8.13-1-ARCH
   -> Running build hook: [base]
   -> Running build hook: [udev]
   -> Running build hook: [autodetect]
   -> Running build hook: [modconf]
   -> Running build hook: [block]
   -> Running build hook: [filesystems]
   -> Running build hook: [keyboard]
   -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.8.13-1-ARCH
   -> Running build hook: [base]
   -> Running build hook: [udev]
   -> Running build hook: [modconf]
   -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
   -> Running build hook: [filesystems]
   -> Running build hook: [keyboard]
   -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
running 'gdk-pixbuf-query-loaders.hook'...
running 'glib-compile-schemas.hook'...
running 'gtk-query-immodules-3.0.hook'...
running 'gtk-update-icon-cache.hook'...
running 'texinfo-install.hook'...
running 'udev-hwdb.hook'...
running 'update-desktop-database.hook'...
running 'update-mime-database.hook'...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'

And today´s update:

starting full system upgrade
transaction started
upgraded bluedevil (1:5.8.4-1 -> 1:5.8.5-1)
upgraded kdecoration (5.8.4-1 -> 5.8.5-1)
upgraded breeze (5.8.4-1 -> 5.8.5-1)
upgraded breeze-gtk (5.8.4-1 -> 5.8.5-1)
upgraded drkonqi (5.8.4-1 -> 5.8.5-1)
upgraded x265 (2.1-2 -> 2.2-1)
upgraded ffmpeg (1:3.2.2-1 -> 1:3.2.2-2)
upgraded ffmpeg2.8 (2.8.9-1 -> 2.8.9-2)
upgraded gst-plugins-bad (1.10.2-1 -> 1.10.2-2)
upgraded kactivitymanagerd (5.8.4-1 -> 5.8.5-1)
upgraded kde-cli-tools (5.8.4-1 -> 5.8.5-1)
upgraded kde-gtk-config (5.8.4-1 -> 5.8.5-1)
upgraded libksysguard (5.8.4-1 -> 5.8.5-1)
upgraded milou (5.8.4-1 -> 5.8.5-1)
upgraded kscreenlocker (5.8.4-1 -> 5.8.5-1)
upgraded kwin (5.8.4-1 -> 5.8.5-1)
upgraded plasma-integration (5.8.4-1 -> 5.8.5-1)
upgraded kuiserver (5.8.4-1 -> 5.8.5-1)
upgraded plasma-workspace (5.8.4-1 -> 5.8.5-1)
upgraded kdeplasma-addons (5.8.4-1 -> 5.8.5-1)
upgraded kgamma5 (5.8.4-1 -> 5.8.5-1)
upgraded khotkeys (5.8.4-1 -> 5.8.5-1)
upgraded kinfocenter (5.8.4-1 -> 5.8.5-1)
upgraded kmenuedit (5.8.4-1 -> 5.8.5-1)
upgraded libkscreen (5.8.4-1 -> 5.8.5-1)
upgraded kscreen (5.8.4-1 -> 5.8.5-1)
upgraded ksshaskpass (5.8.4-1 -> 5.8.5-1)
upgraded ksysguard (5.8.4-1 -> 5.8.5-1)
upgraded kwallet-pam (5.8.4-1 -> 5.8.5-1)
upgraded kwayland-integration (5.8.4-1 -> 5.8.5-1)
upgraded kwrited (5.8.4-1 -> 5.8.5-1)
upgraded lib32-llvm-libs (3.9.0-1 -> 3.9.1-1)
upgraded oxygen (5.8.4-1 -> 5.8.5-1)
upgraded polkit-kde-agent (5.8.4-1 -> 5.8.5-1)
upgraded systemsettings (5.8.4-1 -> 5.8.5-1)
upgraded plasma-desktop (5.8.4-1 -> 5.8.5-1)
upgraded plasma-nm (5.8.4-1 -> 5.8.5-1)
upgraded plasma-pa (5.8.4-1 -> 5.8.5-1)
upgraded plasma-sdk (5.8.4-1 -> 5.8.5-1)
upgraded plasma-workspace-wallpapers (5.8.4-1 -> 5.8.5-1)
upgraded powerdevil (5.8.4-1 -> 5.8.5-1)
upgraded python-setuptools (1:32.2.0-1 -> 1:32.3.1-1)
upgraded python2-setuptools (1:32.2.0-1 -> 1:32.3.1-1)
upgraded sddm-kcm (5.8.4-1 -> 5.8.5-1)
upgraded user-manager (5.8.4-2 -> 5.8.5-1)
upgraded vlc (2.2.4-5 -> 2.2.4-6)
transaction completed
running 'gtk-update-icon-cache.hook'...
running 'update-desktop-database.hook'...
running 'update-mime-database.hook'...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
pacman -Qm

acpidump 4.0-1
audiothumbs-frameworks r5.d10c667-1
brother-brgenml1 3.1.0_1-3
crack-attack 1.1.14-7
crack-attack-sounds 1.1.14-4
downgrade 5.4.0-1
google-earth 7.1.7.2606-1
gpgmepp 16.08.3-1
hpoj 0.91-21
kdeadmin-kuser 16.08.3-1
kdebase-lib 16.08.3-1
kdemultimedia-audiocd-kio 16.08.3-2
kdemultimedia-mplayerthumbs 16.04.3-1
kdgantt2 16.08.3-1
ld-lsb 3-7
libkexiv2_4 15.08.3-2
libkscreen4 1.0.5-2
netcfg 3.2-1
package-query 1.8-2
skype 4.3.0.37-8
virtualbox-ext-oracle 5.1.12-1
yaourt 1.8.1-1

Offline

#4 2016-12-29 15:15:24

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,140
Website

Re: [SOLVED] Plasma crash

kdebase-lib? Looks like you still have KDE4 stuff installed which your (probably) don't need any more. Clean up your system (check for unneeded packages using 'pacman -Qtd').


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2016-12-29 16:43:12

cappuccino
Member
Registered: 2012-12-26
Posts: 83

Re: [SOLVED] Plasma crash

pacman -Qtd didn´t help. I have no more ideas what to do...

Offline

#6 2016-12-29 17:19:33

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 147

Re: [SOLVED] Plasma crash

hi, you still have some old packages 16.08 version and the updated 16.12 like kuser (and maybe another ones), your system is not well updated and probably some packages make some conflict in libs, and with KDE4 libs :-/ could be re-install yours kde system to be sure to have the good/updated dependencies


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#7 2016-12-29 21:45:56

seth
Member
Registered: 2012-09-03
Posts: 12,929

Re: [SOLVED] Plasma crash

KCrash: Attempting to start /usr/lib/drkonqi from kdeinit

pacman -S drkonqi

You should now get a crash dialog including a backtrace which will tell you (or us ;-) where it crashes (and maybe why)

Offline

#8 2017-01-26 02:17:02

cappuccino
Member
Registered: 2012-12-26
Posts: 83

Re: [SOLVED] Plasma crash

Reinstallation ...

Offline

#9 2017-01-30 02:25:10

normaldotcom
Member
Registered: 2012-09-18
Posts: 6

Re: [SOLVED] Plasma crash

Have you had any success solving this issue? Just encountered the same thing after updating.

Drkonqi is installed, but never launches. If I delete Panel.qml or just manually remove the panel containment from my ~/.config/plasma-org.kde.plasma.desktop-appletsrc, everything starts up correctly (with the exception of the panel).

I have tried removing Panel.qml and reinstalling plasma, but that didn't solve the problem either.

Thanks!

Offline

#10 2017-03-13 01:04:44

mueslo
Member
Registered: 2011-10-15
Posts: 26

Re: [SOLVED] Plasma crash

Same thing just started happening for me after I updated. Any updates?

Packages changed:

$ tail -10000 /var/log/pacman.log | grep -E "2017-03.*] upgraded (plasma|kwin|print-manager|glib|linux)"
[2017-03-03 11:00] [ALPM] upgraded kwin (5.9.2-1 -> 5.9.3-1)
[2017-03-03 11:00] [ALPM] upgraded plasma-integration (5.9.2-1 -> 5.9.3-1)
[2017-03-03 11:00] [ALPM] upgraded plasma-workspace (5.9.2-1 -> 5.9.3-1)
[2017-03-03 11:00] [ALPM] upgraded plasma-desktop (5.9.2-1 -> 5.9.3-1)
[2017-03-03 11:00] [ALPM] upgraded plasma-nm (5.9.2-1 -> 5.9.3-1)
[2017-03-03 11:00] [ALPM] upgraded plasma-pa (5.9.2-1 -> 5.9.3-1)
[2017-03-03 11:00] [ALPM] upgraded plasma-sdk (5.9.2-1 -> 5.9.3-2)
[2017-03-03 11:00] [ALPM] upgraded plasma-workspace-wallpapers (5.9.2-1 -> 5.9.3-1)
[2017-03-12 19:15] [ALPM] upgraded linux-api-headers (4.7-1 -> 4.10.1-1)
[2017-03-12 19:15] [ALPM] upgraded glibc (2.24-2 -> 2.25-1)
[2017-03-12 19:16] [ALPM] upgraded linux-firmware (20170217.12987ca-2 -> 20170227.5abb924-1)
[2017-03-12 19:16] [ALPM] upgraded linux (4.9.11-1 -> 4.10.1-1)
[2017-03-12 19:16] [ALPM] upgraded plasma-workspace (5.9.3-1 -> 5.9.3-2)
[2017-03-12 19:16] [ALPM] upgraded plasma-meta (5.9-1 -> 5.9-2)
[2017-03-12 19:16] [ALPM] upgraded print-manager (16.12.2-1 -> 16.12.3-1)

output when directly running plasmashell

kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
Qt WebEngine seems to be initialized from a plugin. Please set Qt::AA_ShareOpenGLContexts using QCoreApplication::setAttribute before constructing QGuiApplication.
Loading Calendar plugin PimEventsPlugin(0x3e69940)
Loading Calendar plugin HolidaysEventsPlugin(0x3ef6010)
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
couldn't load "/usr/lib/qt/plugins/discover-notifier/DiscoverPackageKitNotifier.so" because "Die Bibliothek /usr/lib/qt/plugins/discover-notifier/DiscoverPackageKitNotifier.so kann nicht geladen werden: (libpackagekitqt5.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)"
couldn't find any notifier backend ("/usr/lib/qt/plugins", "/usr/bin")
inotify_add_watch("/etc/fstab") failed: "Permission denied"
Notifications service registered
libkcups: Create-Printer-Subscriptions last error: 0 successful-ok
libkcups: Get-Jobs last error: 0 successful-ok
libkcups: Get-Jobs last error: 0 successful-ok
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property of null
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Plasma Shell startup completed
Registering "org.kde.StatusNotifierItem-941-1/StatusNotifierItem"
libkcups: 6
KCrash: Attempting to start /usr/bin/plasmashell from kdeinit
sock_file=/run/user/1002/kdeinit5__0
KCrash: Application 'plasmashell' crashing...
KCrash: Attempting to start /usr/lib/drkonqi from kdeinit
sock_file=/run/user/1002/kdeinit5__0
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 17 and type 'Read', disabling...
[1]  + 7557 suspended (signal)  plasmashell

gdb backtrace

(gdb) bt
#0  0x00007fff1458a096 in JobModel::updateJob(int, KCupsJob const&) () at /usr/lib/libkcupslib.so
#1  0x00007fff1458e8e3 in JobModel::getJobFinished() () at /usr/lib/libkcupslib.so
#2  0x00007fff145931b5 in  () at /usr/lib/libkcupslib.so
#3  0x00007ffff1e94ba9 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#4  0x00007ffff2dd634c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#5  0x00007ffff2dddb61 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#6  0x00007ffff1e68440 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#7  0x00007ffff1e6abcd in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#8  0x00007ffff1ebcc43 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007fffec3885a7 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#10 0x00007fffec388810 in  () at /usr/lib/libglib-2.0.so.0
#11 0x00007fffec3888bc in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#12 0x00007ffff1ebd04f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#13 0x00007ffff1e6689a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#14 0x00007ffff1e6ede4 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#15 0x000000000041ca42 in  ()
#16 0x00007ffff14d4511 in __libc_start_main () at /usr/lib/libc.so.6
#17 0x000000000041cdca in _start ()

syslog output

Mär 13 02:11:01 whdd22235 drkonqi[7910]: found lsb_release
Mär 13 02:11:01 whdd22235 drkonqi[7910]: Using /proc to determine executable path
Mär 13 02:11:01 whdd22235 drkonqi[7910]: Executable is: "/usr/bin/plasmashell"
Mär 13 02:11:01 whdd22235 drkonqi[7910]: Executable exists: true
Mär 13 02:11:01 whdd22235 drkonqi[7910]: Enabling drkonqi crash catching
Mär 13 02:11:01 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:01 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:01 whdd22235 kded5[788]: Registering "org.kde.StatusNotifierItem-7910-1/StatusNotifierItem" to system tray
Mär 13 02:11:02 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:02 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:04 whdd22235 drkonqi[7910]: Sending SIGSTOP to process
Mär 13 02:11:04 whdd22235 kwin_x11[841]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 35045, resource id: 2097166, major code: 15 (QueryTree), minor code: 0
Mär 13 02:11:07 whdd22235 plasmashell[7909]: Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
Mär 13 02:11:07 whdd22235 plasmashell[7909]: Qt WebEngine seems to be initialized from a plugin. Please set Qt::AA_ShareOpenGLContexts using QCoreApplication::setAttribute before constructing QGuiApplication.
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Loading Calendar plugin PimEventsPlugin(0x3be50a0)
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Loading Calendar plugin HolidaysEventsPlugin(0x3c9b000)
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Both point size and pixel size set. Using pixel size.
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Both point size and pixel size set. Using pixel size.
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Both point size and pixel size set. Using pixel size.
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Mär 13 02:11:08 whdd22235 plasmashell[7909]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Mär 13 02:11:08 whdd22235 plasmashell[7909]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Mär 13 02:11:08 whdd22235 plasmashell[7909]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Mär 13 02:11:08 whdd22235 plasmashell[7909]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Mär 13 02:11:08 whdd22235 plasmashell[7909]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Mär 13 02:11:08 whdd22235 plasmashell[7909]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:44:32: Unable to assign [undefined] to int
Mär 13 02:11:08 whdd22235 kded5[788]: Registering "org.kde.StatusNotifierHost-7909" as system tray
Mär 13 02:11:08 whdd22235 kded5[788]: Service  "org.kde.StatusNotifierItem-941-20" unregistered
Mär 13 02:11:08 whdd22235 kded5[788]: Registering "org.kde.StatusNotifierItem-941-1/StatusNotifierItem" to system tray
Mär 13 02:11:08 whdd22235 plasmashell[7909]: couldn't load "/usr/lib/qt/plugins/discover-notifier/DiscoverPackageKitNotifier.so" because "Die Bibliothek /usr/lib/qt/plugins/discover-notifier/DiscoverPackageKitNotifier.so kann nicht geladen werden: (libpackagekitqt5.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)"
Mär 13 02:11:08 whdd22235 plasmashell[7909]: couldn't find any notifier backend ("/usr/lib/qt/plugins", "/usr/bin")
Mär 13 02:11:08 whdd22235 plasmashell[7909]: inotify_add_watch("/etc/fstab") failed: "Permission denied"
Mär 13 02:11:08 whdd22235 akonadi_davgroupware_resource[1251]: org.kde.knotifications: warning: failed to connect to ActionInvoked dbus signal
Mär 13 02:11:08 whdd22235 plasmashell[7909]: Notifications service registered
Mär 13 02:11:08 whdd22235 yakuake[942]: org.kde.knotifications: warning: failed to connect to ActionInvoked dbus signal
Mär 13 02:11:08 whdd22235 yakuake[942]: org.kde.knotifications: warning: failed to connect to NotificationClosed dbus signal
Mär 13 02:11:08 whdd22235 akonadi_davgroupware_resource[1251]: org.kde.knotifications: warning: failed to connect to NotificationClosed dbus signal
Mär 13 02:11:08 whdd22235 plasmashell[7909]: libkcups: Create-Printer-Subscriptions last error: 0 successful-ok
Mär 13 02:11:08 whdd22235 plasmashell[7909]: libkcups: Get-Jobs last error: 0 successful-ok
Mär 13 02:11:08 whdd22235 plasmashell[7909]: libkcups: Get-Jobs last error: 0 successful-ok
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 plasmashell[7909]: kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/plasma-popupapplet.desktop, tried ("/home/jfalke/.local/share", "/usr/share", "/usr/local/share")
Mär 13 02:11:09 whdd22235 kdeconnectd[1521]: kdeconnect.core: Sending onNetworkChange to  1  LinkProviders
Mär 13 02:11:09 whdd22235 plasmashell[7909]: Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
Mär 13 02:11:09 whdd22235 kdeconnectd[1521]: kdeconnect.core: Broadcasting identity packet
Mär 13 02:11:09 whdd22235 plasmashell[7909]: Plasma Shell startup completed
Mär 13 02:11:09 whdd22235 plasmashell[7909]: Registering "org.kde.StatusNotifierItem-941-1/StatusNotifierItem"
Mär 13 02:11:09 whdd22235 plasmashell[7909]: libkcups: 6
Mär 13 02:11:09 whdd22235 kernel: plasmashell[7909]: segfault at 0 ip 00007fa8ed1bd096 sp 00007ffe631f62e0 error 4 in libkcupslib.so[7fa8ed177000+5f000]
Mär 13 02:11:09 whdd22235 systemd[1]: Started Process Core Dump (PID 7928/UID 0).
Mär 13 02:11:11 whdd22235 systemd-coredump[7929]: Core file was truncated to 2147483648 bytes.
Mär 13 02:11:12 whdd22235 systemd-coredump[7929]: Process 7909 (plasmashell) of user 1002 dumped core.
                                                   
                                                   Stack trace of thread 7909:
                                                   #0  0x00007fa8ed1bd096 _ZN8JobModel9updateJobEiRK8KCupsJob (/usr/lib/libkcupslib.so)
Mär 13 02:11:13 whdd22235 kded5[788]: Service  "org.kde.StatusNotifierHost-7909" unregistered
Mär 13 02:11:13 whdd22235 kwin_x11[841]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 35351, resource id: 117440526, major code: 15 (QueryTree), minor code: 0
Mär 13 02:11:13 whdd22235 korgac[945]: org.kde.knotifications: env says KDE is running but SNI unavailable -- check KDE_FULL_SESSION and XDG_CURRENT_DESKTOP
Mär 13 02:11:13 whdd22235 kded5[788]: Service  "org.kde.StatusNotifierItem-941-1" unregistered
Mär 13 02:11:13 whdd22235 drkonqi[7910]: org.kde.knotifications: env says KDE is running but SNI unavailable -- check KDE_FULL_SESSION and XDG_CURRENT_DESKTOP
Mär 13 02:11:13 whdd22235 kded5[788]: Registering "org.kde.StatusNotifierItem-941-21/StatusNotifierItem" to system tray

Update: Removing ~/.cache and ~/.config does *not* fix the problem -- it seems to be a package issue. Removing print-manager (owner of libkcupslib.so) [pacman -Rdd print-manager] mitigates the problem, but now I'm missing native KDE printer functionality.

Last edited by mueslo (2017-03-14 11:05:59)

Offline

#11 2017-04-07 07:01:56

ulf_n
Member
Registered: 2017-04-07
Posts: 1

Re: [SOLVED] Plasma crash

Hi,

I'm using manjaro but I had exactly the same problem after the last upgrade. Although it occurred not immediately after upgrading, but a few days later. In fact it occurred while my laptop stuck in a dockingstation and I changed the monitor configuration by opening its display and closing it again. From then on the plasmashell keeps crashing.

The given solution by mueslo worked fine but doesn't seem to handle the real reason.

I tried to downgrade both concerned packages (print-manager and plasma-workspace(plasmashell) ) one by one and both, but no former working combination worked for me anymore.

Does anybody have any idea, what else could be responsible for the crash?

[ulf@mdl ~]$ tail -10000 /var/log/pacman.log | grep -E "2017-04.*] upgraded (plasma|kwin|print-manager|glib|linux)"
[2017-04-03 17:59] [ALPM] upgraded kwin (5.9.3-1 -> 5.9.4-1)
[2017-04-03 17:59] [ALPM] upgraded plasma-integration (5.9.3-1 -> 5.9.4-1)
[2017-04-03 17:59] [ALPM] upgraded plasma-workspace (5.9.3-2 -> 5.9.4-1)
[2017-04-03 17:59] [ALPM] upgraded linux44 (4.4.55-1 -> 4.4.59-1)
[2017-04-03 17:59] [ALPM] upgraded linux44-bbswitch (0.8-42 -> 0.8-44)
[2017-04-03 17:59] [ALPM] upgraded linux44-ndiswrapper (1.61-10 -> 1.61-12)
[2017-04-03 17:59] [ALPM] upgraded plasma-desktop (5.9.3-4 -> 5.9.4-1)
[2017-04-03 17:59] [ALPM] upgraded plasma-nm (5.9.3-1 -> 5.9.4-1)
[2017-04-03 17:59] [ALPM] upgraded plasma-pa (5.9.3-1 -> 5.9.4-1)
[2017-04-03 17:59] [ALPM] upgraded plasma-workspace-wallpapers (5.9.3-1 -> 5.9.4-1)

Offline

#12 2017-04-07 10:40:11

TioDuke
Member
Registered: 2009-08-06
Posts: 24

Re: [SOLVED] Plasma crash

Try downgrading to kernel 4.10.6.

I've had the same problem after updating the kernel two days ago. Plasma and kde applications kept on crashing. Downgrading the kernel did the trick for me. I have already posted a question in this forums but nobody replied. Please, keep us informed if it works for you.


[img]http://boincstats.com/signature/-1/user/2670943/sig.png[/img]

Offline

#13 2017-04-07 11:37:44

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,140
Website

Re: [SOLVED] Plasma crash

Please ask on the Manjaro forums, we only support Arch.

https://wiki.archlinux.org/index.php/Co … .2Aonly.2A

Closing.


Continuing: https://bbs.archlinux.org/viewtopic.php?id=224918


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB