You are not logged in.

#1 2017-03-18 23:38:33

spencerjp
Member
Registered: 2013-09-27
Posts: 10

[SOLVED] Sound Card Not Recognized

Today after updating/restarting my only listed audio output channel was "Dummy Output". Gnome's settings and pavucontrol both only list this.

I have a Dell XPS 15" 9550.

Output of aplay -l:

aplay: device_list:270: no soundcards found...

Output of lspci:

00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.1 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #2 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1d.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1)
00:1d.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #15 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev ff)
02:00.0 Network controller: Broadcom Limited BCM43602 802.11ac Wireless LAN SoC (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
04:00.0 Non-Volatile memory controller: Device 1c5c:1283

I'm about to try messing with my laptop-mode tools settings for power saving to see if they're killing it, will update. Thanks!!

Edit: Disabling sound card control did nothing. Also tried booting laptop connected to power, no change. I don't think powersaving is the issue.

Last edited by spencerjp (2017-03-20 23:31:26)

Offline

#2 2017-03-19 07:10:51

seth
Member
Registered: 2012-09-03
Posts: 1,630

Re: [SOLVED] Sound Card Not Recognized

Does it work w/a pulseaudio? (you'll likely have to log into a VT and exit any gnome session to test this)

Offline

#3 2017-03-19 12:19:15

mich41
Member
Registered: 2012-06-22
Posts: 706

Re: [SOLVED] Sound Card Not Recognized

HD Audio ought to work. Check if there are any pcm* files in /dev/snd. If not, post dmesg.

Offline

#4 2017-03-20 23:29:50

spencerjp
Member
Registered: 2013-09-27
Posts: 10

Re: [SOLVED] Sound Card Not Recognized

Turns out the wiki page was updated with information about this. Basically it's just a bug that resolves itself randomly after reboots/wakes. sad

Sound is working right now. Here's the output of find /dev/snd -name pcm* for kicks:

/dev/snd/pcmC0D8p
/dev/snd/pcmC0D7p
/dev/snd/pcmC0D3p
/dev/snd/pcmC0D0c
/dev/snd/pcmC0D0p

Offline

Board footer

Powered by FluxBB