You are not logged in.

#1 2017-04-21 17:44:48

thomas17
Member
Registered: 2017-03-01
Posts: 17

Boot errors

Hi all,

I have a HP Elitebook 850 G3 with two graphic cards. I do not know which one is in use but want to be able to change them. I am a bit confused, what I have to install an configure :-)
Also I found some ACPI and EFI errors I do not find some help via google. How can I fix them?

journalctl:
Apr 21 19:10:11 archhost kernel: efi: requested map not found.
Apr 21 19:10:11 archhost kernel: esrt: ESRT header is not in the memory map.

dmesg:
[   10.603970] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff88042c8455a0 (20160930/exresop-594)
[   10.603974] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20160930/dswexec-461)
[   10.603978] ACPI Error: Method parse/execution failed [\_SB.WMIV.WVPO] (Node ffff8804308a2820), AE_AML_OPERAND_TYPE (20160930/psparse-543)                                                                                                                             
[   10.603983] ACPI Error: Method parse/execution failed [\_SB.WMIV.WMPV] (Node ffff8804308a2230), AE_AML_OPERAND_TYPE (20160930/psparse-543)                                                                                                                             
[   10.605096] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff8804308a97e0 (20160930/exresop-594)
[   10.605099] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20160930/dswexec-461)
[   10.605102] ACPI Error: Method parse/execution failed [\_SB.WMIV.WVPO] (Node ffff8804308a2820), AE_AML_OPERAND_TYPE (20160930/psparse-543)                                                                                                                             
[   10.605107] ACPI Error: Method parse/execution failed [\_SB.WMIV.WMPV] (Node ffff8804308a2230), AE_AML_OPERAND_TYPE (20160930/psparse-543)                                                                                                                             
[   10.606218] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff8804308a9120 (20160930/exresop-594)
[   10.606221] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20160930/dswexec-461)
[   10.606224] ACPI Error: Method parse/execution failed [\_SB.WMIV.WVPO] (Node ffff8804308a2820), AE_AML_OPERAND_TYPE (20160930/psparse-543)                                                                                                                             
[   10.606230] ACPI Error: Method parse/execution failed [\_SB.WMIV.WMPV] (Node ffff8804308a2230), AE_AML_OPERAND_TYPE (20160930/psparse-543)                                                                                                                             
[   10.606302] input: HP WMI hotkeys as /devices/virtual/input/input16
[   10.613139] ACPI Error: Attempt to CreateField of length zero (20160930/dsopcode-168)
[   10.613142] ACPI Error: Method parse/execution failed [\_SB.WMIV.WVPI] (Node ffff8804308a2b18), AE_AML_OPERAND_VALUE (20160930/psparse-543)                                                                                                                           
[   10.613149] ACPI Error: Method parse/execution failed [\_SB.WMIV.WMPV] (Node ffff8804308a2230), AE_AML_OPERAND_VALUE (20160930/psparse-543)
[    9.645377] radeon 0000:03:00.0: failed VCE resume (-110).

Offline

#2 2017-04-21 18:08:08

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,258
Website

Re: Boot errors

For hybrid graphics (I think your laptop's discrete graphics card is from AMD): https://wiki.archlinux.org/index.php/PRIME. I have no clue about the ACPI errors.

Also, please use code tags when posting output.

Offline

#3 2017-04-21 18:16:47

loqs
Member
Registered: 2014-03-06
Posts: 3,100

Re: Boot errors

Both the ACPI and EFI/ESRT errors are triggered by firmware the linux kernel could not parse.
You could try reporting the issues upstream to the linux kernel developers but I suspect the bug reports would be closed as wont fix seek new firmware from your hardware vendor.
Are you experiencing any issues you believe are caused by these error messages?

Offline

#4 2017-04-21 18:32:27

thomas17
Member
Registered: 2017-03-01
Posts: 17

Re: Boot errors

Currently I can not boot due because I installed the ati driver. Nomodeset is not working.

The issues was before too. new is mei_wdt could not reg notify event ret=-22

Last edited by thomas17 (2017-04-21 18:33:05)

Offline

#5 2017-04-21 18:58:00

loqs
Member
Registered: 2014-03-06
Posts: 3,100

Re: Boot errors

thomas17 wrote:

Currently I can not boot due because I installed the ati driver.

What exactly does this mean?  Is a display manager or graphical boot failing?  Can you switch to another terminal with Ctrl + Alt + F2?

thomas17 wrote:

Nomodeset is not working.

What boot parameters exactly did you add?
Please post the journal for a failing boot.  Boot from live media if needed to obtain the journal and use the tip from List_of_applications#Pastebin_clients to post from the console.

Offline

#6 2017-04-21 19:00:03

thomas17
Member
Registered: 2017-03-01
Posts: 17

Re: Boot errors

graphical boot is failing. It stuck on the bootmessages.

Offline

#7 2017-04-21 20:03:59

thomas17
Member
Registered: 2017-03-01
Posts: 17

Re: Boot errors

It boots now again. It was the 20-radeon.conf under /etc/X11/xorg.conf.d

Offline

#8 2017-04-21 21:32:39

seth
Member
Registered: 2012-09-03
Posts: 5,030

Re: Boot errors

The ACPI errors are printed at boot since some 4.9.x kernel - they've usually been there all the time but are now prominently exposed.
If you don't have (new) problems that smell ACPI related, you can safely ignore them. They just mean that board vendors implement ACPI by poking around until it works on the windows version they're currently using...

Offline

Board footer

Powered by FluxBB