You are not logged in.

#1 2004-03-05 00:53:58

rls
Member
From: contracosta, california
Registered: 2003-08-20
Posts: 60

No sound at KDE Startup

Until yesterday my sound worked fine, both at KDE startup and in KDE. After Syu'ing yesterday no sound at KDE startup. However, sound works to extent that aplay plays .wav files. Suspecting that the upgrade altered a config file, I checked the alsa config files and nothing had changed. I don't know where to look in KDE itself other than the sound section, which was also unchanged.

No big deal, upgrading is always a digital experiment. Just curious.

Any intel would be most appreciated.


"Es gibt nichts mehr praktish als theorie" L. Boltzmann

Offline

#2 2004-03-05 01:18:12

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: No sound at KDE Startup

... but kmix is working? ... or you can play a sound with JuK?

ps -e | grep artsd ?


The impossible missions are the only ones which succeed.

Offline

#3 2004-03-05 15:37:36

Guest
Guest

Re: No sound at KDE Startup

This may just be a simple KDE configuration problem: go to the KDE Control Panel -> Sound & Multimedia -> Sound System and then click on the 'Hardware' tab.  Then reset the "Set the audio device:" pick list to 'Advanced Linux Sound Architecture' and click 'Apply'.  This should set the appropriate KDE configuration files.

If you get a /dev/dsp error message, you may have to look elsewhere, such as checking that your devfsd.conf file is setting permissions properly for the sound devices in /dev (this is written up everywhere in the documentation and installation guides).

Good luck,

Win

#4 2004-03-05 17:52:59

rls
Member
From: contracosta, california
Registered: 2003-08-20
Posts: 60

Re: No sound at KDE Startup

First, thanks to dp and Win Carus for the info.

I had done what Win Carus suggested.

ps -e | grep artsd returns nothing. I presume that means the artsd isn't getting started. kmix returns error, cannot find alsamixer.

I also presume the fact that aplay works in an xterminal only means that alsa is working, not the KDE sound system.


"Es gibt nichts mehr praktish als theorie" L. Boltzmann

Offline

#5 2004-03-05 19:08:25

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: No sound at KDE Startup

rls wrote:

ps -e | grep artsd returns nothing. I presume that means the artsd isn't getting started. kmix returns error, cannot find alsamixer.

you have alsa-utils and alsa-lib installed? (and alsa-driver if running 2.4.25, but this is for sure, else aplay will be quiet)

do you load oss-emulation from /etc/rc.conf ? pkg: alsa-oss (module: snd-pcm-oss)

rls wrote:

I also presume the fact that aplay works in an xterminal only means that alsa is working, not the KDE sound system.

artsd (the kde soundsystem) depends on the setting in controlcenter ... if you have there alsa, artsd should run at kde-startup and use alsa to output ...


The impossible missions are the only ones which succeed.

Offline

#6 2004-03-05 23:06:35

rls
Member
From: contracosta, california
Registered: 2003-08-20
Posts: 60

Re: No sound at KDE Startup

Kernel 2.6.3-scsi

Pure alsa, no oss-emulation.

alsa-libs and alsa-utils are installed.

Permissions in devfs.conf for sound haven't changed.

KDE Control>Sound and Multimedia>Sound System>Hardware ALSA is selected.

All of these variables are just as they were several days ago when KDE sound was working. That is why it is such a mystery.

For me, the cause must be a package that I upgraded in the last two days, perhaps something like gstreamer. What would cause artsd to stop loading?


"Es gibt nichts mehr praktish als theorie" L. Boltzmann

Offline

#7 2004-03-23 19:12:04

rls
Member
From: contracosta, california
Registered: 2003-08-20
Posts: 60

Re: No sound at KDE Startup

Still no sound at KDE startup and the mystery deepens, for now artsd is running:

[rick@arch rick]$ ps -e | grep artsd
  750 ?        00:00:03 artsd

and I can play a .wav file with JuK. In fact, the "Test Sound" button works in KDE Control>Sounds & Multimedia>Sound System.

Is there a config variable, other than in KDE Control>Sounds & Multimedia>System Notifications>KDE System Notifications, that controls sound at KDE startup?


"Es gibt nichts mehr praktish als theorie" L. Boltzmann

Offline

#8 2004-03-23 22:51:34

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: No sound at KDE Startup

arts is running and sound is working? is this right now?

the thing is ... maybe you updated your system while openssl was upgraded in arch and got a bad pkg and maybe now solved it by again -Suy'ing it ... but can also be other problem, like an app trying to use alsa besides artsd


The impossible missions are the only ones which succeed.

Offline

#9 2004-03-24 00:13:13

rls
Member
From: contracosta, california
Registered: 2003-08-20
Posts: 60

Re: No sound at KDE Startup

dp:

Correct, arts is running and sound is working. After a bit more research, I realize that I have not stated my question precisely. It is a Systems Notifications issue. None of the System Notifications using sound work, not just the startup sound.

Many thanks for your efforts.


"Es gibt nichts mehr praktish als theorie" L. Boltzmann

Offline

#10 2004-03-24 00:38:14

rls
Member
From: contracosta, california
Registered: 2003-08-20
Posts: 60

Re: No sound at KDE Startup

A little more research and I found the solution. In KDE Control>Sound&Multimedia>System Notifications click the button "Player Settings" and click the box "Use External Player", but leave the field blank.

The wonderful world of Linux.


"Es gibt nichts mehr praktish als theorie" L. Boltzmann

Offline

#11 2004-03-24 00:42:05

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: No sound at KDE Startup

rls wrote:

dp:

Correct, arts is running and sound is working. After a bit more research, I realize that I have not stated my question precisely. It is a Systems Notifications issue. None of the System Notifications using sound work, not just the startup sound.

Many thanks for your efforts.

he he .. ups, i was thinking that arts do not work and you have no sounds in kde --- can be my bad english or not so exact reading :-)

Control>Sounds & Multimedia>System Notifications>KDE System Notifications

is the only thing to set notifications in kde, but it is a tricky one (the UI is not well made):

- check if the volume is set ok: in the "Configure - System Notifiactions" check under the button "Player Settings..." if your volume is not muted (you do not need other player)

- if you select a notification that has sound set ... if you click on the button to test sound, does it work? ... check if the files exist

else i dont know what to try to check why it is not working right ... arts works, so it's not a backend problem ... but a kde-one :-(


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB