You are not logged in.

#1 2017-04-26 18:55:14

thetazerlaser
Member
Registered: 2017-04-26
Posts: 3

[SOLVED] Animation lag after GNOME 3.24 Update

After updating to GNOME 3.24 yesterday my graphical performance has been noticeably choppy, particularly when opening the activities overview and switching between workspaces, scrolling in Chromium also causes framerate drops. I am using the Nvidia proprietary driver on a GTX 960 and this issue affects both Wayland and Xorg. Any suggestions for a fix would be greatly appreciated.

Last edited by thetazerlaser (2017-04-27 17:43:37)

Offline

#2 2017-04-26 19:18:00

gaim123
Member
From: Poland
Registered: 2015-04-27
Posts: 34

Re: [SOLVED] Animation lag after GNOME 3.24 Update

Offline

#3 2017-04-26 22:15:54

DeadMetaler
Member
Registered: 2016-03-16
Posts: 41

Re: [SOLVED] Animation lag after GNOME 3.24 Update

thetazerlaser wrote:

After updating to GNOME 3.24 yesterday my graphical performance has been noticeably choppy, particularly when opening the activities overview and switching between workspaces, scrolling in Chromium also causes framerate drops. I am using the Nvidia proprietary driver on a GTX 960 and this issue affects both Wayland and Xorg. Any suggestions for a fix would be greatly appreciated.

I thought no one would write about it.


https://gist.github.com/DeadMetaler/126 … ffbd6778c6
1. Download 2 files to one dir (PKGBUILD revert.patch)
2. Run in terminal

makepkg -i

3. Restart GNOME Shell --- Alt+F2 + r

Do you still see the lags?

Offline

#4 2017-04-27 13:44:55

hussam
Member
Registered: 2006-03-26
Posts: 556

Re: [SOLVED] Animation lag after GNOME 3.24 Update

DeadMetaler wrote:

https://gist.github.com/DeadMetaler/126 … ffbd6778c6
1. Download 2 files to one dir (PKGBUILD revert.patch)
2. Run in terminal

makepkg -i

3. Restart GNOME Shell --- Alt+F2 + r

Do you still see the lags?

I filed an upstream bug report https://bugzilla.gnome.org/show_bug.cgi?id=781835 and mentioned that reverting the patch helps.
I also mentioned this to a gnome developer a month ago. He basically just agreed that this is not a good thing.
I asked a nvidia developer as well. He said it is due to the overhead of excessive xlib calls that the function introduces.

Offline

#5 2017-04-27 17:35:56

thetazerlaser
Member
Registered: 2017-04-26
Posts: 3

Re: [SOLVED] Animation lag after GNOME 3.24 Update

DeadMetaler wrote:
thetazerlaser wrote:

After updating to GNOME 3.24 yesterday my graphical performance has been noticeably choppy, particularly when opening the activities overview and switching between workspaces, scrolling in Chromium also causes framerate drops. I am using the Nvidia proprietary driver on a GTX 960 and this issue affects both Wayland and Xorg. Any suggestions for a fix would be greatly appreciated.

I thought no one would write about it.


https://gist.github.com/DeadMetaler/126 … ffbd6778c6
1. Download 2 files to one dir (PKGBUILD revert.patch)
2. Run in terminal

makepkg -i

3. Restart GNOME Shell --- Alt+F2 + r

Do you still see the lags?

That fixed the problem, thanks

Offline

#6 2017-04-27 17:52:10

hussam
Member
Registered: 2006-03-26
Posts: 556

Re: [SOLVED] Animation lag after GNOME 3.24 Update

@thetazerlaser would you mind posting in the upstream report that revert.patch helped? More people increases the chance Gnome developers may take a look.

Offline

#7 2017-04-27 18:46:22

thetazerlaser
Member
Registered: 2017-04-26
Posts: 3

Re: [SOLVED] Animation lag after GNOME 3.24 Update

hussam wrote:

@thetazerlaser would you mind posting in the upstream report that revert.patch helped? More people increases the chance Gnome developers may take a look.

Sure

Offline

#8 2017-05-12 15:04:58

sayonalion
Member
Registered: 2016-10-25
Posts: 26

Re: [SOLVED] Animation lag after GNOME 3.24 Update

The bug still exists in mutter-3.24.2.

Offline

#9 2017-05-24 03:52:46

seeks
Member
Registered: 2012-01-28
Posts: 5

Re: [SOLVED] Animation lag after GNOME 3.24 Update

DeadMetaler wrote:
thetazerlaser wrote:

After updating to GNOME 3.24 yesterday my graphical performance has been noticeably choppy, particularly when opening the activities overview and switching between workspaces, scrolling in Chromium also causes framerate drops. I am using the Nvidia proprietary driver on a GTX 960 and this issue affects both Wayland and Xorg. Any suggestions for a fix would be greatly appreciated.

I thought no one would write about it.


https://gist.github.com/DeadMetaler/126 … ffbd6778c6
1. Download 2 files to one dir (PKGBUILD revert.patch)
2. Run in terminal

makepkg -i

3. Restart GNOME Shell --- Alt+F2 + r

Do you still see the lags?

Great googly moogly, thank you for posting this.  Completely solved the issue for me.

Offline

Board footer

Powered by FluxBB