You are not logged in.

#1 2006-06-09 16:21:19

bored2k
Member
Registered: 2006-01-14
Posts: 39

[GDM] Automatic login issues

I've setup an automatic login using gdmsetup to a regular user account, but no matter what I do, after automatically passing the GDM screen, a small popup asks me for authentication, thus screwing up my auto-login.

Did I miss a step here?


Thanks for your help,
bored2k.

Offline

#2 2006-06-10 08:12:56

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: [GDM] Automatic login issues

i remeber this from a friend who told me, my guess it is in the /etc/pam.d/gdm-autologin.

for some reason it won't login anymore


Freedom is what i love

Offline

#3 2006-06-12 12:41:35

murkus
Member
From: Europe/Helsinki
Registered: 2004-03-19
Posts: 254

Re: [GDM] Automatic login issues

#%PAM-1.0
auth            requisite       pam_nologin.so
auth            required        pam_env.so
auth            required        pam_permit.so
account         required        pam_unix.so
session         required        pam_limits.so
session         required        pam_unix.so
password        required        pam_unix.so

There's my /etc/pam.d/gdm-autologin. Now what should I do with it? smile

.murkus

Offline

#4 2006-06-13 05:31:19

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: [GDM] Automatic login issues

bored2k wrote:

Did I miss a step here?

What does your gdm.conf contain??
Should have a section similar to below (mine is default):

# Automatic login, if true the first local screen will automatically logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=false
AutomaticLogin=

Another method:

Open /etc/pam.d/gdm and before this line:

@include common-auth
add these three lines:

# start enable passworldless logins
auth sufficient pam_listfile.so item=user sense=allow file=/etc/X11/gdm/nopassusers.txt onerr=fail
# end enable passwordless logins
Now create the file /etc/X11/gdm/nopassusers.txt and add the usernames of the users that you want to have passwordless logins, one per line.


/path/to/Truth

Offline

#5 2006-06-15 19:04:50

mehldutt
Member
From: Germany
Registered: 2006-01-08
Posts: 128

Re: [GDM] Automatic login issues

Same problem here ...

My /etc/pam.d/gdm and /etc/pam.d/gdm-autologin

look the same als that of Markus

Doesn't anybody have a solution, except of downgading gdm?

Gary

Offline

Board footer

Powered by FluxBB