You are not logged in.

#1 2017-06-19 15:02:58

anselm
Member
Registered: 2016-05-11
Posts: 111

After latest update I get a libcrypto error when starting Apache

I am using ApacheFriends XAMPP 32 bit. After the latest system update I am unable to start Apache:

httpd: Syntax error on line 136 of /opt/lampp/etc/httpd.conf: Cannot load modules/mod_ssl.so into server: /opt/lampp/modules/mod_ssl.so: symbol d2i_OCSP_RESPONSE, version OPENSSL_1.0.1 not defined in file libcrypto.so.1.0.0 with link time reference

Offline

#2 2017-06-19 15:38:55

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 942

Re: After latest update I get a libcrypto error when starting Apache

Is it an official package? I think not... Moving to AUR issues... Wait I'm not...


Github | Soundcloud

Simplicity is the ultimate sophistication ~ Leonardo da Vinci
.

Offline

#3 2017-06-19 15:52:22

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,481
Website

Re: After latest update I get a libcrypto error when starting Apache

Mod note: I am.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

#4 2017-06-19 15:52:56

anselm
Member
Registered: 2016-05-11
Posts: 111

Re: After latest update I get a libcrypto error when starting Apache

I thought maybe I should install another version of libssl.so and / or libcrypto.so
I can't install a newer version of XAMPP because no more 32 bit packages are available.

Last edited by anselm (2017-06-19 15:53:16)

Offline

#5 2017-06-19 16:01:57

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,600
Website

Re: After latest update I get a libcrypto error when starting Apache

anselm wrote:

I thought maybe I should install another version of libssl.so and / or libcrypto.so

Maybe you should.  Or maybe not.  But you probably should tell us which one(s) you currently have installed.


Resist the GNU world order.

Offline

#6 2017-06-19 19:19:08

anselm
Member
Registered: 2016-05-11
Posts: 111

Re: After latest update I get a libcrypto error when starting Apache

My XAMPP version is 5.6.8-0
And it would need: OpenSSL to 1.0.1m
"openssl version -a" gives:

OpenSSL 1.1.0f  25 May 2017
built on: reproducible build, date unspecified
platform: linux-elf
compiler: gcc -DDSO_DLFCN -DHAVE_DLFCN_H -DNDEBUG -DOPENSSL_THREADS -DOPENSSL_NO_STATIC_ENGINE -DOPENSSL_PIC -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DRC4_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM -DECP_NISTZ256_ASM -DPADLOCK_ASM -DPOLY1305_ASM -DOPENSSLDIR="\"/etc/ssl\"" -DENGINESDIR="\"/usr/lib/engines-1.1\""  -Wa,--noexecstack -D_FORTIFY_SOURCE=2 -march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong -Wl,-O1,--sort-common,--as-needed,-z,relro
OPENSSLDIR: "/etc/ssl"
ENGINESDIR: "/usr/lib/engines-1.1"

Offline

#7 2017-06-19 20:51:55

anselm
Member
Registered: 2016-05-11
Posts: 111

Re: After latest update I get a libcrypto error when starting Apache

I tried to recompile openssl-1.0.1u.tar.gz package, but then (after symlinking) I get the same error message.

Offline

#8 2017-06-19 22:33:46

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,600
Website

Re: After latest update I get a libcrypto error when starting Apache

I wanted to know which packages you had installed.  Telling me you have openssl 1.1 is of no help when XAMPP needs openssl-1.0.  What is the output of `pacman -Qs openssl`?  Is this a fully 32-bit system?  If not, do you have mutlilib enabled and do you have openssl-1.0 from multilib?


Resist the GNU world order.

Offline

#9 2017-06-20 06:32:06

anselm
Member
Registered: 2016-05-11
Posts: 111

Re: After latest update I get a libcrypto error when starting Apache

pacman -Qs openssl

local/openssl 1.1.0.f-1
    The Open Source toolkit for Secure Sockets Layer and Transport
    Layer Security
local/openssl-1.0 1.0.2.l-1
    The Open Source toolkit for Secure Sockets Layer and Transport
    Layer Security
local/openssl098 0.9.8.zh-1
    The Open Source toolkit for Secure Sockets Layer and Transport
    Layer Security (0.9.8 branch)
local/python2-pyopenssl 17.0.0-1
    Python2 wrapper module around the OpenSSL library
local/tcltls 1.7.12-1
    OpenSSL extension to Tcl

System is fully 32 bit, virtual VPS. Unfortunately latest XAMPP builds are only available for 64 bit.

Offline

#10 2017-06-20 07:00:55

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,324

Re: After latest update I get a libcrypto error when starting Apache

Well I guess this will only be a problem for a few more months anyway.

https://www.archlinux.org/news/phasing- … 6-support/

Offline

#11 2017-06-20 07:51:45

anselm
Member
Registered: 2016-05-11
Posts: 111

Re: After latest update I get a libcrypto error when starting Apache

Thank you. And which command should I use to determine if my VPS is capable of installing a 64 bit version of Arch Linux?

Offline

#12 2017-06-20 11:11:32

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,600
Website

Re: After latest update I get a libcrypto error when starting Apache

If switching is an option - do that.

For your specific question, RTFW.  But I'm quite sure there are no 32-bit only VPS providers.


Resist the GNU world order.

Offline

#13 2017-06-20 11:20:31

anselm
Member
Registered: 2016-05-11
Posts: 111

Re: After latest update I get a libcrypto error when starting Apache

Thank you, inbetween the original problem has been solved, by installing the latset 32 bit XAMPP package.

Offline

#14 2017-06-20 11:30:26

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,600
Website

Re: After latest update I get a libcrypto error when starting Apache

anselm wrote:

I can't install a newer version of XAMPP because no more 32 bit packages are available.

anselm wrote:

Unfortunately latest XAMPP builds are only available for 64 bit.

anselm wrote:

... by installing the latset 32 bit XAMPP package.

I think I see the problem now - it's not with software.

Please mark the thread as solved.


Resist the GNU world order.

Offline

#15 2017-06-22 10:01:48

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 942

Re: After latest update I get a libcrypto error when starting Apache

another hit & run


Github | Soundcloud

Simplicity is the ultimate sophistication ~ Leonardo da Vinci
.

Offline

Board footer

Powered by FluxBB