You are not logged in.

#1 2006-06-21 13:44:36

ivan22
Member
From: Slovakia
Registered: 2006-06-21
Posts: 18

Kernel 2.6 ... i810 driver doesn't works

I have installed archlinux with kernel 2.6 but driver i810 for my graphic card doesn't works and X ends with "module i810 not found" message.There is file in /lib/modules called i810.ko, but I don't know if this is driver file.


My Archie hardware: Screen: 29" LG 29UM58 Ultrawide - CPU: Intel Pentium G3258 - RAM: Crucial 4GB DDR3 1600MHz - HDD: ADATA Premier Pro SP900 128 GB - MB: Gigabyte H81n

Offline

#2 2006-06-21 13:53:49

kth5
Member
Registered: 2004-04-29
Posts: 655
Website

Re: Kernel 2.6 ... i810 driver doesn't works

you probably don't have xf86-video-i810 installed. smile


I recognize that while theory and practice are, in theory, the same, they are, in practice, different. -Mark Mitchell

Offline

#3 2006-06-21 13:56:40

ralvy
Member
From: Santa Monica, California
Registered: 2004-12-06
Posts: 275

Re: Kernel 2.6 ... i810 driver doesn't works

ivan22 wrote:

I have installed archlinux with kernel 2.6 but driver i810 for my graphic card doesn't works and X ends with "module i810 not found" message.There is file in /lib/modules called i810.ko, but I don't know if this is driver file.

The latest version of Xorg (version 7) doesn't include individual video drivers. They have to be installed separately. So, to find your driver, do a search with pacman:

pacman -Ss i810

This will give you this:

current/xf86-video-i810 1.4.1.3-2
    X.org Intel i810/i830/i915 video drivers

That tells you the name of the package in current you want. Now you install it with:

pacman -S xf86-video-i810

Now everything should be fine after you reload X.

Offline

#4 2006-06-21 13:56:50

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: Kernel 2.6 ... i810 driver doesn't works

Driver i810 won't work until it is installed:

pacman -Sy xf860-video-i810

Have a look at the xorg7 wiki page for more details.

Offline

#5 2006-06-21 15:00:14

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: Kernel 2.6 ... i810 driver doesn't works

... so yes.  Install the driver.  XD  See how helpful we are here?

*marvels at the three posts that all posted thinking they were the first response*  Seriously.  That's awesome. big_smile

Offline

#6 2006-06-21 16:45:11

ScriptDevil
Member
From: In Front of My PC
Registered: 2006-04-06
Posts: 253

Re: Kernel 2.6 ... i810 driver doesn't works

tomk is right, i got it thataway


Be yourself, because you are all that you can be

Offline

#7 2006-06-21 16:48:52

ScriptDevil
Member
From: In Front of My PC
Registered: 2006-04-06
Posts: 253

Re: Kernel 2.6 ... i810 driver doesn't works

try vesa


Be yourself, because you are all that you can be

Offline

#8 2006-06-21 18:34:31

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Kernel 2.6 ... i810 driver doesn't works

That wouldn't help very much, the vesa driver precludes hardware acceleration... As everyone else said, install xf86-video-i810 and see where that gets you.

Offline

#9 2006-06-22 09:04:13

ivan22
Member
From: Slovakia
Registered: 2006-06-21
Posts: 18

Re: Kernel 2.6 ... i810 driver doesn't works

Thank you all guys for your HELP :-)


My Archie hardware: Screen: 29" LG 29UM58 Ultrawide - CPU: Intel Pentium G3258 - RAM: Crucial 4GB DDR3 1600MHz - HDD: ADATA Premier Pro SP900 128 GB - MB: Gigabyte H81n

Offline

Board footer

Powered by FluxBB