You are not logged in.

#1 2017-07-09 14:54:05

rennradler
Member
Registered: 2017-07-09
Posts: 2

[SOLVED] KDE: Composting broken

A resent update has broken composting on my machines. KDE Desktop effects are no longer working on my desktop and my notebook. Both are running nvidia drivers but different branches (340.xx and 381.xx). A Shift-Alt-F12 results in an error message:

kwin_x11[2493]: kwin_core: Compositing is not possible

The kwin version is 5.10.3.1-1 and kernel  version is 4.11.9-1-ARCH. Since there were quite a few packages updated (kernel, qt, plasma) it is hard to say which package caused the problem.

I scanned through the logs but I found no indication of what goes wrong.

Any ideas?

Last edited by rennradler (2017-07-09 15:33:42)

Offline

#2 2017-07-09 14:59:56

Potomac
Member
Registered: 2011-12-25
Posts: 499

Re: [SOLVED] KDE: Composting broken

can you run a 3D game without problem ?

or the tool "glxgears" from the mesa-demos package,
you can also run glxinfo in order to see if "direct rendering" is set to "Yes"

the idea is to check if 3D acceleration ( the use of openGL in hardware mode ) works

Last edited by Potomac (2017-07-09 15:01:20)

Offline

#3 2017-07-09 15:00:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,097

Re: [SOLVED] KDE: Composting broken

This might be a potential detection issue, look into this thread for potential clues.

Offline

#4 2017-07-09 15:30:15

rennradler
Member
Registered: 2017-07-09
Posts: 2

Re: [SOLVED] KDE: Composting broken

Thank you very much. The problem is solved.

It was caused by these lines in .config/kwinrc on both machines:

[Compositing]
OpenGLIsUnsafe=true

I set it to false and now everything works again.

I looked into my backups. It was indeed added yesterday when I did the update.

Offline

Board footer

Powered by FluxBB