You are not logged in.

#1 2017-05-31 00:04:42

carlday
Member
Registered: 2011-10-04
Posts: 19

[Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

Can not get web-servers to "see" different USER-AGENT on Gnome-Web [epiphany]?
A Bank site forcing firefox or chrome or ie or apple, i'm tring to run Wayland apps only.
Could not find anything specific on bbs.archlinux and Web searches find old posts with
different answers?
Newest post from 2014:
************************************************************************************************************************
It is possible using dconf, the key is org.gnome.Epiphany user-agent

The default is empty, so this is probably why you see no UA string set there.

You can also try gsettings set org.gnome.Epiphany user-agent "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2049.0 Safari/537.36" by command line, should do the trick.
shareimprove this answer
answered Jun 26 '14 at 17:21
   
another way is through gconf: /apps/epiphany/general/user_agent. Source:mail.gnome.org/archives/epiphany-list/2011-May/msg00010.html – Elder Geek Jun 26 '14 at 17:56
thanks smile I found out how to do it in dconf going to org > gnome > epiphany > user-agent. Did the same as that command through the GUI.
*********************************************************************************************
On another machine with firefox/linux captured this USER-Agent string:
Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

Tried setting above string with dconf, gconftool-2, and gsettings.
Got a XML conf file in .config/gconf/apps/epiphany/general/%gconf.xml with the above string.
Contents of the XML file:
<?xml version="1.0"?>
<gconf>
    <entry name="user_agent" mtime="1495569379" type="string">
        <stringvalue>Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0</stringvalue>
    </entry>
</gconf>
********************************
Have restarted system and user agent still shows this
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/604.1 (KHTML, like Gecko) Version/11.0 Safari/604.1 Epiphany/3.24.2


TIA

Last edited by carlday (2017-07-20 06:48:27)

Offline

#2 2017-06-03 10:15:24

nuovodna
Member
Registered: 2007-12-15
Posts: 17

Re: [Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

same problem here. I cannot change UA on Gnome Web.

in dconf-editor i have this under /org/gnome/epiphany/ and i

DEPRECATED: This key is deprecated and ignored. Use /org/gnome/epiphany/web/user-agent instead.

Offline

#3 2017-06-06 22:10:34

carlday
Member
Registered: 2011-10-04
Posts: 19

Re: [Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

Midori web-browser Also runs without Xwayland and has a web-extension libstatusbar-features.so which can take a custom U-A pasted in.
The bank and U-A sites see browser as firefox-53. [ also can toggle images and scripts off/on] . Wish the statusbar could be bolted
on to Gnome-Web.  Midori is not stable on some java-script abends taking programs down on half of the sites i use.
From googling gnome-web had web-extensions years ago even on bsd.
The [ephiphany] libephywebextension.so* supplied with the app ??
Linked the libstatusbar-features.so into the epiphany/web-extensions/ ??

Offline

#4 2017-07-17 14:07:10

Michael Catanzaro
Member
Registered: 2012-11-04
Posts: 48

Re: [Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

Hi,

You have to use the command line to do this, using the gsettings command. Old instructions don't work anymore with Epiphany 3.24 because the setting is now relocatable, allowing different Epiphany web apps to have different settings but making it a bit more complicated to set. This will work:

$ gsettings set org.gnome.Epiphany.web:/org.gnome.epiphany/web/ user-agent 'Bunnies! Lots of bunnies in my user agent!'

To revert to the default user agent:

$ gsettings reset org.gnome.Epiphany.web:/org.gnome.epiphany/web/ user-agent

Hope that helps.

Offline

#5 2017-07-17 14:08:51

Michael Catanzaro
Member
Registered: 2012-11-04
Posts: 48

Re: [Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

carlday wrote:

Midori web-browser Also runs without Xwayland and has a web-extension libstatusbar-features.so which can take a custom U-A pasted in.
The bank and U-A sites see browser as firefox-53. [ also can toggle images and scripts off/on] . Wish the statusbar could be bolted
on to Gnome-Web.  Midori is not stable on some java-script abends taking programs down on half of the sites i use.
From googling gnome-web had web-extensions years ago even on bsd.
The [ephiphany] libephywebextension.so* supplied with the app ??
Linked the libstatusbar-features.so into the epiphany/web-extensions/ ??

The web extension is singular and not what you think. It is how Epiphany injects code into the WebKit web process. Think of it as Epiphany's way of extending WebKit. Epiphany does not support real extensions anymore unfortunately.

Offline

#6 2017-07-17 14:10:40

Michael Catanzaro
Member
Registered: 2012-11-04
Posts: 48

Re: [Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

Michael Catanzaro wrote:

$ gsettings set org.gnome.Epiphany.web:/org.gnome.epiphany/web/ user-agent 'Bunnies! Lots of bunnies in my user agent!'

To revert to the default user agent:

$ gsettings reset org.gnome.Epiphany.web:/org.gnome.epiphany/web/ user-agent

Oh no, I copied those instructions wrong! Sorry! Don't try that. Try this instead:

$ gsettings set org.gnome.Epiphany.web:/org/gnome/epiphany/web/ user-agent 'Bunnies! Lots of bunnies in my user agent!'

To revert to the default user agent:

$ gsettings reset org.gnome.Epiphany.web:/org/gnome/epiphany/web/ user-agent

Offline

#7 2017-07-20 06:43:28

carlday
Member
Registered: 2011-10-04
Posts: 19

Re: [Solved] Can Not Spoof User-Agent in Gnome-Web epiphany

Copied the gsettings thru ' put my firefox U-A ' into terminal ran cmd
Restarted browser, the U-A sniffers smelled firefox
and could access bank site after login.[solved]

Last edited by carlday (2017-07-20 06:51:50)

Offline

Board footer

Powered by FluxBB