You are not logged in.

#1 2006-06-24 04:43:02

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

During 'move' update. Lost nvidia support!

This is really strange to me, I was talking to WillySilly on IRC and he said he also did the update and has nvidia support, I also did the update but I don't have nvidia support. Maybe he did it when the nvidia modules were in sync? If so, wouldn't removing nvidia-utils / nvidia and reinstalling them technically fix the problem? Well they don't. Which is frusterating me! I get this error from the xorg log:

(EE) Nvidia(0): Failed to load the nvidia module
(EE) nvidia not found <ABORT>
(EE)Screen(s) Found, but no module

Something around those lines, don't remember exactly what it said. I tried removing them multiple times and installing them but it still dind't work. Should I wait until they post on the 'news' page that current is in sync? Or will I have to completely re-install my arch system?

Offline

#2 2006-06-24 07:20:03

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: During 'move' update. Lost nvidia support!

probably your mirror wasn'T fully synced before you updated,
nvdia 1.0.8762-4 is the correct package for 2.6.17 kernel

Offline

#3 2006-06-24 15:15:24

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: During 'move' update. Lost nvidia support!

tpowa wrote:

probably your mirror wasn'T fully synced before you updated,
nvdia 1.0.8762-4 is the correct package for 2.6.17 kernel

Heres the version of both nvidia packages I remember using:

nvidia-1.0.8762-1
nvidia-utils-1.08762-5

Both which are the same version before I updated and still are the same. When and... if? They become in sync... will everything be alright again?

Offline

#4 2006-06-24 15:27:27

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: During 'move' update. Lost nvidia support!

[root@desktop ~]# pacman -Q nvidia
nvidia 1.0.8762-4

And yes, it's working great (FX5200).


Microshaft delenda est

Offline

#5 2006-06-24 16:21:35

hightower
Member
Registered: 2006-04-02
Posts: 182

Re: During 'move' update. Lost nvidia support!

another possibility is that you use different mirrors for [current] and [extra] like me, so I had the newer kernel, but the old nvidia package, because the [extra] mirror hadn't synced yet.

hightower

Offline

#6 2006-06-24 16:24:52

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: During 'move' update. Lost nvidia support!

So basically I just have to wait until my extra mirrors resync with everything? Or is there a quicker way. I really hate being in console mode, it's taking alot of time from  website I maintain. It's too hard to maintain stuff console based.

Offline

#7 2006-06-24 16:33:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: During 'move' update. Lost nvidia support!

Offline

#8 2006-06-24 17:01:18

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: During 'move' update. Lost nvidia support!

tpowa wrote:

Thanks tpowa, worked smile. I forgot completely about wget... I had to reinstall it because I removed it when I first install arch, never had aneed for it... until now tongue.

Offline

#9 2006-06-24 17:14:23

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: During 'move' update. Lost nvidia support!

Actually, you don't even need wget. wink  Pacman can do it on its own:
pacman -U ftp://ftp.archlinux.org/extra/os/i686/n … pkg.tar.gz

Offline

#10 2006-06-24 17:22:17

twiistedkaos
Member
Registered: 2006-05-20
Posts: 666

Re: During 'move' update. Lost nvidia support!

Snowman wrote:

Actually, you don't even need wget. wink  Pacman can do it on its own:
pacman -U ftp://ftp.archlinux.org/extra/os/i686/n … pkg.tar.gz

w00t, I love you snowman xD. I did figure if I put ftp://ftp.archlinux.org/extra/os/i686/ as my first mirror in /etc/pacman.d/extra that it updates fine, it's just a nuisance waiting for the other mirrors to sync tongue. Thanks for the tip though, I love pacman even more now smile.

Offline

Board footer

Powered by FluxBB