You are not logged in.

#1 2016-10-04 17:02:04

derekstavis
Member
Registered: 2014-04-02
Posts: 5

GNOME 3.22 completely flickering

I have been following GNOME 3.22 builds from softwareperonista.ar and now from testing and I have noticed that I get two flickering issues.

The first issue is with display resolution, where the whole picture flickers, as in a wrong resolution on old CRT displays.

The second issue is with shell rendering, as mouse hovers elements, some parts of widgets fickers.

I can help give some testing if needed.

Offline

#2 2016-10-05 08:58:55

dreivier
Member
Registered: 2016-04-07
Posts: 22

Re: GNOME 3.22 completely flickering

Maybe this is related to Wayland too? https://bbs.archlinux.org/viewtopic.php?id=217840

Offline

#3 2016-10-05 12:16:08

Sleepy Rabbit
Member
Registered: 2013-11-19
Posts: 2

Re: GNOME 3.22 completely flickering

I have a similar issue. The screen flickers and the desktop is too large for the screen (the panel is cut off) in GDM and Gnome.

This happens only when using Wayland (but Weston does not have the same problem) and the default, monitor native, resolution. Gnome 3.20.x did not have the same issue with Wayland.

Last edited by Sleepy Rabbit (2016-10-05 12:17:54)

Offline

#4 2016-10-05 19:28:37

il_santo
Member
Registered: 2016-10-05
Posts: 2

Re: GNOME 3.22 completely flickering

I've the same issue but removing/commenting the "CLUTTER_PAINT=disable-clipped-redraws:disable-culling" in /etc/environments do the tricks for me.

Offline

#5 2016-10-11 09:06:59

PostBlue
Member
Registered: 2012-04-05
Posts: 12
Website

Re: GNOME 3.22 completely flickering

il_santo wrote:

I've the same issue but removing/commenting the "CLUTTER_PAINT=disable-clipped-redraws:disable-culling" in /etc/environments do the tricks for me.

I had this same issue with my sister's computer on Debian Testing (that got GNOME 3.22 before Arch Linux), thanks for the hint, I forgot I had this line modified!

Offline

#6 2016-10-12 16:32:58

ahcaliskan
Member
From: Sweden
Registered: 2008-10-29
Posts: 174

Re: GNOME 3.22 completely flickering

This is a bug in mutter[1].

Adding 'MUTTER_STAGE_VIEWS=0' in /etc/environment fixes the flickering issue.

1. https://bugzilla.gnome.org/show_bug.cgi?id=771815

Offline

#7 2016-10-12 17:53:12

Dowefu
Member
Registered: 2014-03-25
Posts: 68

Re: GNOME 3.22 completely flickering

Same issue with the NVIDIA card and the proprietary driver. Removing ‘CLUTTER_PAINT=disable-clipped-redraws:disable-culling´ from ‘/etc/environment´ solved it. ‘MUTTER_STAGE_VIEWS=0´ has no effect.

Offline

#8 2016-10-12 19:08:42

newt
Member
From: Jakarta - Indonesia
Registered: 2008-10-26
Posts: 14

Re: GNOME 3.22 completely flickering

Thank you il_santo, it works on my Fujitsu laptop.
It might be a (temporary ?) problem solving for the buggy mutter


¡ pıdnʇs 'ǝldɯıs ʇı dǝǝʞ

Offline

#9 2016-10-13 12:34:51

marcvangend
Member
Registered: 2013-04-22
Posts: 20

Re: GNOME 3.22 completely flickering

il_santo wrote:

I've the same issue but removing/commenting the "CLUTTER_PAINT=disable-clipped-redraws:disable-culling" in /etc/environments do the tricks for me.

Awesome, that fixed it for me too. For the record, I added that line once because it fixed another problem: https://wiki.archlinux.org/index.php/GN … D_Graphics. Let's hope that video bug was fixed meanwhile.

Offline

#10 2016-11-01 03:49:54

demizer
Member
From: Santa Clara
Registered: 2010-03-03
Posts: 110
Website

Re: GNOME 3.22 completely flickering

Geez oh man! I thought my Dell XPS 13 9343 was dead due a hardware issue... turns out I also had "CLUTTER_PAINT=disable-clipped-redraws:disable-culling" in /etc/environment! Removing this line saved my laptop.

Offline

#11 2017-08-10 02:04:45

berglh
Member
Registered: 2017-08-10
Posts: 1

Re: GNOME 3.22 completely flickering

ahcaliskan wrote:

This is a bug in mutter[1].

Adding 'MUTTER_STAGE_VIEWS=0' in /etc/environment fixes the flickering issue.

1. https://bugzilla.gnome.org/show_bug.cgi?id=771815

I know this is an Arch only forum, but I just want to post that on Ubuntu Gnome 17.04 using gnome-shell 3.24.2 and mutter 3.24.2 the 'MUTTER_STAGE_VIEWS=0' resolve my flickering issues. Thanks.

Last edited by berglh (2017-08-10 02:05:08)

Offline

#12 2017-08-10 02:08:31

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 22,655
Website

Re: GNOME 3.22 completely flickering

Please don't necrobump: particularly regarding out-of-date software
https://wiki.archlinux.org/index.php/Co … bumping.22



Closing


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB