You are not logged in.

#1 2006-06-25 13:40:08

abe.sinner
Member
Registered: 2006-06-25
Posts: 14

[wireless] no essid - yet another wireless problem

yet another wireless problem

I can't get my wireless working on my acer aspir 5020. I installed the drive of my wirelesscard with ndiswrapper, and that seems to work:

[root@spot abe]# ndiswrapper -l
Installed drivers:
bcmwl5a         driver installed, hardware present

but when I try to connect something goes wrong:

[root@spot abe]# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:00:00:00:00:00
          Bit Rate:54 Mb/s   Tx-Power:25 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[root@spot abe]# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:0E:9B:C4:84:44
          inet6 addr: fe80::20e:9bff:fec4:8444/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:21 Memory:c0204000-c0206000

[root@spot abe]# dhcpcd wlan0
<after>
[root@spot abe]#

dmesg | grep wlan0

[root@spot abe]# dmesg | grep wlan0
wlan0: vendor: ''
wlan0: ndiswrapper ethernet device 00:0e:9b:c4:84:44 using driver bcmwl5a, 14E4:4318.5.conf
wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
wlan0: no IPv6 routers present

The strange thing is that a couple of months ago there was a day my wireless worked. The led of the wireless just started beaming out of the blue, and after running dhcpcd wlan0 essid network I had connection with my wireless router. unfortunately when I rebooted it didn't work anymore.

<_abe>


Ha Ha

Offline

#2 2006-06-25 15:39:58

The_Nerd
Member
From: Syracuse, NY / Baltimore, MD
Registered: 2005-11-30
Posts: 134
Website

Re: [wireless] no essid - yet another wireless problem

i know that with my acer, unless i have the acer hotkey module, or the acer acpi module loaded, my wireless will not connect. Check out "acerhk" in the aur, and give it a shot.

once installed, put "acerhk" in your rc.conf and reboot, or run it without rebooting from rc.d, your call (old windows habits die hard :oops: )

upon reboot, you should see your light flash on once, and then it should allow you to connect to your wireless network no problem.

Also, mabye before trying that, you might want to try pressing your wireless LED button in. I believe it acts as a radio switch, and you may as well press it a few times and see if it does anything.

If acerhk is being a pain, let me know, i have a nice pkgbuild for acer acpi that i have not yet submitted to the aur.. i'll throw it up here

good luck!

Offline

#3 2006-06-25 15:48:12

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: [wireless] no essid - yet another wireless problem

I got an acer too .... err lspci shows wireless as

0000:06:05.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)

not had any luck connecting as yet ?

would madwifi work maybe?


Mr Green

Offline

#4 2006-06-25 17:09:56

abe.sinner
Member
Registered: 2006-06-25
Posts: 14

Re: [wireless] no essid - yet another wireless problem

thx, I have installed acerhk and the wireless works just fine.

<_abe>


Ha Ha

Offline

#5 2006-10-29 21:58:36

VuLTuRe
Member
From: Turkey
Registered: 2005-12-16
Posts: 56
Website

Re: [wireless] no essid - yet another wireless problem

Could anyone supply acerhk again? Because link is broken.


TuX We TrusT

Offline

#6 2006-10-30 00:10:11

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Offline

Board footer

Powered by FluxBB