You are not logged in.

#1 2017-08-29 08:10:14

Michael Gruenstaeudl
Member
Registered: 2014-12-03
Posts: 47

[Solved] Offline system install - How to pacstrap base from local pkgs

I wish to install Arch Linux on a system without internet connection (has neither wired nor wireless). To that end, I boot an Arch ISO image, partition the harddrive, and format the partitions. Simultaneously, on a second system with up-to-date Arch Linux, I copy all packages from /var/cache/pacman/pkg to a USB drive.

Back on the to-be-installed system, I do the following:

1. Mount the file systems

mount /dev/sda1 /mnt
mkdir /mnt/home/
mount /dev/sda3 /mnt/home

2. Mount the USB drive (/dev/sdg2) to the destination pacman directory

mkdir -p /mnt/var/cache/pacman/pkg
mount /dev/sdg2 /mnt/var/cache/pacman/pkg

However, when I now attempt to pacstrap the base group, pacstrap attempts to retrieve the packages of base from the Arch mirrors (which evidently fails given the missing internet connection) and does not take the local copies.

---
As an alternative route towards installing the base group, I thought about arch-chroot into /mnt first, and then installing the local packages through pacman -U. However, that is met with the problem that I cannot arch-chroot into /mnt:

root@archiso ~ # arch-chroot /mnt
mount: /mnt/proc: mount point does not exist.
==> ERROR: failed to setup chroot /mnt.

---

Thus, how can I install the base group to my to-be-installed system and continue with the Arch Linux installation?

Last edited by Michael Gruenstaeudl (2017-08-30 09:50:35)

Offline

#2 2017-08-29 08:47:33

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,006

Re: [Solved] Offline system install - How to pacstrap base from local pkgs

https://wiki.archlinux.org/index.php/Pa … _USB_stick read this and the section below it

Offline

#3 2017-08-29 09:45:18

Michael Gruenstaeudl
Member
Registered: 2014-12-03
Posts: 47

Re: [Solved] Offline system install - How to pacstrap base from local pkgs

@V1del

As per your recommendation, I read through the relevant sections regarding installing packages from a USB stick and followed the described steps:

1. Made a custom local repository that includes base, base-devel and grub-bios:

pacman -Syw base base-devel grub-bios --cachedir .
repo-add ./custom.db.tar.gz ./*

2. Mounted the USB:

mkdir /mnt/repo
mount /dev/sdh1 /mnt/repo

3. Edited /etc/pacman.conf as described, plus I comment out the entries for core, extra and community in /etc/pacman.conf.

Note: If I did not comment out the entries for core, extra and community in /etc/pacman.conf, pacstrap would again attempt to look for the repositories online.

Now, when I then try to pacstrap base from the custom repository, pacstrap cannot resolve the respective dependencies:

pacstrap /mnt base
...
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bzip2"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "bzip2"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "coreutils"
warning: cannot resolve "acl", a dependency of "coreutils"
warning: cannot resolve "attr", a dependency of "coreutils"
warning: cannot resolve "gmp", a dependency of "coreutils"
warning: cannot resolve "libcap", a dependency of "coreutils"
warning: cannot resolve "openssl", a dependency of "coreutils"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "device-mapper"
warning: cannot resolve "libsystemd", a dependency of "device-mapper"
warning: cannot resolve "device-mapper", a dependency of "cryptsetup"
warning: cannot resolve "libgcrypt", a dependency of "cryptsetup"
warning: cannot resolve "popt", a dependency of "cryptsetup"
warning: cannot resolve "libutil-linux", a dependency of "cryptsetup"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "device-mapper"
warning: cannot resolve "libsystemd", a dependency of "device-mapper"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "dhcpcd"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "dhcpcd"
warning: cannot resolve "udev", a dependency of "dhcpcd"
warning: cannot resolve "libsystemd", a dependency of "dhcpcd"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "diffutils"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "diffutils"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "e2fsprogs"
warning: cannot resolve "libutil-linux", a dependency of "e2fsprogs"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "file"
warning: cannot resolve "zlib", a dependency of "file"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "findutils"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "findutils"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "gawk"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "gawk"
warning: cannot resolve "mpfr", a dependency of "gawk"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc>=2.25", a dependency of "gcc-libs"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc>=2.25", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "gettext"
warning: cannot resolve "acl", a dependency of "gettext"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "gettext"
warning: cannot resolve "glib2", a dependency of "gettext"
warning: cannot resolve "libunistring", a dependency of "gettext"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "grep"
warning: cannot resolve "pcre", a dependency of "grep"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "gzip"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "gzip"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "less"
warning: cannot resolve "ncurses", a dependency of "less"
warning: cannot resolve "pcre", a dependency of "less"
warning: cannot resolve "less", a dependency of "gzip"
warning: cannot resolve "pam", a dependency of "inetutils"
warning: cannot resolve "libcap", a dependency of "inetutils"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "iproute2"
warning: cannot resolve "iptables", a dependency of "iproute2"
warning: cannot resolve "libelf", a dependency of "iproute2"
warning: cannot resolve "openssl", a dependency of "iputils"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "sysfsutils"
warning: cannot resolve "sysfsutils", a dependency of "iputils"
warning: cannot resolve "libcap", a dependency of "iputils"
warning: cannot resolve "libidn", a dependency of "iputils"
warning: cannot resolve "pam", a dependency of "util-linux"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "shadow"
warning: cannot resolve "pam", a dependency of "shadow"
warning: cannot resolve "acl", a dependency of "shadow"
warning: cannot resolve "shadow", a dependency of "util-linux"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "coreutils"
warning: cannot resolve "acl", a dependency of "coreutils"
warning: cannot resolve "attr", a dependency of "coreutils"
warning: cannot resolve "gmp", a dependency of "coreutils"
warning: cannot resolve "libcap", a dependency of "coreutils"
warning: cannot resolve "openssl", a dependency of "coreutils"
warning: cannot resolve "coreutils", a dependency of "util-linux"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libcap-ng", a dependency of "util-linux"
warning: cannot resolve "libutil-linux", a dependency of "util-linux"
warning: cannot resolve "util-linux", a dependency of "jfsutils"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "less"
warning: cannot resolve "ncurses", a dependency of "less"
warning: cannot resolve "pcre", a dependency of "less"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "coreutils"
warning: cannot resolve "acl", a dependency of "coreutils"
warning: cannot resolve "attr", a dependency of "coreutils"
warning: cannot resolve "gmp", a dependency of "coreutils"
warning: cannot resolve "libcap", a dependency of "coreutils"
warning: cannot resolve "openssl", a dependency of "coreutils"
warning: cannot resolve "coreutils", a dependency of "linux"
warning: cannot resolve "linux-firmware", a dependency of "linux"
warning: cannot resolve "kmod", a dependency of "linux"
warning: cannot resolve "mkinitcpio>=0.7", a dependency of "linux"
warning: cannot resolve "popt", a dependency of "logrotate"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "gzip"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "gzip"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "less"
warning: cannot resolve "ncurses", a dependency of "less"
warning: cannot resolve "pcre", a dependency of "less"
warning: cannot resolve "less", a dependency of "gzip"
warning: cannot resolve "gzip", a dependency of "logrotate"
warning: cannot resolve "acl", a dependency of "logrotate"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "lvm2"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "device-mapper"
warning: cannot resolve "libsystemd", a dependency of "device-mapper"
warning: cannot resolve "device-mapper>=2.02.173", a dependency of "lvm2"
warning: cannot resolve "libsystemd", a dependency of "lvm2"
warning: cannot resolve "readline", a dependency of "lvm2"
warning: cannot resolve "thin-provisioning-tools", a dependency of "lvm2"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "man-db"
warning: cannot resolve "gdbm", a dependency of "man-db"
warning: cannot resolve "zlib", a dependency of "man-db"
warning: cannot resolve "gdbm", a dependency of "perl"
warning: cannot resolve "db", a dependency of "perl"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "perl"
warning: cannot resolve "perl", a dependency of "groff"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc>=2.25", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "groff"
warning: cannot resolve "groff", a dependency of "man-db"
warning: cannot resolve "libpipeline", a dependency of "man-db"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "less"
warning: cannot resolve "ncurses", a dependency of "less"
warning: cannot resolve "pcre", a dependency of "less"
warning: cannot resolve "less", a dependency of "man-db"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "mdadm"
warning: cannot resolve "ncurses", a dependency of "nano"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "file"
warning: cannot resolve "zlib", a dependency of "file"
warning: cannot resolve "file", a dependency of "nano"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "nano"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "coreutils"
warning: cannot resolve "acl", a dependency of "coreutils"
warning: cannot resolve "attr", a dependency of "coreutils"
warning: cannot resolve "gmp", a dependency of "coreutils"
warning: cannot resolve "libcap", a dependency of "coreutils"
warning: cannot resolve "openssl", a dependency of "coreutils"
warning: cannot resolve "coreutils", a dependency of "netctl"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "iproute2"
warning: cannot resolve "iptables", a dependency of "iproute2"
warning: cannot resolve "libelf", a dependency of "iproute2"
warning: cannot resolve "iproute2", a dependency of "netctl"
warning: cannot resolve "openresolv", a dependency of "netctl"
warning: cannot resolve "systemd>=233", a dependency of "netctl"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "pacman"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "pacman"
warning: cannot resolve "libarchive", a dependency of "pacman"
warning: cannot resolve "curl", a dependency of "pacman"
warning: cannot resolve "gpgme", a dependency of "pacman"
warning: cannot resolve "pacman-mirrorlist", a dependency of "pacman"
warning: cannot resolve "archlinux-keyring", a dependency of "pacman"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "pciutils"
warning: cannot resolve "hwids", a dependency of "pciutils"
warning: cannot resolve "kmod", a dependency of "pciutils"
warning: cannot resolve "systemd", a dependency of "pcmciautils"
warning: cannot resolve "gdbm", a dependency of "perl"
warning: cannot resolve "db", a dependency of "perl"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "perl"
warning: cannot resolve "ncurses", a dependency of "procps-ng"
warning: cannot resolve "libsystemd", a dependency of "procps-ng"
warning: cannot resolve "ncurses", a dependency of "psmisc"
warning: cannot resolve "pam", a dependency of "util-linux"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "shadow"
warning: cannot resolve "pam", a dependency of "shadow"
warning: cannot resolve "acl", a dependency of "shadow"
warning: cannot resolve "shadow", a dependency of "util-linux"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "coreutils"
warning: cannot resolve "acl", a dependency of "coreutils"
warning: cannot resolve "attr", a dependency of "coreutils"
warning: cannot resolve "gmp", a dependency of "coreutils"
warning: cannot resolve "libcap", a dependency of "coreutils"
warning: cannot resolve "openssl", a dependency of "coreutils"
warning: cannot resolve "coreutils", a dependency of "util-linux"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libcap-ng", a dependency of "util-linux"
warning: cannot resolve "libutil-linux", a dependency of "util-linux"
warning: cannot resolve "util-linux", a dependency of "reiserfsprogs"
warning: cannot resolve "openssl", a dependency of "s-nail"
warning: cannot resolve "krb5", a dependency of "s-nail"
warning: cannot resolve "libidn", a dependency of "s-nail"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "sed"
warning: cannot resolve "acl", a dependency of "sed"
warning: cannot resolve "attr", a dependency of "sed"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "shadow"
warning: cannot resolve "pam", a dependency of "shadow"
warning: cannot resolve "acl", a dependency of "shadow"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "sysfsutils"
warning: cannot resolve "systemd", a dependency of "systemd-sysvcompat"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "tar"
warning: cannot resolve "acl", a dependency of "tar"
warning: cannot resolve "attr", a dependency of "tar"
warning: cannot resolve "ncurses", a dependency of "texinfo"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "gzip"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "gzip"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "less"
warning: cannot resolve "ncurses", a dependency of "less"
warning: cannot resolve "pcre", a dependency of "less"
warning: cannot resolve "less", a dependency of "gzip"
warning: cannot resolve "gzip", a dependency of "texinfo"
warning: cannot resolve "gdbm", a dependency of "perl"
warning: cannot resolve "db", a dependency of "perl"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "perl"
warning: cannot resolve "perl", a dependency of "texinfo"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "texinfo"
warning: cannot resolve "libusb", a dependency of "usbutils"
warning: cannot resolve "hwids", a dependency of "usbutils"
warning: cannot resolve "pam", a dependency of "util-linux"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "shadow"
warning: cannot resolve "pam", a dependency of "shadow"
warning: cannot resolve "acl", a dependency of "shadow"
warning: cannot resolve "shadow", a dependency of "util-linux"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "coreutils"
warning: cannot resolve "acl", a dependency of "coreutils"
warning: cannot resolve "attr", a dependency of "coreutils"
warning: cannot resolve "gmp", a dependency of "coreutils"
warning: cannot resolve "libcap", a dependency of "coreutils"
warning: cannot resolve "openssl", a dependency of "coreutils"
warning: cannot resolve "coreutils", a dependency of "util-linux"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libcap-ng", a dependency of "util-linux"
warning: cannot resolve "libutil-linux", a dependency of "util-linux"
warning: cannot resolve "ncurses", a dependency of "vi"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "which"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "which"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "tzdata", a dependency of "glibc"
warning: cannot resolve "iana-etc", a dependency of "filesystem"
warning: cannot resolve "filesystem", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "xfsprogs"
warning: cannot resolve "libutil-linux", a dependency of "xfsprogs"
warning: cannot resolve "readline", a dependency of "xfsprogs"
error: failed to prepare transaction (could not satisfy dependencies)

:: The following packages cannot be upgraded due to unresolvable dependencies:
...
==> ERROR: Failed to install packages to new root

Last edited by Michael Gruenstaeudl (2017-08-29 10:17:55)

Offline

#4 2017-08-29 10:15:28

mcmillan
Member
Registered: 2006-04-06
Posts: 729

Re: [Solved] Offline system install - How to pacstrap base from local pkgs

Looks like those are dependencies for base packages, but aren't in base itself. You'll need to include those in your local repository as well. (note that sh is provided by bash, so that will be available once it is installed with ncurses)

Offline

#5 2017-08-29 10:23:20

Michael Gruenstaeudl
Member
Registered: 2014-12-03
Posts: 47

Re: [Solved] Offline system install - How to pacstrap base from local pkgs

@mcmillan
Actually, the seemingly unresolved packages are all part of base (https://www.archlinux.org/groups/i686/base/). The problem is that they are unresolved vice versa. I believe the problem has actually something to do with the fact that I commented out the entries for core, extra and community in /etc/pacman.conf.

Offline

#6 2017-08-29 10:28:38

Alad
Wiki Admin/IRC Op/TU
From: Bagelstan
Registered: 2014-05-04
Posts: 2,030
Website

Re: [Solved] Offline system install - How to pacstrap base from local pkgs

Just copy over everything from the ISO

https://wiki.archlinux.org/index.php/Ar … net_access


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby
Honest Alad's Package Emporium—Now with added bugs! (Grand reopening: December 1st 2018)

Offline

#7 2017-08-29 13:33:58

Michael Gruenstaeudl
Member
Registered: 2014-12-03
Posts: 47

Re: [Solved] Offline system install - How to pacstrap base from local pkgs

@Alad
Thank you for this recommendation. Installing the Archiso as explained on the ArchWiki (https://wiki.archlinux.org/index.php/Ar … net_access) was indeed the simplest solution.

---

For those curious on the precise steps I had to take to offline-install Arch Linux, here is a run-down:

# Partition the disks

cfdisk /dev/sda

# Format the partitions

mkfs.ext4 /dev/sda1
mkfs.ext4 /dev/sda3

# [Needed ?]

mkswap /dev/sda2
swapon /dev/sda2

# Mount the file systems

mount /dev/sda1 /mnt
mkdir /mnt/home
mount /dev/sda3 /mnt/home

# Install the archiso to the new root

time cp -ax / /mnt
cp -vaT /run/archiso/bootmnt/arch/boot/x86_64/vmlinuz /mnt/boot/vmlinuz-linux

# Generate an fstab

genfstab -p /mnt >> /mnt/etc/fstab

# Chroot into your newly installed system

arch-chroot /mnt /bin/bash

# Restore the configuration of journald (taken from https://wiki.archlinux.org/index.php/Ar … net_access)

sed -i 's/Storage=volatile/#Storage=auto/' /etc/systemd/journald.conf 

# Remove special udev rule (taken from https://wiki.archlinux.org/index.php/Ar … net_access)

rm /etc/udev/rules.d//81-dhcpcd.rules 

# Disable and remove the services created by archiso (taken from https://wiki.archlinux.org/index.php/Ar … net_access)

systemctl disable pacman-init.service choose-mirror.service
rm -r /etc/systemd/system/{choose-mirror.service,pacman-init.service,etc-pacman.d-gnupg.mount,getty@tty1.service.d}
rm /etc/systemd/scripts/choose-mirror

# Remove special scripts of the Live environment (taken from https://wiki.archlinux.org/index.php/Ar … net_access)

rm /etc/systemd/system/getty@tty1.service.d/autologin.conf
rm /root/{.automated_script.sh,.zlogin}
rm /etc/mkinitcpio-archiso.conf 
rm -r /etc/initcpio/

# Import archlinux keys

pacman-key --init
pacman-key --populate archlinux

# Set hosts and hostname

echo "myhostname" > /etc/hostname
nano /etc/hosts

# Initramfs

mkinitcpio -p linux

# Set root password

passwd

# Install boot loader

grub-install --target=i386-pc --recheck /dev/sda
# grub-install --target=i386-pc --recheck --force /dev/sda # was necessary
cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo
grub-mkconfig -o /boot/grub/grub.cfg

Last edited by Michael Gruenstaeudl (2017-08-30 10:24:43)

Offline

Board footer

Powered by FluxBB