You are not logged in.

#1 2015-07-01 10:07:54

jhemp
Member
From: Luxembourg
Registered: 2015-07-01
Posts: 5

[SOLVED] Unable to run mksdcard SDK tool.

Hello,

When I was installing Android Studio, I came across the error: Unable to run mksdcard SDK tool, when I was downloading the required components.
There is no other information about what is going wrong. Googling the problem is leading me to solutions for Ubuntu-based distributions, which apparently do not work for Arch. I already tried Java 7 and 8, no change.
Surprisingly on all my prior Arch installations, that error didn't show up.
Or am I missing some trivial packages?^^

Thanks in advance!

Last edited by jhemp (2015-07-01 17:50:44)

Offline

#2 2015-07-01 11:19:20

Awebb
Member
Registered: 2010-05-06
Posts: 4,914

Re: [SOLVED] Unable to run mksdcard SDK tool.

Details. How did you install it? This one? https://aur4.archlinux.org/packages/android-studio/

Offline

#3 2015-07-01 14:54:03

jhemp
Member
From: Luxembourg
Registered: 2015-07-01
Posts: 5

Re: [SOLVED] Unable to run mksdcard SDK tool.

I always installed it via the zip-file from http://developer.android.com and simply executed the studio.sh file.
But now I got it installed with yaourt, but that was problematic as well, some dependencies like lib32-mesa couldn't be loaded, so I had to simply enable the multlib repositories for 32bit stuff.
I don't know if the latter was crucial for the "traditional" way, but I hope I could help someone else.

Offline

#4 2016-01-13 06:42:38

kolla
Member
Registered: 2015-09-21
Posts: 4

Re: [SOLVED] Unable to run mksdcard SDK tool.

Hello ,
I've got the same error.So I  tried to install through yaourt but curl is giving error.

""curl error: Couldn't resolve host name
error: target not found: android-studio"""

PS: mutlib is enabled already.

Last edited by kolla (2016-01-13 06:44:21)

Offline

#5 2017-08-30 01:50:10

gcb
Member
Registered: 2014-02-12
Posts: 7

Re: [SOLVED] Unable to run mksdcard SDK tool.

Yep, not solved unfortunately.

Not sure what solved for OP. but yaourt repo is broken. No way to install from there. And the regular way, directly from google, the mksdcard tool will not run.

I do not even know who to debug this.

$ file mksdcard
mksdcard: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=119b9b83c17fa0228acfd582e951ea8b050e1229, not stripped

it is an executable just fine.

$ ls -lah
total 1.7M
drwxr-xr-x  6 gcb gcb 4.0K Aug 29 18:37 .
drwxr-xr-x 12 gcb gcb 4.0K Aug 29 18:30 ..
-rwxr-xr-x  1 gcb gcb 4.7K Aug 29 18:23 android
drwxr-xr-x  2 gcb gcb 4.0K Aug 29 18:23 bin
-rwxr-xr-x  1 gcb gcb 629K Aug 29 18:23 emulator
-rwxr-xr-x  1 gcb gcb 386K Aug 29 18:23 emulator-check
drwxr-xr-x  6 gcb gcb 4.0K Aug 29 18:23 lib
-rwxr-xr-x  1 gcb gcb  12K Aug 29 18:23 mksdcard
-rwxr-xr-x  1 gcb gcb 1.3K Aug 29 18:23 monitor
-rw-r--r--  1 gcb gcb 615K Aug 29 18:23 NOTICE.txt
-rw-r--r--  1 gcb gcb  18K Aug 29 18:23 package.xml
drwxr-xr-x  7 gcb gcb 4.0K Aug 29 18:23 proguard
-rw-r--r--  1 gcb gcb  139 Aug 29 18:23 source.properties
drwxr-xr-x  2 gcb gcb 4.0K Aug 29 18:23 support

Has ok permissions. Same as ./android which executes fine.

$ df -h .
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda4       211G   82G  126G  40% /

It is not in any weird FS with exec flag disable or something.

$ ./mksdcard 2G sd.img
bash: ./mksdcard: No such file or directory

yet I cannot execute it.

Offline

#6 2017-08-30 07:31:03

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,009

Re: [SOLVED] Unable to run mksdcard SDK tool.

You likely lack multilib packages, read the comments on https://aur.archlinux.org/packages/android-studio/ for more info on what exactly.

Either way, this topic is old, don't necrobump and make sure to wrap command output into [ code ] tags in the future. Should you run into future issues despite reading the AUR comments create your own thread.

Closing.

Offline

Board footer

Powered by FluxBB