You are not logged in.

#1 2017-09-12 16:49:53

Registered: 2017-09-12
Posts: 2

Chrome fonts not being rendered [SOLVED]

Long time listener, first time caller.

Yesterday after rebooting chrome begin both not rendering any font in the UI and not rendering any spaces in the browser. I've tried uninstalling and re-installing all my custom fonts, running `fc-cache -fv` about 1000 times, uninstalling and reinstalling every flavor of chrome I can imagine, and still nothing has worked.

Any tips would be greatly appreciated. (I've spent all day searching for issues similar to this and have found nothing).

Mod note: converted img to url. Please see the Code of Conduct regarding acceptable image sizes. -- WorMzy

Edit: Figured out the problem!

It turns out, the issue was 100% because of the emoji config in my /etc/fonts/conf.d folder.

The instructions that I used to originally enable color emoji for Github are located here: and they are no longer accurate!

The noto-color-emoji package in AUR now provides a preloaded config that enables fallback emoji support for sites that need it (on github, for example). That is the recommended way to enable them now.

In other words, instead of following the instructions in that issue thread, do this...

$ cd /etc/fonts/conf.d
$ sudo ln -s ../conf.avail/66-noto-color-emoji.conf

Once that's done, you should be all set!

Last edited by dsifford (2017-09-15 00:43:07)


#2 2017-09-12 21:54:34

Registered: 2013-12-22
Posts: 6

Re: Chrome fonts not being rendered [SOLVED]

Weird. It only happens with Chrome?
What font is that?

Maybe you should try these.

* Erase the Google Chrome cache in .cache/ folder.
* Check or delete any custom config files in /etc/fonts and .config/fontconfig/ folders
* Reinstall fontconfig package
* Reinstall freetype2 package
* Install Chromium and see if this happens (maybe bug with Chrome?)


Last edited by e_benitez_soria (2017-09-12 21:55:39)


#3 2017-09-12 23:03:38

Registered: 2017-09-12
Posts: 2

Re: Chrome fonts not being rendered [SOLVED]

@e_benitez_soria Thanks for the recommendations!

I began working through some of your suggestions and, in the middle of doing so, I noticed that chrome had an update available in AUR.

I stopped midway through (after clearing out cache) and gave the update a whirl and lo and behold, either your suggestions or the update fixed it!

I'm gonna go ahead and just give you the credit for this one smile

Thanks for your hospitality!

(@mod -- I'm not sure how to mark this as resolved. Apologies if I missed something. I'm all set!)


To those who may see this in the future: One weird thing that I did notice is that in my /etc/fonts/conf.d/ folder, for some reason I had the noto font config waaaaaaaaaaaaaaaaaaaaaay at the top, and all that the file specified was emojis? (I believe the filename was 00-noto-font.conf or something). I cleared that one out too because I have no idea how that got there!


#4 2017-09-12 23:17:50

Registered: 2014-03-06
Posts: 16,525

Re: Chrome fonts not being rendered [SOLVED]

dsifford wrote:

(@mod -- I'm not sure how to mark this as resolved. Apologies if I missed something. I'm all set!)

You can mark the thread as solved by editing you first post and prepending [SOLVED] to the title.


Board footer

Powered by FluxBB