You are not logged in.

#1 2017-09-13 17:14:15

Registered: 2014-02-28
Posts: 81

[SOLVED] EFI partion not bootable on SSD

I needed to reinstall Arch from scratch as I found errors on my file system and I got system corrupted.
I ran badblock with destructive write test to check disk and I got no errors so I decided to try to reinstall on the same SSD (NVMe).
I followed the Arch wiki for the installation.

I booted from live USB in UEFI mode and partitioned my disk as follow (GPT partition table):

Device                                   Start   End            Sectors    Size      Type
/dev/nvme0n1p1                   2048   1050623    1048576   512M   EFI System
/dev/nvme0n1p2                                                                   16G   Linux Swap
/dev/nvme0n1p3                                                                    32G  Linux filesystem
/dev/nvme0n1p4                                                                  428G  Linux filesystem

Partition 3 is mounted as /, partition 4 as /home and partition 2 is mounted as /boot

Then I arch-chrooted into /mnt and installed grub on /boot partition

Now /boot contains:

  -- EFI
     -- grub
        -- grubx64.efi
  -- grub
       -- fonts
       -- grub.cfg
       -- grub.cfg.example
       -- grubenv
       -- locale
       -- themes
       -- x86_64-efi
  -- initramfs-linux-fallback.img
  -- initramfs-linux.img
  -- vmlinuz-linux

But the disk is not shown as a bootable in UEFI mode.
Any idea? (PLZ help!)

Last edited by lviggiani (2017-09-21 07:38:52)


#2 2017-09-13 19:46:55

From: Sweden
Registered: 2015-06-06
Posts: 736

Re: [SOLVED] EFI partion not bootable on SSD

You should mount p1 to boot, p2 as swap, p3 / and p4 home perhaps?

E: post your fstab please

Last edited by dockland (2017-09-13 19:47:33)

I possess a device, in my pocket, that is capable of accessing the entirety of information known to man.
I use it to look at funny pictures of cats and to argue with strangers.


#3 2017-09-21 07:38:30

Registered: 2014-02-28
Posts: 81

Re: [SOLVED] EFI partion not bootable on SSD

...well it was my mistake... I've been using fdisk to create partitions on GPT instead of gdisk. Switching to gdisk and reinstalling did the trick.

Last edited by lviggiani (2017-09-21 07:39:40)


Board footer

Powered by FluxBB