You are not logged in.

#1 2017-09-12 14:57:58

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 44

[SOLVED] Some KWin shortcuts not working

Commands that move windows around do not work for me anymore. For example, I've attached keybindings to KWin commands "Pack Window Down/Left/Right/Up" and "Window One Desktop Down/Left/Right/Up", but pressing those keys has no effect. The problem is a few days old and I don't believe I broke anything myself. All I do is run pacman -Syu regularly. Can anyone confirm this issue?

Last edited by raul_l (2017-09-14 14:10:48)


Raul Laasner
Duke University

Offline

#2 2017-09-12 15:46:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 2,687

Re: [SOLVED] Some KWin shortcuts not working

Can confirm, might be something in frameworks 5.38. Don't have the time to dig deeper currently.

There's already a report about it: https://bugs.kde.org/show_bug.cgi?id=384597

Last edited by V1del (2017-09-13 11:30:23)

Online

#3 2017-09-14 01:26:26

JadElClemens
Member
Registered: 2014-02-11
Posts: 8

Re: [SOLVED] Some KWin shortcuts not working

Yup, I'm having the same issue. Seems like anything with shift+[arrow key] isn't working, as my meta+shift+{i,j,k,l} shortcuts work just fine but shift+{ctrl,alt}+[arrow key] don't. I'm on Plasma 5.10.5

If it's relevant to anyone here:
In trying to trace down the issue I noticed that xev reports that FocusIn and FocusOut events are generated when I try these shortcuts (and not when other valid shortcuts are pressed). When the shortcuts are unset, the system responds as if only the arrow keys are pressed if the key combo is pressed but not registered.

Offline

#4 2017-09-14 01:36:32

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 44

Re: [SOLVED] Some KWin shortcuts not working

The problem appears to be in kglobalaccel. More info here.
(EDIT: I just saw the update in post #2.)

Last edited by raul_l (2017-09-14 01:38:46)


Raul Laasner
Duke University

Offline

Board footer

Powered by FluxBB